kubernetes/kops

Documented errors, page 5 of 33. Back to kubernetes/kops

Code / MessageTypeSeverityTags
assetsLocation.fileRepository must be set to remap asset
validation error go, assets, configuration, kops
error instance group cannot span public and private subnets
exception error kops, subnets, topology, validation
error parsing Akamai (Linode)
exception error linode, akamai, id-parsing, state-store
failed to get region from ec2 metadata
exception error go, aws, ec2, imds, network, bootstrap
failed to parse kubernetes version
exception error kubernetes, version-parsing, semver, kops
failed to serialize kops-controller config
exception error json, serialization, template-function
getting info for network interface
exception error
path is not cluster readable
validation error aws, s3, vfs, kops, unsupported-backend
subnet not found in network
exception error openstack, subnet, cluster-creation, configuration
AttachDetachReconcileSyncPeriod cannot be set to less than…
validation error kube-controller-manager, configuration, validation, duration
deadline exceeded executing task
exception error
error revoking SecurityGroupEgress
exception error aws, ec2, security-group, revoke-egress
found multiple SecurityGroups with name
exception error openstack, security-group, neutron, duplicate-resources
instance was launched with a resource-based hostname…
validation error aws, hostname, configuration, nodeup
--name is required
validation error cli, kops, cluster-name, missing-flag
policy size was . Policy cannot exceed 10240 bytes
validation error aws, iam, policy-size-limit, quota
cannot determine challenge endpoint for server
exception error hetzner, networking, bootstrap
cannot parse network name
error_code error gce, network, configuration, parsing
cloud %T does not expose Azure subscription ID
exception error
cluster is not an Azure cluster
validation error azure, cluster-config, validation, cloud-provider
duplicate data source found
exception error terraform, data-sources, kops, internal
error loading cluster addon
exception error cli, addons, file-parsing
error marshaling authentication config to yaml
exception error
failed to parse loadbalancer ID
exception error azure, vmss, loadbalancer, resource-id
failed to register instance from targetGroups
exception error aws, elbv2, target-group, drain
%s: %v
exception error go, error-wrapping, asset-copy, concurrency
write to with ACL of unexpected type %T
exception error gcs, acl, type-error, kops, golang
calling IAM GetInstanceProfile on
exception error aws, iam
Cannot determine host
http warning http, oidc, host-header, proxy
error deleting
exception error aws, s3, delete, permissions
error fetching DNS HostedZone
error_code error aws, route53, dns, api-error
error parsing
exception warning json, cache, parsing
failed to get metadata URL
exception error digitalocean, metadata-service, http-request, network, kops
failed to parse subnet ID
exception error azure, vmss, resource-id, parsing
parsing reference
exception error container-image, input-validation, image-reference
unable to marshal JSON
console error json, serialization, cli-output
unable to parse instance url
exception error gce, url-parsing, dump
waiting for load-balancer
exception error scaleway, load-balancer, deletion, timeout
waiting for VMSS deletion completion
exception error azure, vmss, delete, long-running-operation, timeout
creating/updating virtual network
exception error azure, go, network, vnet
error listing machines
exception error clusterapi, kubernetes, rbac, list-machines, kops
EtcdMember # of etcd-cluster did not specify a Name
validation error etcd, cluster-spec, validation
no fetched intermediate certificates matched signer issuer
exception error azure, tls, certificates, aia, chain-mismatch
unable to resolve Kubernetes cluster API URL dns
exception error go, dns, network, kops, validation
unexpected number of access configs in template
exception error gce, instance-template, access-config, external-ip, unsupported-config
unexpected number of network interfaces for instance
exception error aws, ec2, eni, ipv6
unhandled LoadBalancer type
validation error kops, digitalocean, load-balancer, configuration
challenge not set
exception error bootstrap, challenge, nodeup, validation
error creating PoolMonitor
exception error openstack, load-balancer, octavia
invalid channel location
validation error channel, url-parsing, configuration
error checking if configuration file
exception error vfs, state-store, storage
error dialing target
exception error grpc, network, tls, dial
error getting
exception error
error listing nodes in cluster
error_code error kubernetes, api-server, network, rolling-update
error remapping images
exception error assets, image-remapping, manifest
expected exactly one subnet for InstanceGroup
validation error linode, instancegroup, subnet, configuration
failed to copy image
exception error container-image, registry, push, network
Failed to list L3 floating ip
exception error openstack, neutron, floating-ip, list, retry
getting control plane VMSS name for API ingress status
exception error azure, vmss, tags, control-plane
invalid google cloud URL (content after name)
exception error gce, url-parsing, validation
listing VMSS VMs
exception error azure, vmss, pagination, throttling, error-wrapping
reading Docker config
console error
reading embedded file
exception error embedded-files, filesystem, kops
rendering Azure Blob file
exception error azure, terraform, vfs, rendering
addon manifest did not have a spec
exception error addons, bootstrap-channel, validation
couldn't open DNS provider configuration
exception error dns-provider, configuration, file-io
escaping nodeup source
exception error nodeup, url-parsing, bootstrap
must configure at least one Node InstanceGroup
exception error kops, validation, instancegroup, cluster-spec
Path is not a child of
exception error
duplicate variable
exception error terraform, outputs, kops, internal
error building glance client
exception error openstack, glance, endpoint, service-catalog, gophercloud
error building secret store path
exception error nodeup, vfs, secretstore, path-parsing
error querying bucket
exception error gcp, gcs, permissions, storage
error unmarshaling subobject
exception error go, yaml, deserialization, kubemanifest
evictionHard
exception error kubelet, eviction, config-parsing
kOps IPAM controller not supported on cloud
exception error ipam, ipv6, cloud-provider, nodeup
no InstanceGroup objects found
exception error kops, instancegroups, state-store, cli, validation
not a directory
exception error ssh, sftp, filesystem, path-conflict
parsing ip address (bound to network )
exception error
unable to find secret
exception error vfs, secrets, race-condition, mirror
DNS ZoneID not set
validation error aws, route53, dns, kops
error building ssh key
exception error aws, ssh, spotinst, cluster-updates
error deleting ENI
exception error aws, ec2, eni, deletion
error doing DNS lookup for NS records for
exception error dns, network, validation
error querying droplet metadata
error_code error
error updating LaunchTemplate tags
exception error aws, ec2, launch-template, tags
failed to loadbalancer ACTIVE provisioning status
exception error openstack, octavia, provisioning-status, timeout
label not set on
exception error kubernetes, cluster-api, labels, reconcile
no keypair ID for
validation error go, nodeup, keypair, config
rewriting channels manifest
exception error go, yaml, kubernetes, manifest, enrollment
serializing completed cluster spec
exception error serialization, yaml, cluster-spec
spotinst: found multiple role tags
exception error spotinst, aws, iam-roles, tags, validation
unknown InstanceGroup Role
validation error kops, instance-group, volume-size, roles
creating directories
exception error otel, filesystem, permissions
did not find PKI volume
exception error etcd-manager, pki, pod-volumes
error attaching InternetGateway to VPC
exception error aws, ec2, internet-gateway, vpc, networking
error dumping
exception error dump, toolbox, debugging
error during file write of
exception error filesystem, vfs, rename
error setting resources
exception error pki, keystore, serialization
HeadBucket on did not return a bucket region
exception error