kubernetes/kops

Documented errors, page 17 of 33. Back to kubernetes/kops

Code / MessageTypeSeverityTags
field in was not an object, was %T
exception error manifest, type-mismatch, path-navigation
listing resource groups
exception error azure, resource-groups, pagination, error-wrapping
parsing STS request URL
exception error
server-side client does not support MirrorTo
exception error keystore, read-only, unsupported-operation, vfs
timed out waiting for volume to detach
error_code error aws, ec2, launch-template, rolling-update
unexpected amount of ipv6 prefixes on interface
exception error aws, ec2, ipv6, prefix-delegation
unexpected error resolving task
exception error
creating identity
exception error azure, authentication, credentials, azidentity
error checking GCS bucket IAM for gs://
exception error gcs, gcp, storage, iam, policy, api-error
error creating Akamai (Linode) VPC
exception error linode, vpc, create, api-error, kops
error doing systemd daemon-reload
console error nodeup, systemd, daemon-reload, exec
error listing SQS queues
exception error aws, sqs, list-queues, iam
error listing VPCs
exception error aws, ec2, vpc, api-error
error querying for address
exception error gce, address, api-error
error serializing addons yaml
exception error yaml, serialization, addons, kops
failed to find cluster dns zone
exception error openstack, designate, dns, zone-lookup, configuration
failed to find instance group of resource
exception error
failed to find ssh keys for server group
exception error hetzner, ssh, servergroup, config, validation
invalid path in s3fs tree
exception error s3, type-assertion, vfs, internal
network not found
exception error openstack, neutron, network, not-found, cluster-creation
parsing PKCS7 signature
exception error azure, pkcs7, asn1, attestation
removing targets for EventBridge rule
exception error aws, eventbridge, deletion
unable to determine gcp region for cluster
exception error gcp, clusterapi, region
unexpected access type in template
exception error gce, instance-template, access-config, network
unexpected key name
exception error certificates, configuration, bootstrap
upgrade is not for use with imported clusters.)
exception error
Address had no IP
exception error gce, load-balancer, address, state
can't build elastigroup while nodeTerminationHandler flag…
validation error
cannot set more than one CIDR or IPv6CIDR
validation error aws, route, validation, ipv6
creating client for Scaleway NodeIdentifier
exception error scaleway, node-identity, api-client, configuration
error deleting SSH public key
exception error cli, ssh, state-store
error during chmod of
exception error ssh, sftp, permissions, chmod
error finding Address with IP=
exception error gce, load-balancer, address, api-error
error getting instance group for doGroup
error_code error
error parsing InstanceGroup
exception error yaml, parsing, cli
error parsing version
exception error kops, channel, version-parsing, semver
error removing tags from ELBV2
exception error aws, elbv2, tags
error writing SSL PrivateKey
exception error pki, serialization, private-key
failed to prune objects of kind
exception error prune, kubernetes, addon, cleanup
instance role profile with id
exception error aws, iam, instance-profile, configuration
no zones found for instance group
exception error gce, autoscaler, zones, config
removing destination sftp file
exception error ssh, sftp, permissions, file-delete
serving readiness probe
exception critical http-server, port-conflict, daemon, readiness-probe
unsupported resource type
exception error
error creating SSH keypair
exception error
error detaching InternetGateway
exception error aws, ec2, internet-gateway, detach, vpc
Error Details
exception error
error getting instance from metadata
error_code error
error listing Backend Services
exception error
error listing volumes
error_code error aws, ec2, ebs
error rendering server group
exception error
error updating Healthcheck
exception error gce, http-health-check, update, cloud-api
failed to initialize the node controller, error
console error dns-controller, kubernetes, initialization
failed to read
exception error nodeup, linode, fstab, filesystem
field in not found
exception error manifest, path-navigation, go
invalid networking option
validation error networking, topology, kubenet, compatibility
must specify label with cluster name to replace…
validation error kops, sshcredential, validation, manifest, labels
SCW_ACCESS_KEY has to be set
validation error
unmarshalling authorization token
exception error
writing private bundle
exception error mirror, keystore, vfs, write-failed
applying changes to Router is unsupported
exception error gce, networking, router, drift, unsupported-operation
arn does not contain acceptable node role
exception error aws, iam, rbac, bootstrap, arn
could not determine ownership for instance
exception critical gce, tpm, ownership, bootstrap, security
error building well-known operators
exception error addons, feature-flag, operators, kops
error creating IAMOIDCProvider
exception error aws, iam, oidc, kops
error creating subnet
exception error openstack, neutron, subnet, create
error describing network interfaces
exception error aws, ec2, network-interfaces, nlb, describe
error encoding ECDSA private key
exception error pki, ecdsa, x509
error finding CloudInstanceGroups
exception error cloud-api, instancegroups, delete, aws, gce
error parsing kube-apiserver-healthcheck manifest
exception error
failed to find server groups
exception error
Found multiple security groups with the same name
exception error
invalid google cloud URL (no name)
exception error
loading kubecfg settings for
exception error
node not set
exception warning kubernetes, drain, node, configuration
parsing key
exception error tls, certificates, x509, bootstrap
private IP for digitalocean droplet was empty
error_code error
reading userData for
exception error karpenter, userdata, managed-file, kops
rendering server group: adding update tag to server
exception error
unable to determine kubernetes version from
validation error version-parsing, cluster-spec
unable to resolve image
exception error aws, ec2, ami, not-found, karpenter
unexpected credential value
validation error
unexpected format for ServiceAccount email
exception error
unhandled mode
exception error
unsupported target type
validation error cli, target, config-validation
writing to sftp temp file
exception error ssh, sftp, network, io
bare-metal support requires the Metal feature flag to be…
validation error feature-flag, bare-metal, cli
building node labels for
exception error kubernetes, node-labels, karpenter, validation
deleting forwardingRule
exception error gce, forwarding-rule, cloud-api, deletion
error adding Cilium IPSec secret
console error
error checking for /run/cilium/cgroupv2
exception error nodeup, cilium, cgroupv2, statfs, filesystem
error closing temp file
exception error
error converting nodeup config to yaml
exception error nodeup, yaml, serialization, bootstrap
error deleting instance of group
exception error
Error listing endpoints
http error http, storage, list, internal-server-error
error listing IAM role policies for
exception error aws, iam, pagination, api-error
error listing zones
exception error gce, gcp, api, authentication
error modifying warm pool
exception error aws, autoscaling, warm-pool
expected protocol[:portspec] in firewall rule
validation error gce, firewall, parsing, validation
getting FirewallRule
exception error gcp, gce, firewall, api-read