jaegertracing/jaeger
Documented errors, page 2 of 4. Back to jaegertracing/jaeger
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| : it cannot be combined with ; express those predicates in… | validation | error | query, validation, tracestore |
| cannot query for duration and tags simultaneously | validation | error | cassandra, query-validation, unsupported-feature |
| remote server does not support FindTraceSummaries | exception | warning | grpc, api-v3, version-compatibility |
| aggregation not found | exception | error | elasticsearch, metrics, aggregation |
| service/operation reads require a searcher, but this… | exception | error | elasticsearch, configuration, write-only-storage |
| bulk request failed | exception | critical | elasticsearch, network, bulk-index, retryable |
| failed to check if alias exists | exception | error | elasticsearch, auth, aliases |
| failed to create rollover | exception | error | elasticsearch, rollover, network |
| failed to parse int attribute | exception | error | clickhouse, attributes, type-conversion, query-builder |
| unrecognized exporter type | validation | error | cli, configuration, otel, tracegen |
| trace ID must be 32 hex characters, got | validation | error | validation, trace-id, hex, jaeger |
| cannot open index.html | exception | error | ui, static-files, filesystem, file-not-found, startup |
| cannot read embedded all-in-one configuration | error_code | error | config, startup, embedded-assets |
| failed to get trace | exception | error | storage, trace-lookup, jaeger, mcp |
| invalid TraceID length | exception | error | cassandra, json, serialization, trace-id |
| failed to build transport pool | exception | error | elasticsearch, transport, initialization |
| start_time_max must be after start_time_min | validation | error | mcp, input-validation, time-range |
| Field is missing a tag 'metric | validation | error | reflection, struct-tags, metrics |
| latency_unit must be "ms" or "s", not | validation | error | config, validation, prometheus |
| cannot find factory for dependency storage | console | error | go, storage, dependencies, type-assertion |
| ILM/ISM policy doesn't exist. Please create it and re-run… | error_code | error | elasticsearch, ilm, setup |
| failed to query trace | exception | critical | clickhouse, database, query, network |
| multiple backend types found for trace storage | validation | error | config, storage, validation |
| deprecated ES rotation flags | validation | error | elasticsearch, configuration, deprecation, rotation, feature-gate |
| extension does not implement queryinterceptor.Interceptor | exception | error | config, type-assertion, otel-collector, interface |
| invalid query filter | validation | error | storage, query-filter, validation, jaeger |
| unexpected metrics ValueType | exception | error | prometheus, metrics, type-mismatch |
| failed to listen on gRPC port | exception | critical | grpc, network, port-bind, address-in-use |
| server with TLS enabled can not use same host ports for… | validation | error | configuration, tls, startup |
| unsupported schema version | exception | error | cassandra, storage, configuration, schema-version |
| root span top-hit missing _source | exception | error | elasticsearch, top-hits, response-parsing |
| error reading traces from storage | exception | error | cassandra, storage, trace-lookup, iterator |
| no metric backend configuration provided for | console | error | go, jaeger, config, metrics |
| storage ' ' does not support sampling store | console | error | go, jaeger, type-assertion, sampling |
| : it does not index the level | validation | error | filter, shape, tracestore |
| cannot read from index.html | exception | error | io, file-read, jaeger-query, startup |
| failed to create index | exception | error | elasticsearch, network, index-creation |
| malformed bulk response | exception | error | elasticsearch, bulk-index, proxy, protocol-violation |
| trace ID must be 16 bytes, got | validation | error | validation, trace-id, length-check |
| failed to read span rows | exception | error | clickhouse, network, timeout, streaming |
| authenticator is not supported | validation | error | grpc, configuration, authentication |
| failed to parse admin server TLS options | error_code | error | tls, config, admin-server |
| failed to close HTTP server | exception | warning | http, shutdown, lifecycle, server |
| invalid span_id | validation | error | mcp, validation, span-id, jaeger |
| duration_max must be greater than duration_min | validation | error | mcp, input-validation, duration |
| failed to create admin server | error_code | error | admin-server, http-server, startup |
| filter argument is empty: a call argument must carry a call | validation | error | protobuf, filter, decoding |
| failed to create aliases | exception | error | elasticsearch, network, aliases |
| failed to extend lease on resource lock | exception | error | cassandra, distributed-lock, lease-expiry, lwt |
| invalid mapping type | validation | error | elasticsearch, validation, index-template |
| invalid start_time | validation | error | mcp, validation, timestamp, jaeger |
| failed to render mapping to string | exception | error | elasticsearch, template-rendering, versioning |
| failed to search for Latest Probabilities | exception | error | elasticsearch, search, network |
| failed to compute critical path | exception | error | critical-path, analysis, mcp |
| failed to stop the adaptive sampling aggregator | exception | error | go, otel-collector, adaptive-sampling, shutdown |
| unmarshalling documents failed | exception | error | elasticsearch, sampling, json, deserialization |
| cannot find query interceptor extension | exception | error | config, otel-collector, extensions, startup |
| could not find aggregation of | exception | error | elasticsearch, aggregation, response-parsing |
| at least one storage backend is required | validation | error | query-filter, field-mapping, elasticsearch |
| invalid length of decoded trace ID , expected bytes | exception | error | clickhouse, trace-id, data-corruption, hex-decoding |
| filter constant declares the unknown type | validation | error | proto, filter-expression, type-mismatch |
| invalid HTTP server host:port | exception | error | configuration, network, http, startup |
| failed to close rows | exception | warning | clickhouse, connection, resource-cleanup |
| failed to process bucket | exception | error | elasticsearch, metrics, aggregation, bucket-processing |
| : it compares a reference against a constant only | validation | error | filter, shape, tracestore |
| Field [ ]: Buckets should only be defined for Timer and… | validation | error | reflection, struct-tags, metrics |
| failed to initialize config | error_code | error | config, viper, cli |
| : it evaluates a conjunction of predicates only | validation | error | filter, shape, tracestore |
| failed to search for throughputs | exception | error | elasticsearch, sampling, search, network |
| failed to create Elasticsearch client | error_code | error | elasticsearch, client-init, startup |
| cannot start the admin server | error_code | error | network, http-server, port-in-use |
| error reading dependencies from storage | exception | error | cassandra, storage, network, read-failure |
| extension ' ' is not of expected type | console | error | go, jaeger, type-assertion, otel-collector |
| failed to load password from file | exception | error | elasticsearch, authentication, file-io |
| neither table nor exist | exception | critical | cassandra, schema, storage, startup |
| failed to scan span row | exception | error | clickhouse, schema, deserialization, scan |
| failed to acquire resource lock due to cassandra error | exception | error | cassandra, distributed-lock, lwt, storage |
| failed to execute FindTraces | exception | error | grpc, streaming, trace-reader |
| filter argument is empty: exactly one of attr, field… | validation | error | protobuf, filter, decoding |
| indices. : cannot use both 'rotation' config and legacy… | validation | error | elasticsearch, config-validation, index-rotation |
| abnormal value of http status code | error_code | error | http, health-check, cli |
| failed to get dependencies | exception | error | storage, backend, jaeger, mcp |
| failed to resolve backend version | exception | error | elasticsearch, client-init, version-detection, network |
| aggregation bucket has a non-string key | exception | error | elasticsearch, json-decoding, aggregation |
| nil search response | exception | error | elasticsearch, nil-response, response-parsing |
| invalid trace ID | validation | error | validation, hex-decode, trace-id |
| bad request | http | warning | http, sampling, bad-request |
| malformed request object | validation | error | elasticsearch, nil-input, query-validation |
| trace_id is required | validation | error | mcp, input-validation, missing-field |
| tools[ ].name is empty or whitespace | validation | error | validation, http-api, ai-tools |
| cannot resolve query interceptors | console | error | go, config, interceptors, otel-collector |
| failed to parse bulk response | exception | error | elasticsearch, json, bulk-index, proxy |
| websocket dial | exception | error | websocket, network, connection |
| Field is not a pointer to timer, gauge, or counter | validation | error | reflection, struct-tags, metrics, type-error |
| SearchDepth must not be greater than | validation | error | validation, integer-overflow, api-v3 |
| unsupported version : set 0 to auto-detect, or use 7/8/9… | validation | error | elasticsearch, opensearch, configuration, version-validation |
| cannot find metrics storage factory | console | error | go, config, storage, metrics |
| cannot read UI config file | exception | error | io, config, file-not-found, jaeger-query |
| filter term cannot be encoded for the wire | exception | error | filter, encoding, sentinel-error |
| date_histogram aggregation not found in bucket | exception | error | elasticsearch, metrics, aggregation, date-histogram |