ErrLookup › jaegertracing/jaeger

jaegertracing/jaeger

CNCF Jaeger, a Distributed Tracing Platform · Go · 569 source files

Analyzed at 806f444784 on 2026-09-01. 304 documented errors.

Code / MessageTypeSeverityTags
invalid version
validation error cassandra, storage, configuration, dependency-store
: it can carry only one predicate on
exception error jaeger, tracestore, filter-unsupported, duplicate-predicate
: it compares against a string constant only
validation error jaeger, tracestore, filter-unsupported, type-mismatch
failed to parse bool attribute
validation error clickhouse, attributes, type-conversion, query-builder
failed to delete indices
exception error elasticsearch, network, index-management
: the bound on was never read as a duration
exception error jaeger, tracestore, invalid-filter, duration-parse
failed to read token file
exception error auth, filesystem, token, file-io
: it does not support the built-in field of the level
validation error jaeger, tracestore, filter-unsupported, query-shape
cannot create metrics reader
console error go, jaeger, metrics, startup
failed to find latest index
exception error elasticsearch, sampling, index-not-found, storage
failed to append span to batch
exception error clickhouse, go, batch-insert, data-integrity, schema-mismatch
trace not found
exception warning mcp, trace-lookup, not-found
: it does not support the operator on
exception error jaeger, tracestore, filter-unsupported, operator
failed to create the adaptive sampling aggregator
exception error go, otel-collector, adaptive-sampling, startup
file must begin with '['
validation error query-filter, duration-parse, elasticsearch
failed to create gRPC server
exception error grpc, configuration, tls, startup
failed to obtain purger
console error storage, configuration, otel-extension
: it compares against a duration such as "2s" only
exception error jaeger, tracestore, filter-unsupported, duration-type
invalid parameters
validation error go, elasticsearch, metrics, validation
failed to send batch
exception critical clickhouse, go, batch-insert, database, network
UI config file must define function UIConfig()
validation error javascript, config, validation, jaeger-query
failed to read trace ID rows
exception error clickhouse, go, network, streaming
cannot create metrics factory
error_code error config, metrics, startup
the structured query filter is disabled
exception error feature-gate, query-filter, configuration
this storage backend requires a service name to search…
validation error http-api, search, storage-backend, missing-param
cannot unmarshal OTLP
exception error otlp, unmarshal, json, tracing
: it does not support the operator
exception error jaeger, tracestore, filter-unsupported, operator
cannot assign unique span ID, too many spans in the trace
exception error query-filter, typed-constant, elasticsearch
failed to discover Elasticsearch nodes (sniffing)
exception error network, elasticsearch, sniffing, startup
unsupported span kind
validation error query-params, validation, tracing, opentelemetry
failed to get token from file
exception error auth, token, startup, file-io
service Name must be set
validation error cassandra, query-validation, trace-search
start Time Minimum is above Maximum
validation error elasticsearch, query-validation, time-range
invalid mapping type
validation error cli, validation, elasticsearch
query interceptor returned an invalid filter
exception critical interceptor, server-fault, extension
could not find aggregation of traceIDs
exception info go, badger, legacy, aggregation
invalid version format
exception error elasticsearch, version-parsing, type-mismatch
invalid OTLP proxy target
exception error config, http, url-parsing, otlp, startup
query exists in template without ";"
validation error cassandra, schema, template-parsing, configuration
unable to parse param
validation error query-params, validation, http-api
failed to initialize storage
error_code error storage, startup, config
invalid end_time
validation error mcp, validation, timestamp, jaeger
archive span storage was not configured
exception warning archive, configuration, optional-feature
this storage backend does not compute trace summaries…
exception info jaeger, tracestore, unsupported-capability, summaries
unknown metrics backend specified
validation error config, metrics, startup
max spans count reached
exception error regex, elasticsearch, unsupported-feature
only one of basic auth (--es.username/--es.password)…
validation error query-filter, operator, duration
: it returned no filter for a query that had predicates…
exception error interceptor, security, validation, query-filter
could not find 'featuregate' command
panic error panic, cli, otelcol, dependency-drift
cannot load index.html
exception error config, ui, static-files, filesystem, startup
error reading throughput from storage
exception error cassandra, storage, gocql, error-wrapping
wrong number of arguments
validation error query-filter, invalid-argument, expression
this query parameter is not supported yet
validation info go, badger, unsupported-feature, compatibility
error starting cleaner server
exception error network, http-server, port-conflict
failed to query dependencies
exception error clickhouse, dependency-store, query-failure, database
this storage backend cannot serve this query filter
exception error storage, query-filter, jaeger
cannot load adaptive sampling components from
exception error adaptive-sampling, configuration, otel-extension
please provide at least one service name
validation error http-api, metrics, missing-param
internal data consistency issue
exception critical go, badger, data-corruption, consistency
error reading probabilities from storage
exception error cassandra, storage, gocql, error-wrapping
failed getting error metrics
exception error prometheus, metrics, storage, network
failed to scan dependency row
exception error clickhouse, dependency-store, row-scan, schema
failed executing metrics query
exception error elasticsearch, network, metrics, query
TraceID is not a 128bit integer
exception error cassandra, trace-id, data-corruption, deserialization
server URL must include a scheme and host, e.g…
validation error config, url-validation, elasticsearch
ai.agent_headers
validation error config, validation, startup
error generating mappings
exception error cli, config, template-rendering, elasticsearch
failed to prepare batch
exception critical clickhouse, go, batch-insert, database, schema-mismatch
failed to query trace IDs
exception critical clickhouse, go, network, database, connection
api_v3 does not expose the backend's search capabilities
exception warning api-v3, search-capabilities, unsupported
unknown encoding type: %#02x
exception error badger, storage, serialization, configuration
of bulk items rejected
exception error elasticsearch, bulk-index, mapping-conflict, retryable
%w: %w
exception error interceptor, expression, validation, query-filter
failed to check if template exists
exception warning elasticsearch, testing, index-template
cannot find extension
console error go, jaeger, otel-collector, config
failed to parse double attribute
validation error clickhouse, attributes, type-conversion, query-builder
service name must be set
validation error go, badger, query-validation, spanstore
storage ' ' not declared in ' ' extension configuration
console error go, jaeger, config, lookup
duration Minimum is above Maximum
validation error elasticsearch, query-validation, duration-range
empty configuration
validation error query-filter, unsupported-feature, elasticsearch
failed to decode trace ID
exception error clickhouse, go, data-integrity, hex-decode
error creating Elasticsearch client
error_code error elasticsearch, startup, client-init
%s: %w
exception error cassandra, write, storage, indexing
.tls.* options cannot be used when is false
validation error config, tls, validation
unsupported attribute type
exception error clickhouse, attributes, unsupported-type, query-builder
failed to get latest index
exception error elasticsearch, storage, sampling
invalid server URL
validation error configuration, url-parsing, elasticsearch, startup
unsupported --es-version
validation error cli, validation, versioning, opensearch
cannot send the query filter
exception error validation, query-filter, proto
failed to convert aggregations to metrics
exception error elasticsearch, metrics, aggregation, translation
unrecognized write_mode
validation error elasticsearch, config-validation
cannot copy stored trace
exception error memory-store, deep-copy, serialization
failed to execute GetOperations
exception error grpc, storage, trace-reader
failed to unmarshal configuration
validation error go, viper, configuration, remote-storage
unknown column for position
exception error cassandra, udt, schema-mismatch, gocql
cannot initialize admin server
error_code error config, http-server, startup
invalid configuration
validation error go, configuration, validation, remote-storage
trace storage
validation error config, storage, validation
failed to create template
exception error elasticsearch, index-template, network
: enable the feature gate to use it
exception warning feature-gate, config, query-filter, bad-request