ipfs/kubo
Documented errors, page 4 of 7. Back to ipfs/kubo
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| error constructing namesys | exception | error | ipns, namesys, offline, initialization |
| remote pinning service name not specified | validation | error | cli, remote-pinning, empty-argument, validation |
| not installed | exception | error | |
| could not get repo version | exception | error | migrations, repo-version, go |
| failed to decode multibase | exception | error | |
| Kubo RPC Access Denied: Please provide a valid… | http | error | http, rpc, auth, security |
| linux-musl not supported, you must build the binary from… | exception | error | migrations, platform-support, linux, musl |
| n.Err (server-provided bad-node error message) | exception | warning | pin, verify, bad-nodes, datastore |
| private network does not work with Routing.Type=auto… | validation | error | config, routing, private-network, validation |
| syncing stash file | exception | error | io, filesystem, fsync, update |
| not found in tar.gz | exception | error | |
| serveHTTPGateway: manet.ToNetAddr() failed | exception | error | multiaddr, gateway, config |
| unknown event type | exception | error | cli, internal, events, type-assertion |
| bootstrap address without a transport | validation | error | cli, bootstrap, multiaddr, validation |
| can only update directories | exception | error | |
| cannot parse $EDITOR value | exception | error | config, environment, parsing |
| required Datastore.Spec entry missing from config file | exception | error | |
| unrecognized key type | validation | error | config, crypto, keys, identity |
| Version.SwarmCheckPercentThreshold must be between 1 and 100 | validation | error | configuration, version-check, validation |
| "all" strategy cannot be combined with other strategies in | validation | error | config, provide, dht, validation |
| ' ' is not a known key, an IPNS Name, or a valid PeerID | exception | error | verification, ipns, key-lookup |
| cannot remove key with name 'self' | exception | error | keystore, ipfs, identity |
| cp: cannot unlink existing file | exception | error | mfs, cli, cp |
| failed to configure private network | exception | error | pnet, libp2p, config, swarm-key |
| invalid provide strategy: empty token in | validation | error | config, provide, parsing, dht |
| reading config from repo | exception | error | config, repo, cli |
| can't remove some files | exception | error | |
| expected env to be of type %T, got %T | exception | error | env, type-mismatch, coreapi, test-harness |
| file argument was nil | exception | error | cli, files, directory |
| missing option "mhlen" | validation | error | cli, block-put, options, internal |
| opening repo (is the daemon running?) | exception | error | repo, fsrepo, daemon, lock, cli |
| serveHTTPApi: GetConfig() failed | exception | error | ipfs, kubo, config, api, daemon-startup |
| cannot specify negative length | validation | error | cli, cat, argument-validation |
| core/commands: unexpected type %T, expected… | exception | error | cli, encoding, type-assertion |
| invalid CID | exception | error | validation, cid, cli, parsing |
| pin name is bytes (max bytes) | validation | error | pinning, validation, remote |
| unknown autonat mode | validation | error | config, autonat, unmarshal, enum-validation |
| writing new MFS root | exception | error | |
| cp: cannot flush the created file | exception | error | mfs, cli, flush |
| no id specified | validation | error | cli, ipfs, p2p, missing-argument |
| Provide.DHT.SendProviderRecordTimeout must be positive, got | validation | error | config, go, validation, timeout |
| support for IPFS_REUSEPORT was removed. Use… | validation | error | environment-variables, deprecation, daemon, reuseport |
| http api returned no error and no results | exception | warning | pin, http-rpc, response-validation, version-skew |
| Import.UnixFSChunker invalid format | validation | error | config, chunker, validation, import |
| Import.UnixFSHAMTDirectorySizeEstimation must be | validation | error | config, hamt, unixfs, validation |
| -- implies -- =false and cannot be combined with -- =true… | validation | error | cli, dag-import, flag-conflict, pinning |
| existing IPNS record has sequence | validation | error | |
| pinning root FAILED | exception | error | |
| %s: %s | http | error | |
| 'type' field missing or not a string | validation | error | datastore, config, type-validation, go |
| cp: cannot flush the created file's parent folder | exception | warning | mfs, cli, flush |
| parsing target version | exception | error | version-parsing, semver, cli, self-update |
| a service name must be passed | validation | error | cli, remote-pinning, missing-option, argument-validation |
| chmod temp file | exception | error | filesystem, permissions, chmod, update |
| CID cannot be parsed | validation | error | |
| invalid peer address | error_code | error | |
| : cannot put node in path | exception | error | cli, mfs, to-files, putnode |
| close | error_code | warning | shutdown, context-deadline, goroutine |
| was not a file | exception | error | |
| creating delete batch | error_code | warning | datastore, batch, migration, dht, purge |
| Import.UnixFSHAMTDirectoryMaxFanout must be a power of 2… | validation | error | config, hamt, unixfs, validation |
| new root must be a directory, got | exception | error | |
| new root does not exist locally; fetch it first with 'ipfs… | exception | error | blockstore, cid, garbage-collection, cli |
| out.Err (server-provided error message) | exception | error | pin, verify, stream-error, server-error |
| the --verbose and --quiet options can not be used at the… | validation | error | ipfs, cli, pinning, flag-validation |
| this is a potentially destructive operation; pass --confirm… | exception | error | cli, destructive-operation, safety-guard, mfs |
| unexpected Objects len | exception | error | rpc-client, unixfs, dag-pb |
| creating temp file | exception | error | filesystem, temp-file, permissions, update |
| err.Error() | http | error | logging, http, http-500, rpc-api |
| experimental pubsub feature not enabled, run daemon with… | exception | error | ipfs, pubsub, config, experimental-feature |
| failed to decode file as config | exception | error | config, json, cli |
| invalid format string | validation | error | cli, cid, format-string, validation |
| import failed after block | exception | error | car, dag-import, truncated-data |
| invalid request path | http | error | |
| mtime nanoseconds must be in range [1, 999999999] | validation | error | unixfs, mtime, validation, options |
| downloading asset | exception | error | |
| failed to download migrations | exception | error | migrations, network-download, aggregate-error |
| getting repo config | error_code | error | |
| provider: error loading MFS root | error_code | error | mfs, provider, blockstore, reprovide, unique |
| serveHTTPGateway: SetGatewayAddr() failed | exception | error | repo, datastore, write, gateway |
| --expand-auto can only be used for reading config values… | validation | error | |
| CheckCIDSize: getting dag | exception | error | dag, blockstore, cid |
| creating batch for orphaned keystore cleanup | error_code | error | |
| failed to load remote pinning services info | exception | error | |
| private key in config was not a string | exception | error | config, identity, type-error |
| writing temp file | exception | error | io, write, disk-full, update |
| can't convert non-dag-pb nodes to cidv0 | validation | error | cli, cid, codec, dag-pb |
| could not find ipfs binary in archive | exception | error | |
| : MFS destination parent does not exist | exception | error | cli, mfs, to-files, path-not-found |
| serveHTTPApi: invalid API address | exception | error | ipfs, kubo, multiaddr, config, api |
ErrNoResourceMgr missing ResourceMgr: make sure the daemon is running with… | error_code | error | |
| errors while displaying some entries | exception | error | |
| expected a file | validation | error | cli, block-put, file-argument, directory-input |
| paths must start with a leading slash | validation | error | validation, mfs, path, cli |
| can't be used with UnixFS metadata like mode or… | validation | error | cli, validation, unixfs, raw-leaves |
| cannot get migrations from unknown fetcher type | exception | error | daemon, migrations, repo-upgrade |
| fail to resolve the multiaddr | exception | error | network, dns, multiaddr |
| failed to check pin status for requestid= | exception | error | |
| failed to put key | exception | error | |
| no stashed binaries found in | exception | error | update, rollback, stash, missing-file |