ErrLookup › ipfs/kubo
ipfs/kubo
IPFS implementation in Go: a daemon that stores and serves content-addressed data, with a CLI, HTTP Gateway, and RPC API · Go · 340 source files
Analyzed at 329838acdf on 2026-09-03. 638 documented errors.
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| unexpected keystore suffix | error_code | error | go, datastore, keystore, validation |
| creating datastore config for | error_code | error | go, datastore, config, spec |
| provider: error loading MFS root, cannot provide MFS | error_code | error | mfs, provider, blockstore, reprovide |
| stream flush failed | exception | warning | io-pipe, broken-pipe, streaming |
| reading repo config | error_code | critical | go, config, repo, startup |
| generating profile data for | exception | error | diagnostics, pprof, go, concurrency |
| invalid DHT mode | error_code | error | config, dht, routing, kubo |
| external migration phase failed | exception | critical | go, migrations, repo-upgrade, subprocess |
| invalid key size : keys are always bits | validation | error | go, ipfs, key-generation, validation |
| iterating orphaned keystore data | error_code | error | go, datastore, iteration, io |
| refusing to export key to | exception | warning | cli, keystore, filesystem, race-condition, security |
| Provide.DHT.Interval=0 no longer disables the provide… | validation | error | config, validation, migration, breaking-change |
| this action must be run in online mode, try running 'ipfs… | exception | error | offline, coreapi, ipns, sentinel-error, daemon |
| operation not supported | exception | warning | coreapi, sentinel-error, routing, unsupported-operation |
| refusing to export key to | exception | error | cli, keystore, filesystem, validation |
| nocopy option requires '--raw-leaves' to be enabled as well | validation | error | go, ipfs, unixfs, filestore, options |
| can't put while offline: pass `--allow-offline` to store… | exception | error | ipns, offline, publishing |
| failed to initialize MFS root from | exception | error | mfs, datastore, corruption, startup |
| encoding PEM block | exception | error | cli, keystore, pem, io |
| compressing result | exception | error | io, archive, disk-full, diagnostics |
| +unique/+entities is incompatible with roots in | validation | error | config, validation, provide-strategy |
| GetClosestPeers not supported: WAN DHT is not available | exception | error | dht, routing, http-api, kubo |
| invalid configuration profile | validation | error | cli, init, config, validation |
| error listing directory | exception | error | unixfs, directory-listing, error-wrapping, iterator |
| expected at least one child dir, got none | exception | error | unixfs, add, empty-directory, importer |
| aborted | exception | error | cli, blockstore, block-rm |
| api not running | error_code | info | daemon, rpc, sentinel-error |
| cp: source must be a valid UnixFS (dag-pb or raw codec) | exception | error | mfs, cli, unixfs, cid |
| unrecognized fsn type: %#v | exception | error | unixfs, add, importer, type-dispatch |
| querying orphaned keystore data | error_code | error | go, datastore, query, maintenance |
| lcStatStop: stopFunc was nil | exception | error | lifecycle, fx, internal |
| cannot create libp2p gateway: node PeerHost is nil (this… | exception | critical | go, daemon, dependency-injection, startup |
| compression level must be between 1 and 9 | error_code | error | cli, gzip, validation, options |
| 'true' is not a valid priority | validation | error | config, json-parsing, kubo |
| assets: could load Asset | exception | error | go, ipfs, embedded-assets, init |
| keystore name for backing up old key must be provided | exception | error | cli, keystore, missing-argument |
| GetClosestPeers not supported for DHT type %T | exception | error | dht, routing, http-api, type-switch |
| internal error during CAR export | exception | critical | panic, internal-error, car-export, ipld-codec |
| failed to build MFS options from Import config | exception | error | config, import, mfs, validation, startup |
| no release found with a binary for | exception | error | github, releases, platform, unsupported-platform, cli |
| error while listing remote pins | exception | error | remote-pinning, network, api |
ErrMaxStorageExceeded maximum storage limit exceeded. Try to unpin some files | error_code | error | repo, gc, storage-limit, pinning |
| pin check failed | exception | error | go, ipfs, pins, blockstore, gc |
| cannot apply options to api without node | exception | error | coreapi, node-lifecycle, library-usage |
| error loading plugins (preload) | exception | error | plugins, daemon, startup |
| embedded migration phase failed | exception | critical | go, migrations, embedded, datastore, repo-upgrade |
| cannot write to , incorrect permissions | exception | error | filesystem, permissions, init |
| panic(err) | panic | error | |
| cannot set Identity.PeerID to a value that does not match… | validation | error | config, identity, cli, peerid |
| iterating datastore keys | error_code | warning | datastore, migration, dht, purge, corruption |
| parsing current version | exception | error | version-parsing, semver, cli, self-update |
| Provide.DHT.KeystoreBatchSize must be positive, got | validation | error | config, go, validation, dht |
| Provide.Strategy | validation | error | config, validation, provide-strategy |
| invalid configuration: Bitswap.Libp2pEnabled and… | exception | critical | config, bitswap, startup, kubo |
| service already present | validation | error | cli, config, remote-pinning, duplicate-key |
| configuring muxers with LIBP2P_MUX_PREFS is no longer… | error_code | error | libp2p, config, muxer, deprecation |
| cannot add links to a HAMTShard at the dag-pb level (would… | validation | error | unixfs, hamt, dag-pb, deprecated-api |
| failed to parse peer address | validation | error | cli, peer-id, multiaddr, parsing |
| bloom tracker | error_code | error | provider, bloom-filter, unique, reprovide, memory |
| config setting IPNS.RepublishPeriod is not between 1min and… | exception | error | ipns, config, startup |
| unexpected redirect | exception | error | go, ipfs, rpc, http, redirect |
| could not read versions | error_code | error | network, io, versioning |
| error loading filesroot from dagservice | exception | critical | mfs, blockstore, garbage-collection, startup |
| unknown file type | exception | error | unixfs, add, file-type, importer |
| only dag-pb is allowed with CIDv0 | validation | error | block, cid, cidv0, dag-pb, validation |
| constructing the node (see log for full detail) | exception | error | node-construction, dependency-injection, fx |
| building fx opts | exception | error | node-construction, dependency-injection, fx |
| ipfs not initialized, please run 'ipfs init' | exception | error | repo, initialization, go, config |
| error setting ulimit without hard limit | validation | error | ulimit, file-descriptors, permissions, go |
| -- implies --offline and cannot be combined with… | validation | error | cli, flags-conflict, dag-export |
| key is not a map | exception | error | config, golang, map-traversal |
| api version mismatch | exception | error | http, rpc, versioning, compatibility |
ErrNotDHT routing service is not a DHT | error_code | error | routing, dht, cli, deprecated |
| key export expects repo version | exception | error | |
| cannot remove links from a non-UnixFS dag-pb node; pass… | validation | error | unixfs, dag-pb, validation, deprecated-api |
| error setting: ulimit | validation | error | ulimit, syscall, file-descriptors, go |
| Import.HashFunction is not allowed for use in IPFS | validation | error | config, hash, verifcid, validation |
| AutoConf cannot use the default mainnet URL | validation | error | autoconf, private-network, swarm-key, config-validation |
| points below a root CID, expected a single CID | validation | error | cid, path, arguments |
| cannot parse mode | exception | error | go, ipfs, rpc, parsing |
| service not known | exception | error | config, remote-pinning, lookup-failed, missing-config |
| libp2p stream mounting not enabled | exception | error | ipfs, cli, experimental-feature, config |
| cannot manually publish while IPNS is mounted | exception | error | ipns, fuse, mount |
| Provide.BloomFPRate must be >= | validation | error | config, validation, bloom-filter |
| unexpected multipart response during emit, please file a… | exception | error | multipart, rpc, bugreport, protocol-violation |
| checking if new root exists | exception | error | blockstore, cid, local-data, cli |
| could not parse our own version | exception | error | versioning, build, ldflags |
| failed to check pin status for requestid= | exception | error | network, ipfs, pinning, remote-service, polling |
| GitHub API rate limit exceeded | exception | error | github, rate-limit, network, http-403, cli |
| embedded downgrade phase failed | exception | critical | go, migrations, downgrade, embedded |
| init: seeding init docs failed | exception | warning | init, filesystem, assets |
| unsupported file type | exception | error | go, ipfs, rpc, unixfs |
| already have a datastore named | exception | error | plugins, datastore, config, registration |
| 'ipfs id' cannot query information on remote peers without… | exception | error | cli, daemon, offline, network |
| marshalling key to PKCS8 format | exception | error | |
| private key in config does not match id | exception | critical | identity, config, peerid |
| could not perform version check due to missing or… | exception | error | dht, version-check, configuration |
| failed to set config value | exception | error | config, cli, json |
| creating output file | exception | error | io, archive, diagnostics |
| failed to get PrivKey | exception | error | config, identity, peerid |