hashicorp/nomad

Documented errors, page 24 of 29. Back to hashicorp/nomad

Code / MessageTypeSeverityTags
Deployment ID matched no deployments
console error cli, not-found, identifier
evaluation does not exist
exception error
failed to create secrets/
exception error
failed to detect memset
error_code critical cgroups, cpuset, numa, client-startup
failed to find storage provider info for client
exception error
failed to list iptables chains
exception error
Failed to resolve Serf advertise address
validation error
invalid MaxTokenTTL value
validation error acl, ttl, validation, nomad
minimum count must be specified and non-negative
validation error nomad, scaling-policy, validation
minimum MemoryMB value is
validation error nomad, resources, validation, memory
missing code
validation error nomad, acl, oidc, validation, auth-code
must specify plugin allocation ID to deregister
validation error validation, plugin-registry, nomad
scheduler resulted in an unexpected number of eval updates
exception error
task state entry not found
console warning nomad, boltdb, state-migration
users: release of unused uid/gid
exception warning go, nomad, pool, lifecycle
while multiple audiences is allowed, it is more secure to…
validation warning nomad, workload-identity, security, jwt
auth method specifies BoundIssuers but the provided token…
validation error auth, jwt, issuer-validation
decompression_size_limit must be <
validation error nomad, config-validation, overflow, decompression
EventLogger is not supported on this platform
exception error go, windows, platform, logging
Got 0 byte response with non-nil decode object
exception error
init of plugin failed
exception error nomad, plugin, driver, initialization, environment
limit must be greater than or equal to 0 but found
validation error nomad, check-restart, job-validation
one-time token lookup failed: missing secret
validation warning nomad, state-store, one-time-token, validation
unexpected message type: %#v
exception error
configuration path must be a directory
validation error config, consul, file-loading, path
empty signed identity response
exception error workload-identity, rpc, empty-response, nomad
error getting job summary
exception error nomad, csi, state-store, job-summary
error parsing S3Timeout
validation error config, parsing, duration, go
failed to decode task state from 'simple-all' entry
console error nomad, msgpack, decoding, state-migration
failed to determine disk space for
exception error filesystem, disk-space, fingerprinting
failed to initialize driver after it exited unexpectedly
exception error
failed to query node allocs
exception error
Invalid value for "-in"; valid values are [hcl, json]
validation error go, cli, flags, validation
Job must be in a namespace
validation error nomad, go, validation, namespaces
missing job for registration
validation error nomad, job-registration, validation, api
node pool has non-terminal jobs in regions
validation error nomad, node-pools, jobs, multi-region
PrivateKey is required for `private_key` KeySource
validation error nomad, oidc, jwt, validation
Windows service manager is not supported on this platform
exception error go, windows, platform, services
client_introduction.enforcement must be one of
validation error config, validation, nomad
Consul Ingress Service doesn't support associating hosts to…
validation error nomad, consul, ingress-gateway, tcp, hosts
could not detach from controller
exception error
failed to convert version
exception error go, version-parsing, plugin-loader, nomad
failed to write snapshot data header
exception error tar, io, disk
https_handshake_timeout must be >= 0
validation error configuration, validation, tls, nomad
invalid IP address
validation error docker, networking, etc-hosts, config-validation
No file or directory at
console error cli, filesystem, fmt
restart of an alloc that should not run
exception error lifecycle, alloc-runner, terminal-state, api
unable to create unix socket for Consul gRPC endpoint
exception error
unsupported raft log store backend
validation error configuration, raft, validation, nomad
cron.end must contain
validation error
Error formatting host volume
console error cli, formatting, template, host-volumes
failed to annotate job diff
exception error
failed to decode object
exception error hcl, config, decoding, device
failed to determine mount point for
exception error filesystem, exec, df, fingerprinting
failed to get config schema
exception error plugin, device, config, schema
failed to open a tty
exception error tty, pty, exec, container, nomad
failed to open consul TLS certificate
exception error
failed to setup vault client
exception error client, vault, initialization
invalid access mode
validation error nomad, validation, host-volume, access-mode
invalid drain_on_shutdown config
validation error nomad, config-validation, drain
port must be < but found
validation error nomad, ports, validation, config
Unknown node
error_code error nodes, not-found, rpc, nomad
volume does not have MULTI_NODE volume capability
exception error
address_mode = driver may only be set for Consul service…
validation error nomad, consul, address-mode, validation
binary install failed
exception error windows, filesystem, installation
DestroyNetwork RPC not supported by driver
exception error plugin, driver, network, capability
-dev=connect uses network namespaces
validation error network, dev-connect, linux, interfaces
failed to cleanup iptables rules for alloc
exception error
failed to write snapshot hashes header
exception error tar, io, disk
image name required for docker driver
validation error docker, nomad-driver, missing-config, image
limit should be an object
validation error hcl, parsing, quota, nomad
max requested capacity
validation error
Task name cannot include null characters
validation error nomad, task, naming, validation
tasks can only have 1 identity block until all servers are…
validation error nomad, workload-identity, version-skew, rolling-upgrade
unknown deployment
console error nomad, deployment, not-found, state-store
volume is already staged to but with incompatible…
exception error
%w: "%s"
validation error nomad, volumes, selinux, validation
[✘] Could not create Consul policy
exception error consul, acl, setup
dynamic_user_max must not be negative
validation error nomad, agent-config, validation, range-check
error parsing Consul address
exception error
ErrUnknownNode
%w %s
exception error
Invalid delay function
validation error nomad, validation, enum, reschedule-policy
invalid publish_time
http error
Missing job name
validation error nomad, go, validation, job-spec
namespace not found
validation warning nomad, namespace, state-store
nil HTTP client transport
validation error
no identities to sign
exception error workload-identity, validation, nomad
Payload is not provided but required by parameterized job
validation error nomad, api, payload, parameterized-job, validation
%s: %q
error_code error
transparent proxy block has invalid ExcludeUIDs field
validation error validation, connect, transparent-proxy
unable to get CWD from filesystem
exception error filesystem, fingerprinting, cwd
-dev=connect uses network namespaces: could not find public…
validation error network, dev-connect, interfaces, containers
error building environment variables
exception error
failed to parse certificate
validation error tls, x509, certificate, pem
failed to reattach to plugin because supported API versions…
exception error plugin-loader, api-version, reattach
failed to write secrets/
exception error
invalid start time in schedule
validation error
malformed port map: -- error
validation error nomad, mock-driver, config, port-mapping
Operator requires an RTarget
validation error nomad, constraint, missing-value, job-validation
volume has unrecognized type
validation error nomad, volumes, validation, config