goharbor/harbor
Documented errors, page 2 of 4. Back to goharbor/harbor
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| unauthorized | http | critical | harbor, jobservice, auth, secret, service-to-service |
| not supported | exception | warning | harbor, auth, auth-mode, not-supported |
| empty cron string is invalid | validation | error | |
| the name of namespace cannot be null | validation | error | go, jfrog, artifactory, replication, validation, empty-string |
| This operation only allowed for admin | exception | error | python, harbor, chart-migration, authorization, cli |
| load configurations error | panic | error | |
| failed to load configuration, error | panic | error | |
| failed to fetch artifacts | exception | error | |
| [tencent-tcr.FetchArtifacts.matchImage] image= | exception | error | |
| list tags for repo ' ' error | exception | error | |
| failed to connect to tcp | console | error | |
| missing custom token/key data | exception | error | p2p-preheat, custom-auth, credentials, provider, harbor |
| manifest not found in local registry | http | error | |
| empty search dn | exception | error | ldap, config, bind-dn, harbor |
| invalid execution ID | validation | error | |
| State mismatch | http | error | harbor, oidc, sso, session, csrf |
| unsupported candidate kind | exception | error | |
| group does not exist | exception | error | harbor, auth, ldap, usergroup |
| enqueue timestamp missing for scheduled job | validation | error | |
| ldap server network timeout | exception | error | ldap, network, timeout, connectivity, harbor |
| malformed scan report object | validation | error | scan, report, required-fields, validation |
| Trace enabled but no trace exporter set | validation | error | go, harbor, json, scan, validation |
| bad _REDIS_URL_HARBOR | panic | error | |
| malformed endpoint | validation | error | scanner, registration, uuid, validation |
| empty rule template ID | validation | error | retention, rule, template, validation |
| nil stats body | validation | error | jobservice, job-stats, validation, serialization, harbor |
| should provide a group name | validation | warning | harbor, auth-proxy, usergroup, validation |
| Trace endpoint not set | validation | error | go, harbor, scanner-adapter, metadata, validation |
| check existence of namespace | exception | error | |
| invalid int64 string | validation | error | |
| purge upload age should set with with nh, n is the number… | validation | error | go, harbor, sbom, dao, data-safety, validation |
| invalid database | console | error | |
| the 1st field (indicating Seconds of time) of the cron… | validation | error | |
| cache expire hours should be positive number | validation | error | go, harbor, sbom, report, validation |
| failed to pull blob from registry | http | error | |
| failed to decode content | http | error | |
| invalid filter value type for label filter, expecting… | validation | error | |
| Jaeger Colector Endpoint and Agent host both set, only can… | validation | error | go, harbor, scan, rest-client, mime-type, validation |
| no worker worker is configured | validation | critical | harbor, jobservice, config, worker-pool, startup |
| invalid credential | exception | error | ldap, auth, credentials, config |
| empty JSON data | validation | error | |
| empty secret is not allowed | exception | error | harbor, jobservice, auth, secret |
| failed to create request | http | error | |
| is too large | validation | error | |
| the LDAP group DN is invalid | exception | warning | harbor, ldap, dn, validation, usergroup |
| fail to match tag pattern, error= | validation | error | |
| repo , tag not found | http | error | |
| 127.0.0.1 can not be the hostname | validation | error | go, harbor, sbom, report, validation |
| type error | validation | error | |
| failed to list artifacts of repository | exception | error | |
TOO_MANY_REQUEST too many requests to upstream registry | http | error | |
| Jaeger Colector Endpoint or Agent host not set, must set one | validation | error | go, harbor, scan, rest-client, validation |
PROJECTPOLICYVIOLATION current image without vulnerability scanning cannot be pulled due to configured… | error_code | error | |
| nil request | validation | info | harbor, jobservice, auth, nil-guard |
| no log data getter is configured | http | error | |
| the artifact is not ready yet, failed to tag it to | exception | error | |
| missing logger config of job service | validation | critical | configuration, logging, jobservice, harbor, startup |
| VolcEngineCR only support repo in format | validation | error | |
| unsupported repository kind | exception | error | |
| [VolcengineCR adapt] fail to parse reference | exception | error | |
| invalid filter value type for tag filter, expecting string | validation | error | |
| volcengineCR fail to list all tags | exception | error | |
| received unexpected status code | http | error | |
METHOD_NOT_ALLOWED the operation isn't supported for a proxy cache project | error_code | error | |
BadRequestCode cannot be empty | validation | error | labels, validation, api, harbor |
| [ ][ ] | http | error | |
UNKNOWN internal server error | http | error | |
| invalid log identify | validation | error | |
| failed to create the notification policy | exception | error | |
| failed to get registry, registryID | exception | error | |
| failed to list projects at page | exception | error | |
| report not found, uuid | exception | warning | scan, report, race-condition, not-found |
| empty json data to parse | validation | error | scan, export, json, job-parameters |
| Only can have one trace exporter at a time | validation | error | go, harbor, scan, registry, validation |
| resources is negative for resource(s) | exception | error | |
| failed to check health | http | error | |
| failed to wait the execution record to be inserted | exception | error | |
| http status code: , body | http | error | |
| the subject from userinfo | exception | error | |
| cert file should include SAN | validation | error | go, harbor, type-assertion, scan, summary |
| can not bind search dn, error | exception | error | |
| empty digest to get report data | validation | error | scan, report, digest, validation |
| failed to create OIDC provider, error | exception | error | |
| purge upload interval should set with with nh, n is the… | validation | error | go, harbor, sbom, report, validation |
| unsupported format | http | error | |
| failed to parse certificate | validation | error | |
| empty URL | validation | error | |
FORBIDDEN only admins(system and project) can access permissions | error_code | error | |
| resource not support | validation | error | |
| is less than zero | validation | error | |
| URL of redis worker is empty | validation | critical | harbor, jobservice, config, redis, startup |
| failed to get CVE allowlist for project | exception | error | |
| expected ' ' but got | validation | error | |
| failed to fetch artifacts | exception | error | |
| cannot add child to non-directory node | http | error | |
| scan artifact @ failed | http | error | |
| [VolcengineCR] GetAuthorizationToken output nil | exception | error | |
| dockerhub only support repo in format | validation | error | |
| the configure value can not be empty | validation | error | |
| a LDAP user group with same DN already exist | exception | warning | harbor, ldap, usergroup, duplicate |