ErrLookup › goharbor/harbor
goharbor/harbor
An open source trusted cloud native registry project that stores, signs, and scans content. · Go · 1,372 source files
Analyzed at a0d2a899d3 on 2026-09-03. 365 documented errors.
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Error: storage driver | validation | error | harbor, storage, registry, configuration, validation |
| Error: no provider configurations are provided for provider | validation | error | harbor, storage, s3, configuration, validation |
| invalid redis URL | validation | critical | redis, configuration, jobservice, harbor, url, startup |
| bad redis url for registry | exception | error | harbor, redis, cache, configuration, url-parsing |
| no migration path found to target version | exception | critical | harbor, migration, upgrade, versioning |
| secret key's length has to be 16 chars, current length | exception | error | harbor, secrets, encryption, installation, file-system |
NOT_FOUND no blob found to mark delete failed, ID | error_code | error | gc, blob, database, concurrency, not-found, harbor, jobservice |
| Can not get file info | exception | error | harbor, storage, ca-certificate, file-system, configuration |
| Failed to read chart.yaml from the chart tgz file. filename | exception | error | python, helm, chart-migration, tarfile, harbor |
| [tencent-tcr.newAdapter] Please use SecretId/SecretKey, NOT… | validation | error | go, tencent-tcr, tencentcloud, credentials, configuration |
| the tag deletion isn't supported | validation | error | go, docker-registry, distribution, native-adapter, unsupported-operation, deletion |
| the name of the repository cannot be null | validation | error | go, harbor, replication, validation, nil-check, prepare-for-push |
BAD_REQUEST invalid cron string for scheduled preheat | validation | error | p2p-preheat, cron, scheduler, validation, harbor |
| [volcengine-cr.PrepareForPush] the name of the namespace… | validation | error | go, volcengine-cr, replication, validation, empty-string |
| [tencent-tcr.newAdapter] Invalid TCR instance endpoint | validation | error | go, tencent-tcr, tencentcloud, registry-endpoint, configuration |
VIOLATE_FOREIGN_KEY_CONSTRAINT the deleting artifact is referenced by others | error_code | error | go, harbor, api, artifact, delete, foreign-key, oci-index |
REQUEST_ENTITY_TOO_LARGE The file is too large to be processed | error_code | error | go, harbor, cnai, artifact, size-limit, http-413 |
| chart name: is illegal | console | warning | python, helm, chart-migration, yaml, harbor |
| Error: The protocol is https but attribute ssl_cert is not… | validation | error | harbor, https, tls, certificate, configuration |
| Error: The protocol is https but attribute ssl_cert_key is… | exception | error | harbor, https, tls, private-key, legacy-config |
| no credential data provided | exception | error | p2p-preheat, auth, credentials, nil-guard, harbor |
10013 missing job parameters | validation | error | jobservice, gdpr, audit, validation, job-parameters, harbor |
| failed to create the schedule: the task status is | exception | error | |
| empty password | exception | error | ldap, auth, config, secrets, harbor |
| File not exist | validation | error | go, harbor, scan, report, validation |
| preheating is failed | exception | error | p2p-preheat, dragonfly, kraken, jobs, distribution |
| log level must be one of debug, info, warning, error, fatal | validation | error | harbor, logging, configuration, validation |
| chart.yaml not found in the chart tgz file. filename | exception | error | python, helm, chart-migration, tarfile, harbor |
| invalid CA certificate: no valid certificates found in PEM… | validation | error | go, tls, pem, certificate, harbor, x509 |
| Please specify hostname | validation | error | harbor, configuration, installation, validation |
| Internal dir for tls | validation | error | go, harbor, json, scan, report, validation |
| invalid | validation | error | go, harbor, type-assertion, scan, merge |
NotFoundCode the reference tries to refer a non existing label | error_code | error | labels, artifacts, database, foreign-key, api |
| failed to read request body | http | error | |
| Cert File should be owned by user with uid 10000 or… | validation | error | harbor, storage, ca-certificate, file-permissions, security |
| found more than one scheduled scan all job, please ensure… | http | error | |
| fail to ping LDAP server | exception | error | ldap, tls, certificate, config, harbor |
| Error: The path for certificate key | exception | error | harbor, https, tls, file-system, legacy-config |
| unsupported auth scheme | exception | error | |
| bearer auth scheme isn't supported | exception | error | |
CONFLICT rule is conflict with rule | http | error | |
| entity not found | exception | error | ldap, group-sync, active-directory, harbor |
| Trace url path not set | validation | error | go, harbor, scanner-adapter, metadata, validation |
| Path exists and the type is regular file | exception | error | harbor, file-system, installation, data-volume |
| [volcengine-cr.PrepareForPush] the metadata of resource… | validation | error | go, volcengine-cr, replication, validation, nil-check |
| missing username and/or password | exception | error | p2p-preheat, basic-auth, credentials, provider, harbor |
| [tencent-tcr.newAdapter] Can not get TCR instance info… | exception | error | |
| Port number in metrics is not valid | validation | error | go, harbor, scan, rest-client, validation |
| [tencent-tcr.PrepareForPush] the namespace of resource… | validation | error | go, tencent-tcr, replication, validation, nil-check |
| Artifact already exist in harbor | console | warning | python, harbor, chart-migration, idempotency |
| unknown status | http | info | health, startup, sentinel, concurrency |
| empty realm | validation | error | |
| failed to parse the URL of registry | panic | error | |
| lack digest of candidate for | exception | error | |
| the namespace of resource cannot be null | validation | error | go, quay, replication, validation, nil-check |
| set api key in is invalid | validation | error | |
| the metadata of resource cannot be null | validation | error | go, jfrog, artifactory, replication, validation, nil-check |
| the resource cannot be null | validation | error | go, jfrog, artifactory, replication, validation, nil-check |
| [VolcengineCR] fail to parse expire time returned | exception | error | |
PRECONDITION the policy is disabled | error_code | error | harbor, replication, policy, precondition, api |
| key file permission is not 600 | validation | error | go, harbor, type-assertion, scan, merge |
| Error: must set log endpoint host to enable external host | validation | error | harbor, logging, syslog, configuration |
| File should readable by owner | validation | error | go, harbor, type-assertion, scan, summary |
| single active replication is not allowed for event_based… | http | error | |
| the system is in read only mode, cancel the request | exception | error | read-only, interceptor, maintenance, system-state |
UNAUTHORIZED security context not found | http | error | |
| Internal Server Error | http | error | |
| missing OAuth token | validation | error | p2p-preheat, oauth, bearer-token, credentials, harbor |
| [tencent-tcr.PrepareForPush] the name of the namespace… | validation | error | go, tencent-tcr, replication, validation, empty-string |
| create namespace ' ' in Quay error | exception | error | |
| Unauthorized | http | error | harbor, auth, unauthorized, api, credentials |
| bad _REDIS_URL_CORE | panic | error | |
| Data cannot be converted to v1 report format | exception | error | scan, report-converter, type-assertion, vulnerability |
| invalid content range format | exception | error | |
| no such Retention policy with id | exception | error | |
DENIED permission scope is invalid. It must be equal to or more restrictive than the… | http | error | |
| invalid json request | validation | error | go, harbor, api, json, validation |
| missing job name in job stats | validation | error | jobservice, job-stats, validation, serialization, harbor |
| missing logger config of job | validation | critical | configuration, logging, jobservice, harbor, startup |
| path conflicts: exists with different type | http | error | |
| namespace of redis worker is required | validation | critical | redis, configuration, jobservice, harbor, namespace, startup |
| the name of the namespace cannot be null | validation | error | go, quay, replication, validation, empty-string |
| [VolcEngineCR.DeleteManifest] ListTags resp nil | exception | error | |
| [tencent-tcr.PrepareForPush] the metadata of resource… | validation | error | go, tencent-tcr, replication, validation, nil-check |
| failed to get upload status | exception | error | |
| purge job with id not found | http | error | |
| failed to list artifacts of repository | exception | error | |
| %d -- %s | http | error | |
| failed to validate configuration | http | error | |
| Protocol in external log endpoint must be one of 'udp' or… | validation | error | harbor, logging, syslog, configuration, validation |
| invalid filter syntax | exception | error | ldap, filter, config, query-syntax |
| Error: must set log endpoint port to enable external host | validation | error | harbor, logging, syslog, configuration |
| internal TLS enabled but can't get cert file | console | error | |
| invalid filter value type for repository name filter… | validation | error | |
| check scan report timeout | exception | error | scan, timeout, scanner-adapter, polling |
| invalid CA certificate | validation | error | |
| tcr only support repo in format | validation | error | |
| %s: %v | http | error | |
| [tencent-tcr.FetchArtifacts.listImages] runner= | exception | error | |
| empty action | validation | error | retention, policy, validation, action |