crowdsecurity/crowdsec

Documented errors, page 8 of 11. Back to crowdsecurity/crowdsec

Code / MessageTypeSeverityTags
labels not a map
validation error docker, labels, type-mismatch
no appsec_config provided
validation error appsec, configuration, hub, yaml
: has no stage
validation error hub, index, parser
saving token
exception error database, sqlite, token, write-failure, capi
controller init
exception error lapi, controller, initialization
EOL after timestamp
validation error syslog, rfc5424, parsing, truncated-message
owner is invalid
exception error windows, security, plugin, permissions
unable to parse target
exception error url, config, test-harness, appsec
while parsing
exception critical config, url, crowdsec, startup
building client config for context
exception error
invalid body_size_exceeded_action
validation error appsec, config, enum
invalid DSN for journalctl source, must start with…
validation error go, dsn, configuration, journalctl
invalid log level
validation error wineventlog, windows, configuration
no listen_uri or listen_socket specified
validation error go, config, lapi, crowdsec
reading from socket
exception error network, udp, socket, syslog
while loading console options
validation error config, lapi, console, yaml
AverageInterval expects exactly one parameter: a slice of…
validation error expr, scenario, crowdsec
basic_auth is selected, but password is not provided
validation error config, validation, authentication, basic-auth, secrets
compiling static expression
validation error parser, statics, expr, compilation
consumer_name is mandatory when use_enhanced_fanout is true
validation error aws, kinesis, config-validation, enhanced-fanout
duration is required
validation error leakybucket, yaml-config, validation, crowdsec
empty time now()
exception error go, time, lapi
ErrFeatureNameInvalid
invalid name (allowed a-z, 0-9, _, .)
error_code error go, feature-flags, validation
expected exactly one value for 'since'
validation error dsn, query-parameters, journalctl
failed to get filesystem type
exception error go, freebsd, filesystem, statfs
invalid ip address / range
error_code warning database, crowdsec, ip, filter
query parameter not found
validation error appsec, openapi, api-key, query-parameter, auth
unable to update bouncer type and version in database
exception error database, ent, bouncers, middleware
alert graph delete batch meta
exception error database, delete, alerts
fail to get decision
exception error database, ent, crowdsec, query-failed
grok requires 'expression' or 'apply_on'
validation error parser, grok, validation, configuration
item : not found
exception error hub, not-found, api
marking stale usage metrics as sent
exception error database, sqlite, update-failure, metrics
multiple cookies with name
validation error appsec, openapi, api-key, cookie, duplicate
no database configuration provided
validation error config, database, crowdsec
procid is too long
validation error
unable to hash
error_code error
can't create a kubernetes client for namespace=
exception error
EOL after hostname
validation warning syslog, rfc5424, truncated-message, parsing
event is not supported
exception warning s3, acquisition, notifications, sns
group_name is mandatory for CloudwatchSource
validation error cloudwatch, aws, configuration, validation
invalid threshold: must be > 0 and <= 1
validation error crowdsec, leakybucket, config-validation, bayesian
listing bouncers
exception error database, bouncer, query, cscli
local API server stopped with error
exception error http-server, lifecycle, lapi
loki channel closed
exception error loki, websocket, streaming, channel
no hub configuration provided
validation error config, hub, nil, go
alert with ID
exception error database, delete, alerts
cannot wait for consumer deregistration
exception error aws, kinesis, timeout
ErrFeatureDeprecated
the flag is deprecated
error_code warning go, feature-flags, deprecation
machine attempted to auth with TLS cert but it is…
exception error tls, auth, mtls, machines, config
no certificate in request
http error tls, mtls, certificate, apiserver
while getting decisions from blocklist
exception error network, http, capi, blocklist, pull
failed to generate challenge JS
exception error appsec, challenge, cache, obfuscation
invalid DSN for file source, must start with file://
validation error
unable to load inband rule
exception error appsec, rules, hub
unauthorized
http error api, authentication, http, cti
url is required
validation error validation, constructor, papi
while checking acquisition_path
validation error acquisition, filesystem, permissions, agent
cti is disabled
exception warning config, cti, feature-flag, expr
filter parameter ' ' is unknown (= )
exception error go, lapi, query-params
invalid log_level in dsn
validation error config, logging, victorialogs
message for ' ' contains bad data format
validation error json, papi, decisions
no embedded content for
exception error hub, index, embedded-content
unable to copy .index.json file in
exception error hubtest, file-copy, setup, testing
body size exceeds max body size
http error http, payload, limit
consumer is not active after tries
exception error aws, kinesis, timeout, efo
could not access CRL file
exception error tls, crl, filesystem, config, go
could not get jwt token
exception error
could not read CRL file
exception error tls, crl, filesystem, io, go
ErrFeatureRetired
the flag is retired
error_code error go, feature-flags, deprecation
headers is selected, but headers is not provided
validation error config, validation, authentication, headers
invalid max_failure_duration in dsn
validation error config, duration-parsing, victorialogs
while saving alert from
exception error database, sqlite, postgresql, capi, blocklist
could not parse file
exception error tls, x509, crl, pem, go
invalid DSN for docker source, must start with ://
validation error dsn, config, url-scheme
leaky.BucketConfig is nil
exception error crowdsec, leakybucket, nil-pointer, alert
is a directory, not a file
exception error binary, filesystem, hubtest, cli
unable to decode response
exception error
VictoriaLogs url is mandatory
validation error yaml, configuration, victorialogs
while dumping console config to
validation error filesystem, permissions, file-write
cannot register stream consumer
exception error aws, kinesis, efo, permissions
empty host
validation error dsn, configuration, victorialogs
expected zero or one argument for 'end_date'
validation error
missing
validation error auth, http, request-binding, json, go
unable to parse time
error_code error database, crowdsec, time, parsing
unable to update bouncer stream pull in database
exception error database, ent, sqlite, bouncers, stream
unsupported mode for file source
validation error config, file-source, enum
while parsing duration
exception error go, lapi, duration
listening on
exception error network, bind, port
nil alert
validation error
PRI too long
validation warning syslog, parsing, rfc3164
isn't managed by hub
exception error hub, symlink, item-management
starting crowdsec daemon
exception error subprocess, crowdsec, test-harness, exec
while getting decision
exception error database, ent, query, blocklist, decisions
while setting security info
exception error windows, acl, setsecurity, permissions
appname is empty
validation error
cloudwatch path must contain group and stream …
validation error cloudwatch, aws, dsn, url
could not encode jwt auth body
exception error
could not remove all inotify watches
exception error
expired decisions with filters
exception error database, crowdsec, filter-parsing, lapi