crowdsecurity/crowdsec
Documented errors, page 6 of 11. Back to crowdsecurity/crowdsec
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| cannot specify both group_id and partition | validation | error | kafka, config, validation |
| MachineID not found in claims | http | error | jwt, claims, machine, lapi |
| security descriptor is invalid | exception | error | windows, security, plugin, permissions |
| server_cert is required | validation | error | crowdsec, http-acquisition, tls, config-validation |
| server_key is required | validation | error | crowdsec, http-acquisition, tls, config-validation |
| version must be followed by a space | validation | error | syslog, rfc5424, parsing, truncated-message |
| appname is too long | validation | error | |
| expiring decisions error | exception | error | |
| failed to decode obfuscated fingerprint | exception | warning | appsec, base64, fingerprint, validation |
| GrantChallengeCookie accepts at most one TTL argument, got | validation | error | |
| plugin broker | exception | error | plugins, notifications, configuration |
| while parsing simulation file | exception | error | yaml, simulation, config |
| while removing file | exception | error | filesystem, permissions, file-delete |
| cannot copy a folder onto itself | exception | error | filesystem, copy, path-validation |
| empty journalctl:// DSN | validation | error | dsn, journalctl, config |
| failed to generate nonce | exception | critical | appsec, crypto, entropy, csprng |
| failed opening connection to | exception | error | database, connection, ent-orm |
| invalid type for ip : %T | validation | error | expr, type-mismatch, cti |
| missing lapi client credentials | validation | error | appsec, lapi, credentials, configuration |
| PRI must be up to 3 characters long | validation | error | syslog, rfc5424, parsing, value-out-of-range |
| ' ' is not a boolean | exception | error | go, lapi, query-params |
| websocket error | exception | error | loki, websocket, network |
| while describing group | exception | error | aws, cloudwatch, iam, network |
| failed to parse feature flags | exception | error | go, yaml, config, feature-flags |
| multiple headers with name | validation | error | appsec, openapi, api-key, header, duplicate |
| user/password authentication and TLS authentication are… | validation | error | go, config, tls, authentication |
| while getting DACL | exception | error | windows, acl, security |
| while syncing | exception | error | go, hub, versioning |
| failed to get docker info | exception | error | docker, network, daemon |
| loki query is mandatory | validation | error | config, loki, validation, acquisition |
| consumer is not deregistered after tries | exception | error | aws, kinesis, timeout |
| couldn't find custom scenario | exception | error | crowdsec, hub, scenario, testing |
| empty scope information | exception | error | crowdsec, leakybucket, scope, config-validation |
| failed to create wasm runtime in compiler mode | exception | critical | go, wasm, wazero, seccomp, selinux, containers |
| failed to parse api server credentials configuration file | validation | error | |
| unable to update allowlist | exception | error | database, allowlist, update, unique-constraint |
| CS_LAPI_SECRET not strong enough | validation | error | configuration, jwt, env-var, security |
| empty loki host | validation | error | dsn, loki, config, url |
| failed to load system cert pool | exception | error | tls, x509, certificates, http |
| feature flag | exception | error | go, feature-flags, validation, naming |
| invalid Loki entry: expected [timestamp, line], got | validation | error | loki, json, acquisition |
| nil message | exception | error | |
| no zones defined | validation | error | appsec, rules, validation |
| on_challenge hooks are only valid in-band, not under… | validation | error | appsec, config, crowdsec, hooks |
| bouncer already exists | exception | error | database, bouncer, duplicate, constraint |
| unable to create directory | exception | error | filesystem, mkdir, permissions, test-harness |
| unable to update bouncer ip address in database | exception | error | database, ent, bouncers, middleware |
| appsec rule name is empty for | validation | error | appsec, config, hub, validation |
| certificate revoked by OCSP | http | critical | tls, mtls, ocsp, revocation, certificate |
| missing API key | error_code | error | |
| no filename or filenames configuration provided | validation | error | |
| unable to update machine last pull in database | exception | error | database, ent, sqlite, bouncers |
| while initializing cache | exception | error | parser, stash, cache, config |
| cannot create a reader with an empty list of broker… | validation | error | go, kafka, configuration, brokers |
| hex master secret decodes to | validation | error | crypto, hex, configuration |
| unable to find grok | exception | error | parser, grok, config, crowdsec |
| unable to parse as unix timestamp | exception | error | expr, timestamp, parsing |
| while pulling blocklist | exception | error | |
| appsec_config and appsec_config_path are mutually exclusive… | validation | error | |
| failed to generate DB connection string | exception | error | database, configuration, crowdsec |
| missing filter directive | validation | error | crowdsec, leakybucket, config-validation, expr |
| onsuccess not continue,next_stage | validation | error | parser, validation, config, crowdsec |
| : must be a relative path | exception | error | security, path, validation |
| unable to delete bouncers | exception | error | database, ent, sqlite, bouncers |
| unable to serialize | error_code | error | database, crowdsec, json, serialization |
| while creating machine entry for | exception | error | tls, mtls, database, auth, go |
| can't get absolute path of hub | exception | error | filesystem, paths, hubtest |
| error when starting acquisition | exception | error | victorialogs, acquisition, startup |
ErrUserCanceled operation canceled | error_code | info | go, cli, hub, user-abort |
| failed to stat | exception | error | filesystem, lstat, permissions, symlink |
| jsonExtractType: expected type | exception | error | go, json, type-mismatch, schema |
| listen_port cannot be empty | validation | error | kubernetes, audit, config-validation, webhook |
| unable to symlink parser | exception | error | hubtest, symlink, filesystem, windows |
| while closing reader on topic | exception | warning | kafka, shutdown, kafka-go, crowdsec |
| while getting last pull timestamp for blocklist | exception | error | database, config-item, blocklist, pull-timestamp |
| while starting VictoriaLogs tail | exception | error | streaming, victorialogs, tail, startup |
| failed creating schema resources | exception | error | database, migration, schema |
| failed to compile obfuscator wasm module | exception | critical | go, wasm, wazero, startup |
| listing machines | exception | error | database, query-failed, crowdsec, sqlite |
| rule expansion produced | exception | error | |
| while updating allowlist meta | exception | error | database, allowlist, metadata, update |
| basename: want string, got %T | exception | error | expr, type-mismatch, hubtest, helpers |
| error while reading tail response | exception | error | network, streaming, victorialogs, io |
| invalid limit in dsn | validation | error | config, loki, parsing |
| listen_addr or listen_socket is required | validation | error | |
| missing mandatory 'tag' field in | validation | error | data-files, validation, crowdsec |
| query is mandatory (at least start_date and end_date or… | validation | error | cloudwatch, aws, dsn, url |
| unable to init database client | exception | critical | database, startup, configuration |
| unable to read logs from service | exception | error | docker, swarm, logs, acquisition |
| unable to update machine IP in database | exception | error | database, update-failed, crowdsec, authenticator |
| unknown ip size | validation | error | database, network, internal, filter |
| couldn't find custom appsec-rule | exception | error | hub, test, custom-item, not-found |
ErrChallengePayload invalid challenge response payload | validation | error | |
| expected zero or one value for 'profile' | validation | error | |
| hard delete decisions with provided filter | exception | error | go, database, delete, ent |
| unable to flush alerts older than | exception | error | go, database, crowdsec, flush |
| failed to decompress obfuscator wasm | exception | critical | go, wasm, gzip, embedded-assets |
| message is empty | validation | error | go, syslog, rfc3164, parsing, empty-message |
| on_unsupported_security_scheme | exception | error | appsec, configuration, enum, policy |
| while checking if we should force pull blocklist | exception | error | database, blocklist, capi, pull |