apache/seatunnel
Documented errors, page 3 of 22. Back to apache/seatunnel
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Unsupported action type: | exception | error | elasticsearch, catalog, unsupported-action, preview |
| Kerberos authentication is not configured, it will skip… | console | warning | kerberos, iceberg, authentication, security |
| Stripe option 'page_size' must be between 1 and 100 | validation | error | config-validation, range-check, http-connector |
| Unable to initialize metrics context for file source… | console | warning | file-connector, metrics, split-enumerator |
| can't find task group address from taskGroupLocation | exception | error | jobmaster, task-scheduling, slot-profile, internal-state |
| Failed to drop table | exception | error | elasticsearch, catalog, drop-table, http-error-response |
| setTypeInfo method is not supported | exception | error | |
| Stripe API rate limit reached, retry | console | warning | http, rate-limit, retry, api |
| Cannot read the binlog filename and position via | exception | error | mysql, cdc, binlog, server-configuration, snapshot |
| e.getMessage() (wrapped SeaTunnelRuntimeException from… | validation | error | config-validation, starrocks, option-validation |
| Failed to execute query | exception | error | clickhouse, sql, query, jdbc |
KAFKA_TRANSACTION_NOT_STARTED Kafka transaction [ ] has record(s) but is still reported as not started after… | error_code | critical | kafka, transactions, exactly-once, data-loss-prevention |
| Failed to load readyToCloseStartingTask from IMap, key | exception | critical | zeta-engine, checkpoint, imap, hazelcast, failover |
| Failed to read data from sql | exception | error | clickhouse, sql, query, source-reader |
HANDLE_SAVE_MODE_FAILED All candidate sink tables were skipped during cluster save mode. | error_code | error | sink, save-mode, multi-table, job-failed |
| SeaTunnel job executed failed | exception | critical | job-execution, command-execution, wrapper-exception |
| tables_configs[ ]: 'cql' must not be blank | validation | error | cassandra, config-validation, source-connector |
| The head sequence is greater than the committed event index | console | warning | logging, ringbuffer, observability |
| The table changes should only have one element | exception | error | cdc, schema-history, debezium, data-corruption |
| Unsupported type: | exception | error | |
COMMON_WRITER_OPERATION_FAILED unable to open JDBC exactly one writer | error_code | error | jdbc, xa, exactly-once, sink, initialization |
| Encountered change event for table | exception | critical | binlog, schema-history, mysql-cdc, streaming, deserialization |
| Failed to create BigQuery table: | exception | error | bigquery, gcp, create-table, permissions, schema |
| Read snapshot for split | exception | critical | mysql, cdc, snapshot, illegal-state |
| ' ' duplicate in ' '. | validation | error | |
| Failed to create BigQuery dataset: | exception | error | bigquery, catalog, dataset-creation, gcp |
| Map type requires Map value, got | validation | error | arrow, map-type, type-mismatch, lance |
| Please configure unique `table_name`, not allow… | validation | error | hudi, config, duplicate-table-name, validation |
| resetting default realm failed, current default realm will… | console | warning | kerberos, kudu, authentication, config |
| The status of open scanner result from | console | warning | doris, backend, thrift, scanner, retry |
| Unable to find table in relational model | exception | error | oracle, cdc, logminer, schema, table-not-found |
| Unsupported dry-run mode | validation | error | cli, dry-run, argument-parsing |
RedisErrorCode-01 Failed to get the redis version | error_code | error | redis, jedis, version-detection |
| System or JVM property | exception | error | mysql, configuration, system-properties, conflict |
| The DB connection is not a valid replication connection | exception | error | postgresql, cdc, replication, jdbc, connection |
| Close file output stream | console | warning | ioexception, hadoop, file-close, storage |
| connector-jar-storage-mode must in [SHARED, ISOLATED] | validation | error | config, zeta, enum, connector-jar |
| Failed to get file status | exception | error | sftp, ioexception, file-status, network |
| Failed to read schema for table | exception | error | mysql, cdc, jdbc, schema-introspection |
| source register failed. | console | error | zeta-engine, source-reader, cluster-communication |
| Could not parse duration value | validation | error | |
| Failed to release error sink classloader for jobId= | console | warning | classloader, resource-leak, cleanup |
| Multiple MetadataProvider implementations found for kind | exception | error | |
| Skipping unsupported default value for column | console | warning | jdbc, dameng, schema-evolution, default-value |
| The job id is waiting for terminal state cleanup, please… | exception | error | zeta-engine, job-submission, jobid-reuse |
HttpConnectorErrorCode.REQUEST_FAILED http client execute exception, http response status code | error_code | error | http, network, prometheus, connector |
LOAD_HIVE_BASE_HADOOP_CONFIG_FAILED Failed to load hadoop configuration, please check it | error_code | error | hadoop, hive, config-load |
| Post-sync backup failed: backup target path is empty… | console | warning | hadoop, file-source, backup, retryable |
| PostgreSQL-CDC schema evolution requires… | validation | error | postgresql, cdc, config-validation, schema-evolution |
| The String type in Doris can only store up to 2GB bytes… | console | warning | doris, type-conversion, string-length, schema |
| Unsupported data type: | exception | error | influxdb, timestamp, serialization, sink |
UNSUPPORTED_OPERATION Unsupported operation | error_code | error | cdc, rowkind, serialization, json-format |
| Failed to close the JDBC source connection after… | console | warning | jdbc, connection, close, resource-leak, cleanup |
| Interrupted while emitting initial DROP TABLE events | exception | info | mysql, cdc, snapshot, interruption, cancellation |
| Multiple DebeziumAdapters matched connector class " +… | exception | error | cdc, classpath, duplicate-plugin, initialization |
| recovery after rollback prepared transaction failure also… | console | error | jdbc, xa, recovery, distributed-transaction, in-doubt-transaction |
| Circular condition chain detected | validation | error | filesystem, io, file-discovery, hadoop |
CLICKHOUSE_GET_TABLE_LIST_CONFIG_ERROR PluginName: , PluginType: , Message | error_code | error | clickhouse, config, source, missing-table |
CONNECTION_FAILED Failed to create Google Pub/Sub publisher for topic | error_code | critical | google-pubsub, connection, authentication, java |
| Failed to call factoryIdentifier method. | exception | error | spi, reflection, classpath, zeta-engine |
| Index: , Fields size | exception | error | index-out-of-bounds, doris, schema-parsing |
IotdbConnectorErrorCode.CLOSE_SESSION_FAILED Close IoTDB session failed | error_code | warning | iotdb, session-close, network |
| MySQL-CDC diagnostic: connected to MySQL hostname= | console | info | mysql, cdc, diagnostics, server-identity |
| Post-sync backup skipped because target already exists… | console | warning | hadoop, file-source, backup, file-already-exists |
| Primary key( ) is not in table( ) columns( ) | exception | error | cdc, configuration, primary-key, schema-mismatch |
| Run SeaTunnel on spark failed | exception | error | spark, command-execution, job-failure |
| schema-change checkpoint | exception | error | checkpoint, schema-change, barrier, state-machine |
| Failed to alter table add column, SQL: | console | warning | doris, ddl, schema-change, sql, jdbc |
| Failed to update offset for skipped event | console | warning | mysql, cdc, binlog, offset, logging |
UNSUPPORTED_SCHEMA_CHANGE_TYPE PostgreSQL CDC currently supports only ADD COLUMN relation changes. The job… | error_code | error | postgres, cdc, schema-change, unsupported-operation |
| begin next transaction failed, rollback prepared… | console | error | jdbc, xa, distributed-transaction, prepare-commit, rollback-failure |
DATE_BASE_ERROR ${e.getMessage()} | error_code | error | java, neo4j, cypher, database |
| Received AlterTableEvent but schema_evolution_enabled=false… | validation | error | file-sink, schema-evolution, cdc, config |
| SeaTunnel server is not available on this node. | exception | error | rest-api, cluster, engine, state |
| unable to rollback prepared transaction, xid= | console | warning | jdbc, xa, distributed-transaction, rollback-failure |
| Unsupported schemaChangeEvent | exception | error | schema-change, cdc, unsupported-operation, doris |
| Checkpoint is enabled and job starts with savepoint, but… | exception | critical | checkpoint, savepoint, state, job-restart |
| create(): Mkdirs failed to create | exception | error | sftp, io, mkdir, file-write |
| Failed to load JDBC driver com.mysql.cj.jdbc.Driver | console | warning | mysql, jdbc, classpath, dependency |
INITIALIZE_HIVE_METASTORE_CLIENT_FAILED Failed to initialize HiveMetaStoreClient | error_code | error | hive-metastore, connection, initialization |
| MySQL-CDC diagnostic | console | warning | mysql, cdc, diagnostics, logging |
WRITER_OPERATION_FAILED Get parquet writer for file | error_code | critical | parquet, io, file-sink, writer |
COMMON_ERROR_CODE-1 ReadColumn: unsupported ORC file column type: | exception | error | orc, unsupported-type, file-connector, schema |
| current cache size = | exception | error | tikv, scan-iterator, batching, internal-invariant |
| Failed to close PreparedStatement during schema change | console | warning | jdbc, statement, schema-change, resource-cleanup |
| Failed to get table: | exception | error | lance, catalog, storage |
INVALID_SCHEMA_STRUCTURE Failed to resolve PostgreSQL RELATION schema change for | error_code | critical | postgresql, cdc, schema-evolution, schema-resolution |
| master not yet known | exception | warning | cluster, master-election, retryable, rest-api |
| Some vertices may not be reporting metrics yet for table | console | warning | metrics, rest-api, partial-data |
| Table does not exist in catalog hive | exception | error | hive, catalog, table-not-exist, metastore |
| unable to close XA connection | console | warning | jdbc, xa, connection-close, resource-leak |
| [ ] request http failed | console | warning | http, retry, network |
| Target BigQuery table | exception | error | bigquery, schema-validation, save-mode, column-missing |
| Continuous discovery scheduler does not terminate in 5… | console | warning | file-connector, scheduler, shutdown, timeout |
| Failed to get table schema from catalog, will try to infer… | console | warning | catalog, schema, fallback, databend-source |
| unable to fail/rollback current transaction, xid= | console | warning | jdbc, xa-transaction, rollback, exactly-once, database |
| Unexpected default trust managers: | exception | error | ssl, tls, elasticsearch, jdk-compatibility |
| Connect to doris failed. | console | error | network, thrift, doris, connectivity |
DATA_TYPE_CAST_FAILED error field: | error_code | error | jdbc, type-conversion, data-quality, sink |
| Failed to close SQL cursor | console | warning | elasticsearch, cleanup, network |