apache/seatunnel
Documented errors, page 2 of 22. Back to apache/seatunnel
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Unsupported required option type | validation | error | rest, internal, unsupported-type, option-rules |
| Can not sync pipeline owned slot profiles with IMap | exception | error | imapping, slot-profile, retry-exhausted, jobmaster |
| formatErrorMessage(action, xid, errorCode, errorMessage) | console | warning | jdbc, xa, rollback, transaction |
| Hadoop found on classpath but could not create config… | console | warning | hadoop, iceberg, classpath, reflection |
| Unable to filtered publication for | exception | error | postgresql, cdc, replication, publication, sql |
| checkpoint.interval is set to | console | warning | flink, checkpoint, configuration, fallback |
| ColumnNotExistException | exception | error | paimon, schema-evolution, missing-column, alter-table |
| DamengDB does not support modifying the TEXT type directly… | console | warning | jdbc, dameng, schema-evolution, ddl |
| Fail to deserialize row | exception | error | cdc, tidb, deserialization, schema-mismatch |
| HugeGraph does not provide a SeaTunnel Catalog; schema and… | exception | error | unsupported-operation, catalog, hugegraph, sink, save-mode |
| The catalog: is not supported the getTableWithConditionSql… | console | warning | jdbc, catalog, unsupported-operation, fallback |
| Cannot compare null values in numeric comparison… | validation | error | |
| ' ' duplicate in options. | validation | error | |
| SeaTunnel avro format is not supported for this data type | exception | error | protobuf, data-type, type-conversion |
| Ambiguous timeout on Couchbase write | console | warning | couchbase, timeout, retry, idempotency |
| Error sink previously failed for stage | exception | error | error-sink, route-mode, task-failure, zeta-engine |
| Failed to fetch running jobs from IMap during master switch… | exception | error | hazelcast, imap, failover, master-switch, zeta-engine |
| No mappings matched table | console | warning | hugegraph, config, no-op, mapping |
| Unsupported timestamp type: | exception | error | java, aerospike, timestamp, type-mismatch |
| Failed to evaluate recovered split | console | warning | file-connector, checkpoint-recovery, filesystem |
| Running job dag json cache evicted entries due to max size… | console | info | cache, rest-api, zeta-engine |
| Failed to validate BigQuery schema coherence | exception | error | bigquery, schema-validation, save-mode, api-error |
| No upstream source or transform is available for sink. | validation | error | dry-run, dag, missing-upstream, config-validation |
| Online REDO LOG files or archive log files do not contain… | exception | error | cdc, oracle, logminer, scn, redo-log, snapshot-required |
| Some sink tables were skipped in Flink starter. | console | warning | flink, sink, multi-table |
| Unable to load Hive metastore client factory | exception | critical | hive, classpath, reflection, connector |
| Condition for option | validation | error | filesystem, io, file-discovery, hadoop |
| Failed to calculate oldest SCN available in logs | exception | critical | oracle, cdc, logminer, archived-log, scn |
| Failed to list BigQuery databases (datasets) | exception | error | bigquery, gcp, authentication, network, metadata |
| MySQL-CDC diagnostic: cannot compare binlog sequence… | console | warning | mysql, cdc, binlog, diagnostics |
| can't support custom load jar | exception | error | classpath, plugin-discovery, jdk, unsupported-operation |
| Failed listing database in catalog | exception | error | |
| listDatabases failed via getAllDatabases(), check HMS… | console | error | hive, metastore, thrift, version-compatibility, catalog |
| Plugin type must be one of: [source, sink, transform] | validation | error | cli, enum, argument-parsing |
| Shallow key discovery failed on path | console | warning | firebase, split-enumerator, fallback, parallelism, log-warn |
| Cannot obtain valid replication slot | console | warning | cdc, postgresql, replication-slot, retry |
| Failed getting table | exception | error | sap-hana, catalog, metadata, jdbc |
| Time values must use number of milliseconds greater than 0… | exception | error | java, cdc, time-conversion, value-out-of-range |
COMMON_UNSUPPORTED_DATA_TYPE Time series type expected for field | error_code | error | excel, type-mismatch, data-types |
CommonErrorCodeDeprecated.UNSUPPORTED_OPERATION Archived entry [ ] is %,d bytes, larger than POI limit %,d bytes. Please set… | error_code | error | file, excel, archive, size-limit |
| FTP connection active mode test failed | exception | warning | ftp, network, firewall, fallback |
CLIENT_CREATE_FAILED Failed to create BigQueryWriteClient | error_code | critical | bigquery, client-initialization, credentials, gcp |
| Post-sync cannot restore staged source while waiting for… | console | warning | hadoop, file-source, staging, restore-failed, retryable |
| python.working.directory is not a directory | validation | error | config, filesystem, validation |
TABLE_NOT_EXISTED Cannot get table from clickhouse, resultSet is empty | error_code | error | clickhouse, table-not-found, metadata, empty-result |
| Cannot find table schema for table | exception | error | postgresql, cdc, snapshot, table-schema, config |
| Failed to serialize EdgeIngressPacket to JSON | exception | error | serialization, json, jackson, runtime |
| Table does not exist in catalog | exception | error | mongodb, catalog, table-not-exist |
| Unsupported SQL type | console | warning | jdbc, type-mapping, fallback, databend |
| Hive metastore client factory | exception | error | hive-metastore, reflection, class-not-found |
| Operator requires an expectValue, but expectValue is null | validation | error | excel, schema, unsupported, connector-file |
| Read split error due to . | exception | error | cdc, snapshot-scan, database, exception-wrapping |
| The decimal column type decimal( , ) is out of range, which… | console | warning | jdbc, phoenix, decimal, type-conversion, schema |
| Unsupported JDBC type: | exception | error | jdbc, type-mapping, unsupported-operation |
LOAD_CATALOG ${e.message} | error_code | error | paimon, catalog, initialization, wrapped-exception |
| NebulaGraph sink writer is already closed. | exception | error | java, sink, lifecycle, nebulagraph |
| sendUntilReceived exhausted reconnect cycles for batchId= | exception | error | retry, reconnect, socket, unacknowledged-batch |
| ${CommonError.convertToConnectorPropsBlankError(Paimon… | validation | error | paimon, configuration, blank-property, validation |
| Invalid regex pattern in `table_name`: , resolved pattern: | validation | error | hive, regex, config |
RABBITMQ-01 handle queue consumer shutdown signal failed | error_code | error | rabbitmq, amqp, consumer, shutdown, interruption |
| can't apply resource request with retry times | exception | error | zeta-engine, resource-allocation, no-enough-resource |
| Error adding Hadoop resource | console | warning | hadoop, iceberg, config, io |
| Failed to consume python source stdout | exception | critical | python, subprocess, stream-consumption, process-crash |
| wait worker register error | exception | error | interrupted, worker-registration, failover, zeta-engine |
| Airtable API rate limit reached, retry | console | warning | airtable, rate-limit, http-429, retry, source |
| Failed to read data from part | exception | error | clickhouse, query, network, source-reader |
SCROLL_REQUEST_ERROR POST response null | error_code | error | http, null-response, scroll, easysearch |
| set checkpoint.mode failed, unknown checkpoint.mode | validation | warning | flink, config, checkpointing |
| Single file mode is not supported when file_name_expression… | exception | error | file-sink, parallelism, configuration |
| Error reading MySQL variables | exception | error | mysql, jdbc, variables, cdc, sql |
| Invalid bytes for Decimal field | exception | error | cdc, debezium, decimal, type-conversion |
| Text file does not support this compress type | console | warning | file-connector, compression, unsupported-compress-codec |
| TIMESTAMP_TZ is written to Xugu as a plain TIMESTAMP: the… | console | warning | jdbc, xugu, timestamp, timezone, driver-limitation |
| Unknown SQLServer binary type | console | warning | jdbc, sqlserver, type-mapping, binary-data |
| wrong target release operation with job | console | warning | zeta-engine, slot-management, stale-state |
| Batch write failed ( element(s)); falling back to… | console | warning | hugegraph, batch, fallback, sink |
| Failed to consume python source stderr | exception | critical | python, subprocess, stream-consumption, process-crash |
| Failed to resolve datasource config for connector | exception | error | |
| Ingress queue at backpressure watermark, returning… | console | warning | backpressure, queue-full, socket-source, throttling |
| The S3A credentials provider chain configured via | validation | error | s3, config, validation |
| The S3A credentials provider class | validation | error | config, aws-s3, validation |
CommonErrorCodeDeprecated.FLUSH_DATA_FAILED Writing records to IoTDB failed. | error_code | error | iotdb, sink, write-failure, retry-exhausted |
| Could not load service provider for MetadataProvider. | exception | error | |
| paimon privilege is enabled, user and password is required | exception | error | paimon, authentication, missing-credentials, catalog |
| Reader is not registered. Pending splits are not assigned. | console | warning | iceberg, source, split-assignment, reader-registration |
| Skipped unparseable FTP listing entries under | console | warning | ftp, listing, parsing, listing-parsing |
| The connector option 'flush_interval' has been removed and… | console | warning | config, deprecated, prometheus |
| checkpoint do not exist or have already been committed. | console | warning | rocketmq, checkpoint, offset-commit, idempotency |
| Column already exists in table . Skipping add column… | console | warning | starrocks, schema-change, idempotency |
| Failed TRUNCATE TABLE in catalog | exception | error | |
FLUSH_DATA_FAILED Writing records to IoTDB failed. | error_code | critical | iotdb, write-failure, retry, flush |
| System or JVM property | exception | error | configuration, jvm, conflict, cdc |
GRAPH_OPERATION_FAILED Mapping[ / ]: Failed to compute graph element ID for update | error_code | error | hugegraph, graph-sink, cdc-update, id-extraction |
| Interrupted while waiting for valid replication slot info | exception | error | postgres, opengauss, cdc, replication-slot, interruption |
| prepare method is not supported | exception | error | excel, configuration, enum, connector-file |
| SeaTunnel job on spark engine deploy mode only support… | validation | error | spark, cli, validation |
| Single-record fallback completed | console | warning | hugegraph, batch-write, dirty-data, sink |
| Some sink tables were skipped in Spark starter. | console | warning | spark, sink, multi-table |
| Invalid table name | validation | error | oracle-cdc, config-validation, table-name-format |
| does not support writing both a multi-table source and… | validation | error | dry-run, sink, multi-table, dag-validation |