apache/pulsar
Documented errors, page 9 of 15. Back to apache/pulsar
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Failed to increment key | exception | error | state, bookkeeper, counter, blocking-call |
| Go instance current not support EFFECTIVELY_ONCE processing… | panic | critical | go, processing-guarantees, unsupported-feature, configuration |
| Invalid checkpoint data: empty | exception | error | deserialization, checkpoint, corrupt-data |
| Invalid schema type . Valid options are: avro, json | validation | error | cli, schema, validation |
| Positions must not be null | validation | error | null-check, illegal-argument, positions, managed-ledger |
| ' ' is not found | http | error | rest-api, not-found, functions, state |
| Cloning a generated a , this is a bug, original error is | exception | error | bug, reflection, internal |
| Failed to start zookeeper | exception | critical | zookeeper, metadata-store, pulsar-proxy, startup |
| Must pass one of the params: --bundle / --bundle-type | validation | error | cli, parameter-validation, pulsar-admin, bundle-splitting |
| No version string in lookup data for broker | exception | warning | load-manager, broker-filter, version-comparison, missing-metadata |
| Per instance CPU requested is not specified. Must specify… | validation | error | kubernetes, resources, cpu, validation, admission |
| The message payload processor class | validation | error | pulsar-functions, payload-processor, class-not-found, bytebuddy |
| Broker id ' ' not found in available brokers. | http | error | |
| Cluster [ ] is not in the list of allowed clusters list for… | http | error | authorization, http-403, tenant, cluster |
| Expected target metadata store to be Oxia | exception | error | metadata-store, migration, oxia, configuration |
| Failed to read token from file | exception | error | token-auth, file-io, ioexception, configuration |
| Invalid key format | validation | error | pulsar, encryption, uri, configuration |
| Invalid number of bundles. Number of bundles has to be in… | http | error | validation, namespaces, bundles |
| PulsarAdmin is not enabled in function worker | exception | error | pulsar-functions, configuration, pulsar-admin, security |
| Sink name is not provided | http | error | rest-api, bad-request, validation, pulsar-sinks |
| Source class does not implement the correct interface | validation | error | pulsar-functions, connector-interface, type-mismatch, pulsar-io |
| Timeout during clear backlog operation | exception | error | azure, configuration, env-var, credentials |
| A future has already been attached to this instance. | exception | error | concurrency, async, future, state |
| Error starting LogTopic Producer for function | exception | error | java, pulsar-functions, producer, log-topic, startup |
| Failed to create base storage directory at | exception | critical | filesystem, io, permissions, startup, storage |
| Failed to obtain broker-client authentication TLS material | exception | error | tls, authentication, supplier, wrapped-exception |
| Malformed authentication parameters | validation | error | pulsar-client, oauth2, json, configuration |
| Metadata store is not configured for migration. Please… | http | error | metadata-migration, configuration, bad-request |
| No token credentials passed | exception | error | jwt, token, authentication |
| Source class implements but batch source source config is… | validation | error | pulsar-functions, config-validation, batch-source |
| Timeout during delete operation | exception | error | configuration, validation, offload, bucket |
| UnsupportedOperationException | exception | warning | java, unsupported-operation, iterator |
| Failed to get permissions | http | error | pulsar, rest-api, authorization, internal-error |
| ManagedLedgerFactory is already closed. | exception | error | lifecycle, managed-ledger, factory-closed, state |
| No secret key was provided for token authentication | validation | critical | configuration, authentication, missing-key, startup |
| Output Serde mismatch | validation | error | pulsar-functions, immutable-field, update-validation, serde |
| Try to reserve/release memory failed, the param memorySize… | validation | error | pulsar, memory-limit, validation, client |
| Unauthorized to validateBothTenantOperationAndSuperUser for… | http | warning | authorization, security, rest-api, tenant |
| Unknown consumer crypto failure action | exception | error | enum, crypto, mapping, version-compatibility |
| Cannot handle messages with null messages | exception | error | pulsar, acknowledgment, null-check, batch |
| configProperties cannot be null | validation | error | configuration, null-check, validation |
| Failed to clone ReaderConfigurationData | exception | error | clone, reader, internal, configuration |
| Invalid signed text: | exception | error | authentication, sasl, signature, security |
| Kubernetes does not allow upper case jobNames. | validation | error | kubernetes, functions-runtime, naming |
| Too few workers (need at least 2) | http | error | rest-api, functions-worker, cluster-topology |
| Could not start MetaData topic tailer | exception | critical | pulsar-functions, worker, metadata, tailer, pulsar-client |
| Couldn't get the access key secret. | validation | error | configuration, environment-variables, aliyun-oss, credentials |
| Didn't find in built-in connectors | exception | error | configuration, connectors, builtin, pulsar-functions |
| Field ' ' must be a Positive Number | validation | error | config-validation, positive-number, illegal-argument |
| Function language runtime is either not set or cannot be… | validation | error | pulsar-functions, config-validation, runtime |
NO_PUBLIC_KEY Unable to retrieve ZTS Public Key | exception | error | athenz, authentication, public-key, key-rotation |
| Segment topic not loaded | http | warning | rest, not-found, segment, backlog, polling, http-404 |
| Unauthorized to validateTenantOperation for… | http | warning | http-401, authorization, tenant, rbac |
| Cannot compare with | exception | error | message-id, comparison, illegal-argument |
| Cannot convert from to . Conversion failed with | exception | error | reflection, number-format, configuration |
| Invalid MetadataStoreConfig query parameter | validation | error | configuration, url-parsing, metadata-store, malformed-url |
| MessagePayloadProcessor class name required | validation | error | pulsar-functions, config-validation |
| No factory is found for name | exception | error | |
| start function failed, please check. | panic | critical | go, startup, panic, function-lifecycle |
| The schema class does not exist | validation | error | pulsar-functions, schema, class-not-found, bytebuddy |
| Timeout during delete-cursors operation | exception | error | configuration, validation, offload, block-size |
| (wraps reflective instantiation failure for… | exception | error | reflection, broker-entry-metadata, configuration, pulsar-common |
| Action name is empty! | validation | error | pulsar-io, validation, builder |
| Error compacting | exception | error | compaction, broker, bookkeeper |
| extension for ` ` attempts to use for its listening port… | exception | critical | pulsar-proxy, extensions, port-conflict |
| Failed to create instance for message payload processor… | exception | error | pulsar-functions, reflection, instantiation, message-payload-processor |
| Failed to decode public key | validation | error | authentication, crypto, key-parsing, java |
| Failed to read decryption key from | exception | error | io, filesystem, encryption, cli |
| Invalid segment topic name: local name must contain… | validation | error | java, illegal-argument, segment-domain, topic-name, pulsar |
| Keyname or KeyReader is null | validation | error | configuration, null-check, encryption, crypto-key-reader |
| No latest service lookup data found. | exception | error | load-manager, redirect, race-condition, lookup-data |
| Schema file is not found. Relative path is resolved to … | exception | error | cli, schema, file-not-found, filesystem |
| This method cannot be used under this SEPARATED encoding… | exception | error | schema, keyvalue, encoding |
| Timeout during managed ledger delete operation | exception | error | timeout, managed-ledger, delete, bookkeeper |
| Version mismatch, actual= | exception | error | rocksdb, optimistic-concurrency, version-conflict |
| Can't get accurate schema information for topic | exception | error | pulsar, schema, auto-consume, schema-info-provider, serialization |
| Effectively-once processing guarantees not yet supported in… | exception | error | pulsar-functions, go-runtime, processing-guarantees, unsupported-feature |
ERROR_DECODING_JWT Invalid token: cannot be null | exception | error | auth, oidc, jwt, null |
| Expected MessageIdV5, got: + messageId.getClass() | exception | error | pulsar, messageid, transaction, cumulative-ack |
| Fail to create RocksDB file directory | exception | error | rocksdb, filesystem, permissions |
| Failed to retrieve Cluster data due to empty… | exception | critical | configuration, metadata, startup |
| Illegal base64 character or Key file | validation | error | authentication, crypto, base64, configuration |
| Incorrect custom schema inputs,Topic | validation | error | pulsar-functions, schema, json, configuration |
| Invalid Fully Qualified Function Name | exception | error | pulsar-functions, parsing, fqfn, validation |
| Namespace already references a resource group | exception | error | |
| schema type must be 'bytes' or 'auto_consume' | validation | error | cli, schema, validation, arguments |
| Bucket cannot be empty for Local offload | validation | error | |
| Could not examine messages due to the total message is zero | http | error | |
| description should be at most 64 characters | validation | error | |
| Does not support topic domain: | exception | error | parsing, validation, topics |
| earlyTokenRefreshPercent must be greater than 0. | validation | error | pulsar-client, oauth2, configuration, argument-validation |
| Invalid data found | exception | critical | bookkeeper, underreplication, corrupt-data, layout |
| Unauthorized to validateNamespaceOperation for operation | http | warning | http-403, authorization, namespace, rbac |
| authentication plugin does not expose… | exception | error | pulsar, authentication, binary-transport, unsupported-authentication |
| Failed to initialize Metadata Manager | exception | critical | pulsar-functions, worker, metadata, startup, pulsar-client |
| Failed to refresh self owner info. | exception | critical | startup, namespace-ownership, metadata-store, zookeeper |
| Function class does not implement the correct interface | validation | error | pulsar, functions, java, type-check |
| Function Name not provided | validation | error | cli, validation, naming, pulsar-functions |
| FunctionID not set | validation | error | pulsar-functions, function-cache, null-argument |
| Invalid MessageIdV5 data: too short | exception | error | deserialization, message-id, corrupt-data |