apache/pulsar
Documented errors, page 8 of 15. Back to apache/pulsar
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Could not open configuration file | exception | error | configuration, startup, io |
| delta at index must be >= 0, got | exception | error | metadata, argument-validation, sequence-deltas |
| Failed at fetching schema info for… | exception | error | pulsar, schema, schema-version, fetch-failed |
| Invalid MetaValue data, size= | exception | error | rocksdb, corruption, serialization, metadata-store |
| Invalid package name | validation | error | validation, naming, package-management |
| Invalid pulsar service | validation | error | uri, config, service-uri |
| Key schemas or Value schemas are different schema type… | exception | error | pulsar, key-value-schema, compatibility |
| No Function Classname specified | validation | error | cli, functions, missing-argument, validation |
| Sink config is not provided | http | error | rest-api, bad-request, validation, pulsar-sinks |
| Sink name cannot be null | validation | error | pulsar, config-validation, sink, illegal-argument |
| Timeout during skip messages operation | exception | error | azure, configuration, env-var, credentials |
| directory does not have read/write privilege | exception | error | filesystem, permissions, io, directory |
| Failed to create parent dirs for | exception | error | filesystem, io, permissions, storage |
| function takes two arguments, but the first is not Context… | error_code | error | go, pulsar-functions, reflection, context |
| Interrupted while creating segment producer | exception | error | interruption, segment-producer, lifecycle, pulsar-client |
| No configuration file for Bookie | exception | error | configuration, startup, cli |
| Only allowed to set schemaInfoForReplicator for a… | exception | error | pulsar, replication, schema, message |
| Peer cluster data not found | http | error | http-404, geo-replication, cluster-configuration, stale-config |
| Topic was terminated | exception | error | pulsar, topic-terminated, consumer, lifecycle |
| User class doesn't have such method | exception | error | pulsar-functions, windowing, reflection, constructor |
| ${ex.getMessage()} | exception | error | lifecycle, close, async |
| keyFilePath must not be null | validation | error | java, tls, authentication, configuration, pulsar-client |
| LogTopic topic is invalid | validation | error | pulsar-functions, config-validation, topic-name, illegal-argument |
| Peek messages on a non-persistent topic is not allowed | http | warning | rest-api, non-persistent-topic, method-not-allowed, admin |
| Request Timed Out | http | error | timeout, pulsar-functions, rest-api |
| Sink tenant cannot be null | validation | error | pulsar, config-validation, sink, illegal-argument |
| The broker is not among the shared broker pools for the… | exception | error | configuration, namespace-isolation, regex-mismatch |
| The ' ' connector does not provide a source implementation | exception | error | pulsar-io, connector, nar, missing-source-class |
| TlsPolicy sets certificateFilePath='certificateFilePath'… | validation | critical | tls, pem, missing-configuration, private-key |
| v4 authentication must not be null | validation | error | authentication, null-check, illegal-argument, v4-adapter |
| Couldn't get the access key id. | validation | error | configuration, environment-variables, aliyun-oss, credentials |
| failed to init BookieId list | validation | critical | metadata-store, initialization, zookeeper, connectivity |
| Invalid hostname | validation | error | uri, hostname, config |
| Invalid size ' '. Valid formats are: (4096, 100K, 10M, 16G… | validation | error | |
| Migration has already been completed | exception | error | migration, metadata-store, idempotency, oxia |
| Output topic is invalid | validation | error | pulsar-functions, validation, topic-name, configuration |
| Receiver queue size should be >= zero | validation | error | pulsar-functions, config-validation, illegal-argument |
| Windows Function not support delivery semantics. | validation | error | pulsar-functions, windowing, processing-guarantees, configuration |
| at least one key name must be configured | validation | error | java, validation, encryption, client-config |
| Failed to retrieve counter from key | exception | error | state, bookkeeper, counter, blocking-call |
| doesn't exist | http | error | pulsar-functions, not-found, http-400 |
| Invalid MessageIdV5 data: bad parent-topic length | exception | error | deserialization, message-id, corrupt-data |
| Invalid value '' for enum | exception | error | configuration, enum, parsing, fieldparser |
| Leader not yet ready. Please retry again | http | warning | rest, service-unavailable, leader-election, pulsar-functions, retryable |
| Schema definition must specify pojo class or schema json… | exception | error | avro, schema, invalid-config |
| The pinned provider's TrustManagerFactory returned no… | exception | error | tls, truststore, security-provider, keystore |
| When Guarantees == , autoAck must be equal to true. If you… | panic | critical | go, processing-guarantees, autoack, configuration |
| Expected MessageIdV5, got | exception | error | pulsar, messageid, type-mismatch, acknowledgement |
| jcaProvider=' ' supplies none of the in-memory carrier… | exception | error | java, tls, keystore, fips, configuration |
| MaxMessageRetries and Effectively once don't gel well | validation | error | pulsar-functions, validation, retries, processing-guarantees |
| Package metadata is in legacy Java serialization format but… | exception | error | deserialization, legacy, security, packages, upgrade |
| is invalid. Expected format: ' ://tenant/namespace/topic | validation | error | java, topic-naming, format-validation |
| Deprecated; use EncodedAuthenticationParameterSupport | exception | error | deprecated-api, oauth2, pulsar-client |
| must not be null or blank | exception | error | pulsar, configuration, service-url, validation |
| Incompatible layout found (LAYOUT:1) | exception | critical | bookkeeper, underreplication, layout, version-compatibility |
| interval must be greater than or equal to 0 | validation | error | http-412, deduplication, validation, admin-api |
| Kubernetes only admits lower case and numbers. | validation | error | kubernetes, functions-runtime, naming, validation |
| --offloadedReadPriority parameter must be one of | validation | error | enum, parsing, configuration, cli |
| Could not validate source config: | validation | error | pulsar-functions, config-validation, json-deserialization, jackson |
| Current size and other size not equals | exception | warning | pulsar, messageid, partitioned, compareto, illegal-argument |
| Invalid value for message TTL | validation | error | http-412, message-ttl, validation, admin-api |
| Label name cannot be null or empty | http | error | metrics, prometheus, validation, rest |
| Operation not permitted | http | warning | pulsar-functions, http-400, illegal-state-transition, lifecycle |
| ServiceUrlProvider has already been initialized | exception | error | pulsar-client, lifecycle, initialization, illegal-state |
| Unknown resource type: | exception | error | pulsar, client, illegal-argument, enum |
| V5 does not support non-persistent:// topics: + topic | exception | error | v5-sdk, topic-domain, unsupported-feature, configuration |
| (wraps v4 producer send failure message) | exception | error | send, retry, pulsar-client, broker |
| Cannot split non-active segment | validation | error | pulsar, scalable-topic, segment-layout, state-validation |
| earlyTokenRefreshPercent must be greater than 0, got | validation | error | pulsar-client, oauth2, configuration, argument-validation |
| No authentication parameters were provided | validation | error | pulsar-client, oauth2, authentication, configuration |
NO_CLIENT Authentication data source does not have a client address | exception | error | athenz, authentication, peer-address, validation |
| No TLS context available (factory not initialized or closed) | exception | error | tls, lifecycle, race-condition, netty |
| not implemented | exception | warning | pulsar-io, unsupported-operation, seek, sink-context |
| Per instance ram requested | validation | error | pulsar-functions, kubernetes, resource-validation, configuration |
| Segments are not adjacent | validation | error | java, illegal-argument, hash-range, segment-layout |
| Examine messages on a partitioned topic is not allowed… | http | warning | rest-api, partitioned-topic, method-not-allowed, admin |
| Fail to read LedgerMetadata for ledgerId | exception | error | io, tiered-storage, bookkeeper, pulsar |
| Failed to initialize controller for | exception | error | pulsar, scalable-topic, initialization, async |
| Failed to set/create | exception | error | metadata-store, create-failure, concurrency, exception-wrapping |
| Invalid interval ' '. | validation | error | cli, argument-validation, range-check |
| No TLS material configured for server purpose purpose | exception | critical | tls, server, missing-configuration |
| cannot be less than or equal to <0>! | validation | error | cli, validation, argument, pulsar |
| Per instance cpu requested | validation | error | pulsar-functions, kubernetes, resource-validation, configuration |
| Property | validation | error | configuration, classpath, jvm, system-property |
| Sink Names differ | validation | error | pulsar, functions, config-validation, immutable-field |
| Topic name is not valid | http | error | http-412, topic-name, validation, admin-api |
| Cannot convert to AVRO | exception | error | avro, json, serialization, cli |
| Corrupt Function MetaData | http | error | rest, bad-request, protobuf, pulsar-functions |
| Neither METADATA_STORE_INSTANCE configuration set in the BK… | validation | error | configuration, metadata-store, zookeeper, missing-config |
| This schema is not meant to be used for encoding | exception | error | pulsar, schema, unsupported-operation, encode |
| Can not enable for all producers but denies for… | http | error | pulsar, admin-api, rest-exception, schema, validation |
| HTTP response body exceeds the configured maximum of | exception | warning | http, response-size, oauth2, limit-exceeded, pulsar-client |
| already exists in the dynamicConfigurationMap | exception | error | java, broker, configuration, plugin, duplicate-key |
| No available broker found. | exception | error | load-manager, redirect, no-brokers-available, cluster-startup |
| Proxy not authorized for super-user operation | http | error | authorization, proxy, superuser, rest-api, pulsar |
| The log error handler cannot be changed once the appender… | exception | error | java, pulsar-functions, logging, lifecycle, illegal-state |
| User class must have a public constructor | exception | error | reflection, access-modifier, visibility |
| Command Factory ` ` does NOT provide a Command Factory… | exception | error | |
| Exception while stopping auto ledger re-replication | exception | error | bookkeeper, metadata-store, autorecovery, disable |
| expiry time cannot be empty | validation | error | validation, configuration, time-parsing |