apache/druid
Documented errors, page 7 of 18. Back to apache/druid
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Can't get sketch from object of type | exception | error | java, datasketches, type-mismatch |
| Cardinality aggregator does not support | exception | error | druid, vectorization, aggregation, array |
| Could not populate cache | console | warning | druid, cache, background-population |
| Failed to parse array: element | validation | error | druid, expression-parser, array-literal, string-literal |
| forceGuaranteedRollup is set but partitionsSpec | exception | error | partitioning, perfect-rollup, multi-phase-ingestion |
| RuntimeException wrapping underlying cause | exception | error | azure, blob-storage, upload, wrapper-exception |
| StringAnyAggregator does not support getFloat() | exception | error | aggregation, unsupported-operation, type-mismatch, druid |
| This supervisor type does not support partition expiration. | exception | error | druid, supervisor, unsupported-operation, kinesis |
| Unable to find open port between | exception | error | network, ports, socket |
| Unhandled type | exception | error | java, ingestion, nested-columns, invariant, column-type |
| Cannot start Druid as table | exception | critical | metadata, schema, upgrade, startup |
| Column[ ] has conflicting types [ ] and [ ] | validation | error | java, row-signature, type-conflict, schema |
| Could not unassign role | exception | error | druid, basic-security, zookeeper, concurrency |
| Mismatched kafka and task partitions: Missing Task… | console | warning | kafka, partitions, supervisor, monitoring |
| Number of metricColumns | validation | error | java, datasketches, tuple-sketch |
| Segment id [ ] is unknown | console | info | http, rest-api, segment, not-found |
| Sink must not be null for identifier when persisting hydrant | exception | error | appenderator, lifecycle, invariant |
| Stage [ ] is missing a definition | exception | error | msq, query-definition, missing-stage, dangling-reference |
| This method should not be invoked for this granularity type | exception | error | granularity, unsupported-operation, ingestion |
CLEANER_NOT_SUPPORTED_EXCEPTION Cleaning is not support on this platform, because internal Java APIs are not… | exception | warning | jvm, memory-cleanup, platform, reflection |
| Closed | exception | error | iteration, invalid-state, frame-processor |
| getPosition() is not supported in RabbitMQ streams | exception | error | |
| Node[ ] disappeared but was unknown for service listener [… | console | warning | service-discovery, zookeeper, state-sync |
| Pre-sorted data required, rows | exception | error | grouping, presorted-input, invariant-violation |
| Problem reading persisted sinks in path | exception | error | filesystem, persist, batch-ingestion |
| Shutdown callback registry expected class | console | warning | logging, log4j, shutdown, configuration |
| Statistics gathered, but not required for stage | exception | error | msq, statistics, shuffle |
| Unknown id [ ] | exception | error | druid, nested-columns, segment-corruption |
| Unknown strategy[ ], query id [ ] | exception | error | search-query, invalid-enum-value, query-context |
| Aggregator[ ] cannot vectorize | exception | warning | druid, aggregation, vectorization, unsupported-operation |
| DynamicPartitionsSpec must be used for best-effort rollup | validation | error | druid, indexing, configuration, validation |
| Encountered metadata exception for task | exception | error | metadata-store, sql, task-management, database-write-failed |
| Failed to reserve partial metadata for segment | exception | error | segment-cache, bootstrap, reservation, disk-capacity |
| Health check executor did not terminate in time | console | warning | shutdown, executor, consul, health-check |
| Key[ ] is required in map[ ] | validation | error | map, required-key, configuration |
| Map column doesn't support getRow() | exception | error | java, virtual-columns, unsupported-operation, map-column |
| [ ] is an invalid granularity string. | validation | error | granularity, catalog, validation |
| is not supported for partitionsSpec[ ] | exception | error | druid, segment-allocation, partitions, unsupported |
| Unexpected null value in BloomFilterMergeAggregator | exception | error | druid, bloom-filter, null-value, internal-invariant |
| ApproximateHistogramBufferAggregator does not support… | exception | error | java, druid, aggregation, unsupported-operation |
| Cannot handle constant condition | validation | error | msq, join, sql, unsupported-operation |
| Cannot handle equality condition involving left-hand… | validation | error | sql, join, msq |
| Cannot handle inputSpec of class | exception | error | |
| Currently only single segment datasources are supported for… | exception | error | join, broadcast, segment-layout |
| Expected key [ ] to be an Integer, but got [ ] | validation | error | druid, query-context, type-mismatch, integer |
| Health check failed [ / ] for [ ] | console | warning | consul, health-check, network, retry |
| interrupted | exception | error | interruption, threads, stream-io |
| Possible data truncation, param | validation | error | expression, numeric-range, vectorized-query, bitwise |
| Projected output type | console | warning | expression, virtual-column, type-mismatch |
| StringAnyBufferAggregator does not support getLong() | exception | error | java, druid, aggregation, unsupported |
| StringFirstAggregator does not support getFloat() | exception | error | java, druid, aggregation, buffer-aggregator, unsupported-operation |
| Unable to run cleaning action | exception | error | jvm, memory-cleanup, reflection, lifecycle |
| Do not know how to handle source | exception | error | segment-loading, unsupported-format, local-deep-storage |
| Executor already shutdown | exception | warning | concurrency, executor, rejected-execution |
| Failed to run deferred eviction of container | console | warning | segment-cache, eviction, file |
| FloatAnyAggregatorFactory is not supported during ingestion… | exception | error | ingestion, rollup, unsupported-operation, druid |
| impossible, unknown encoding strategy id | exception | error | java, segment-read, encoding-strategy, version-skew |
| Monitor doesn't support working with lazy loading on start | exception | error | config, monitoring |
| Object cannot be deserialized to a Moments Sketch: | exception | error | serialization, deserialization, aggregation, sketch, druid |
| Query[ ] url[ ] total bytes gathered[%,d] exceeds… | exception | error | druid, broker, resource-limit, scatter-gather |
| rowLimit[ ] must be positive | exception | error | config, validation, sorting |
| Current thread is interrupted after | exception | warning | retry, thread-interrupt, cancellation |
| Failed to get blob item from Azure container | exception | error | azure, blob-storage, listing, network |
| lookup management on node | console | info | interruption, lookups, coordinator, shutdown |
| Row too large to add to frame (max frame size = %,d) | exception | error | msq, memory, frame |
| S3 requires the parameter if is set | validation | error | s3, sql, missing-parameter, table-function |
| Timed out waiting for operation | exception | error | |
| trying to add taskGroup with id | exception | error | supervisor, race-condition, internal-state |
| Unable to decompress zstd data | exception | error | java, compression, zstd, corruption |
| cannot perform lookup when applying an extraction function | exception | error | java, unsupported-operation, extraction-function |
| Cannot publish segments with shardSpec | exception | error | java, segments, publishing |
| Failed to get locks for intervals | exception | error | druid, ingestion, locking, concurrency |
| Failed to parse array element | validation | error | druid, expression-parser, array-literal, number-format |
| Failed to read Avro message with schema id | exception | error | avro, deserialization, kafka-ingestion |
| Granularity is not supported. | validation | error | granularity, period, invalid-argument, druid |
| Item must either be a String or StringTuple | validation | error | java, illegal-argument, type-mismatch, string-tuple |
| Not enough direct memory. Please adjust… | exception | critical | memory, configuration, startup |
| numThreads[ ] configured, that is ignored on Router | console | info | configuration, router, ignored-setting |
| Shutting down Catalog sync with | console | warning | shutdown, queue-drop, lifecycle, cache-sync |
| Cannot create type [ ] | exception | error | expressions, deserialization, type-mismatch |
| Couldn't serialize authenticator userMap! | exception | error | java, security, jackson, serialization |
| Failed to serialize object | exception | error | serialization, java, java-io |
| Invalid stageNumber [ ] | validation | error | java, argument-validation, msq |
| K8s pod with label[job-name= ] not found | exception | error | kubernetes, pod-not-found, druid-overlord, resource-lookup |
| Restricted data source | exception | error | join, row-level-security, restricted-datasource, unsupported |
| %s | exception | error | druid, ingestion, partitionspec, unsupported |
| is an unknown multi stage query mode. Acceptable modes | validation | error | msq, query-context, validation, enum |
| Unable to parse timestamps with format | exception | error | timestamp, date-format, joda-time |
| Unknown globalId [ ] | exception | error | nested-column, dictionary, illegal-argument |
| Unknown index version | exception | error | segment-loading, indexio, version, unsupported |
| Unknown type of emitter. Please set | exception | error | configuration, emitter, druid |
| Can't read row memory from frame. Wrong type or signature? | exception | error | |
| Cannot convert to Long offset | exception | error | |
| Cannot load resource | exception | error | classpath, resource-loading, io-error |
| Could not create user | exception | error | concurrency, optimistic-locking, authorization, basic-security |
| Format [ ], property [ ] of class [ ] conflicts with… | exception | error | druid, input-format, parameter-conflict, registry |
| Input format type is not registered | validation | error | druid, catalog, input-format, configuration |
| Metadata should be null because BatchAppenderatorDriver… | exception | error | appenderator, batch-ingestion, invariant |
| Task[ ] already exists in taskGroup[ ] with data[ ] | exception | error | supervisor, duplicate-task, race-condition |
| The Apache Hadoop ingestion task was removed in Druid 37.0 | exception | error | hadoop, removed-feature, migration, deprecated-api-usage |