ErrLookup › apache/druid
apache/druid
Apache Druid: a high performance real-time analytics database. · Java · 6,426 source files
Analyzed at 9b90983fd2 on 2026-09-07. 1766 documented errors.
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Invalid segment granularity timeline for dataSource | validation | error | compaction, reindexing, segment-granularity, validation |
| cannot vectorize fixed bucket histogram aggregation for type | validation | error | druid, vectorization, histogram, aggregation |
| Can't find previous segmentIds for sequence | exception | error | ingestion, batch-ingestion, internal-state |
| Unable to kill segment | exception | error | hdfs, segment-deletion, io-exception, deep-storage |
| Iceberg filter produced residual expression that requires… | console | error | iceberg, pushdown, residual-filter, ingestion |
| No usable range reader for partial segment | exception | error | segment-cache, bootstrap, range-reader, deep-storage |
| AggregatorFactoryNotMergeableException | exception | error | druid, aggregation, javascript, query-processing, merge |
| Found different granularities in segments | exception | error | druid, segment-granularity, compaction, segment-lock |
| Unauthorized | exception | error | grpc, authorization, forbidden, permissions |
| Failed to initialize Glue catalog | exception | critical | aws, glue, catalog-init, iceberg, druid |
| ApproximateHistogramBufferAggregator does not support… | exception | error | java, druid, aggregation, unsupported-operation |
| Could not find remote outputs of stage | exception | error | deep-storage, msq, distributed-shuffle, missing-output |
| Lock key [ ] has no session owner | console | warning | consul, distributed-lock, leader-election, session-expired |
| Transaction failure publishing segments for sequence | exception | error | druid, streaming, transaction, segment-publish |
| requires at least 1 argument | validation | error | expression, argument-count, validation |
| Could not create group mapping | exception | error | druid, basic-security, zookeeper, concurrency |
| Table name is required | validation | error | validation, catalog, missing-field |
| Driver for sequence[ ] attempted to publish invalid… | exception | critical | kafka, kinesis, ingestion, state-consistency |
| Cannot deserialize type | validation | error | deserialization, type-mismatch, java, druid |
| NotEnoughMemoryFault | error_code | critical | msq, memory, configuration |
| A valid tlsPort needs to specified when druid.enableTlsPort… | validation | error | configuration, druid-node, tls, ports |
| Set only one of 'key' or 'sharedAccessStorageToken' or… | validation | error | configuration, azure, startup, mutually-exclusive |
| segment[ ] and segment[ ] have the same rootPartitionRange… | exception | error | druid, atomic-update-group, compaction, root-partition |
| Cannot operate on a dimension with no dictionary | exception | error | query, topn, dictionary-encoding, druid |
| interrupted flushing elements from queue | exception | error | bloom-filter, deserialization, corrupt-data, druid |
| Stream ingestion task unexpectedly attempted to overwrite… | exception | error | druid, streaming, segments, internal-invariant |
| Index[ ] >= size[ ] | validation | error | java, bounds-check, index |
| Error loading [ ] | exception | error | hdfs, io-exception, segment-loading, network |
| Metric mismatch, index | validation | error | druid, segment-merge, schema-mismatch |
| KV entry [ ] not found for service metadata | console | warning | consul, service-discovery, kv-store, missing-metadata |
| Failed to deserialize DiscoveryDruidNode | exception | error | kubernetes, jackson, deserialization, discovery |
| Got a [ ] which isn't a | exception | error | druid, internal-error, query-routing, type-mismatch |
| Column name must be provided and non-empty | validation | error | druid, column-signature, empty-required-field |
| Failed to get object summaries from S3 bucket | exception | error | s3, aws-sdk, retry-exhausted, permissions, listing |
| HDFS Reader not supported | exception | error | hdfs, unsupported-operation, fileobject, reader |
| Emit called unexpectedly before service start | exception | error | bloom-filter, argument-validation, aggregation, druid |
| Cannot delete all segment files since… | exception | error | hdfs, configuration, kill-all, missing-config |
| Pod adapter [ ] requires the local Overlord pod namespace… | validation | error | kubernetes, configuration, namespace, druid-overlord |
| Unable to get SHA1 digest instance | exception | error | druid, aggregation, javascript, cache, jvm, sha1 |
| Can't compact segments of non-consecutive rootPartition… | exception | error | druid, root-partition, compaction, segment-lock |
| clusteringColumns must be the leading prefix of columns, in… | validation | error | projection-spec, clustering, validation, ingestion |
| Unused segment[ ] has version[ ] > task version[ ] | exception | error | druid, segment-versioning, restore-task, locking |
| AggregatorFactoryNotMergeableException(this, other) | exception | error | druid, datasketches, kll, aggregation |
| Improper cleanup | exception | error | internal-state, resource-cleanup, lifecycle |
BAD_STATE Table has an invalid type [ ] | error_code | error | catalog, bad-state, table-type |
| Unable to copy key [ ] to file [ ] | exception | error | bloom-filter, argument-validation, aggregation, druid |
| User [ ] already exists. | http | error | security, rest-api, duplicate-resource |
| Incompatible aggregator factories, [this] and [other] | exception | error | aggregation, merge, incompatible-types, query |
| Lock key [ ] owned by session [ ], expected [ ] | console | warning | consul, distributed-lock, leader-election, session-mismatch |
| Root partition range | exception | error | druid, segment-publish, partitioning, lineage |
| Unsupported method in default query metrics implementation. | exception | error | metrics, search-query, configuration, unsupported-operation |
| AppenderatorsManager methods should only called by services… | exception | error | java, druid, dependency-injection, unsupported-operation |
| CardinalityBufferAggregator does not support getLong() | exception | error | java, druid, aggregation, cardinality, unsupported |
| StringFirstAggregator does not support getDouble() | exception | error | druid, aggregation, unsupported-getter |
| bf1 NumHashFunctions/NumBits does not match bf2 | validation | error | |
| Invalid pod adapter [ ], only pod adapter [ ] can be… | validation | error | kubernetes, configuration, druid-overlord, incompatible-config |
| No files found at [ ] | exception | error | hdfs, segment-not-found, deep-storage, metadata-skew |
| requires at least arguments | validation | error | expression, argument-count, validation |
| Unsupported unknown value type | exception | error | druid, expressions, type-conversion, null-argument |
| Unable to load TrustStore | exception | error | ssl, tls, keystore, influxdb, java |
| Could not create user | exception | error | concurrency, retry-exhausted, metadata-store |
FrameTooLarge FrameRowTooLargeException: row too large for frame allocator capacity | error_code | error | msq, window-function, memory, frame-allocator |
| Failed to delete deep storage directory | exception | error | hdfs, recursion, directory-deletion, permissions |
| authResult.getErrorMessage() | http | error | authorization, http-api, supervisor, druid |
| Could not find the dimension spec for ordering column | exception | error | druid, limit-spec, ordering, internal-state |
| Could not transform value for __time. | exception | error | ingestion, parse-exception, transform, null-value |
| K8s pod for the task | exception | error | kubernetes, pod-lifecycle, druid-overlord, task-cancellation |
| New sequence startOffset | exception | error | druid, kafka, kinesis, checkpoints, offsets |
| Unknown type[ ] for metric[ ] | validation | error | query, topn, json-type-error, druid |
| Cannot convert object to float | exception | error | druid, unnest, type-mismatch |
| Failed to sample data | exception | error | ingestion, sampling, http, druid-overlord |
| Failed to merge existing aggregators when generating… | exception | error | druid, compaction, aggregator, configuration |
| cannot be used for perfect rollup | validation | error | druid, ingestion, rollup, partitionspec |
| Record sequenceNumber | exception | error | druid, kafka, kinesis, offsets, checkpoints |
| Work order for worker | exception | error | msq, controller, internal-state, worker-allocation |
| Guaranteed rollup is not supported | validation | error | ingestion, config, rollup |
| S3StorageConfig cannot be null! | validation | error | aws-s3, configuration, encryption, druid |
| Cannot set mergers for final level more than once | exception | error | internal-state, write-once, sorting |
| Invalid permission, resource name regex | http | error | |
| Invalid Wrapper type. | exception | error | protobuf, deserialization, classloading |
| datasource name cannot be null | validation | error | metadata, null-argument, supervisor |
| Expected key [ ] to be referring to one of the values [ ]… | validation | error | druid, query-context, enum, validation |
| outDir[ ] must exist and be a directory | validation | error | io, filesystem, compression |
| Size[ ] must be non-negative | validation | error | druid, segment, query |
| Can't load TrustStore. Truststore path or password is not… | exception | error | ssl, tls, configuration, influxdb, java |
| Batched segment allocation is disabled | exception | error | druid, segment-allocation, feature-flag, overlord |
| requires to arguments | validation | error | expression, argument-count, validation |
| Expected key [ ] to be a human readable number, but got [ ] | validation | error | druid, query-context, human-readable-bytes, parse-error |
| <authResult.getErrorMessage()> | http | error | authorization, http, security, forbidden |
| Both union and sketch were null! | exception | error | invariant, datasketches, hll, constructor |
| Cannot translate sqlTypeName | exception | error | sql, type-mapping, planner, druid |
| Empty bitmapFullnessFactorizationStops: | validation | critical | java, jvm-properties, static-init, segment, bitmap |
| Invalid level | exception | error | internal-state, index-out-of-range, sorting |
| Column capacity exceeded | exception | error | capacity, segment, serialization |
| partitionDimensions must be specified | validation | error | druid, batch-ingestion, partitioning, config-validation |
| Task [ ] requested pod template [ ] via context key, but no… | validation | error | kubernetes, pod-template, task-context, druid-overlord |
| Timeout [maxDefaultTimeout] must be a non negative value… | validation | error | query-context, timeout, config, validation |
| Bad null-marker byte, delegate class | exception | critical | java, aggregation, bytebuffer, corruption, vectorized |
| HistogramAggregator does not support getLong() | exception | error | druid, aggregation, unsupported-operation, histogram |
| LookupCoordinatorManager can't stop. | exception | error | lifecycle, illegal-state |