apache/druid
Documented errors, page 3 of 18. Back to apache/druid
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Comparing histograms is not supported | exception | error | druid, datasketches, kll, post-aggregator, unsupported-operation |
| Exclusive start partitions | exception | error | druid, kafka, kinesis, resharding, checkpoints |
| FixedBucketsHistogramBufferAggregator does not support… | exception | error | druid, histogram, unsupported-operation |
| No futures set | exception | error | java, frame-processor, state-error, listenable-future |
| Output partitions are not ready yet | exception | error | state, concurrency, timing |
| Worker completion callback error for stage | exception | error | msq, callback, controller-communication |
| Could not fetch partitions for topic/stream | exception | error | |
| Failed to handle query | http | error | sql, msq, query-planning, http-api |
| sun.misc.Unsafe is not supported on this platform, because… | exception | error | jvm, unsupported-platform, reflection |
| Writable channel is not available. The output channel might… | exception | error | java, illegal-state, frame-channel |
| Already shut down, not starting again | console | warning | kafka, lookup, lifecycle, shutdown |
| bucketSize must be a power of two (from 1 up to 128) but… | exception | error | java, segment-writer, validation |
| Couldn't deserialize authorizer roleMap! | exception | error | jackson, deserialization, metadata-store |
| Dim [ ] values not equal. Expected found | validation | error | druid, segment-validation, data-integrity |
| Failed to authenticate user principal | exception | error | |
| Found a different granularity from knownSegmentGranularity | exception | error | druid, segment-granularity, locking, replace-task |
| Function[ ] | validation | error | expression, function-validation, argument-count, druid |
| Unable to parse value | exception | error | java, parse-exception, number-format, druid-rows |
| Double dot in property | validation | error | guice, configuration, property-parsing, startup |
| Expected a number or an instance of MergingDigest, but… | exception | error | |
| Must use natural comparator for column | validation | error | msq, groupby, sorting |
| This inputSource does not support input source based… | exception | error | security, input-source, authorization |
| Unknown version[ ] | validation | error | serialization, segment-data, deserialization |
| cachedSerializedGroupMappingMap is not available from the… | console | info | security, druid, upgrade-compatibility, http-404 |
| Exception while attempting to automatically reset sequences… | exception | error | |
| Expected a string with a number, received value | validation | error | |
| No servers found for query | console | warning | druid, broker, server-selection, priority, load-balancing |
| Resetting server[ ] with state[ ] as it is not syncing… | console | warning | druid, cluster-coordination, segment-inventory, sync |
| Unexpected call made to NoopQueryProcessingPool | exception | error | druid, query-processing, defensive-exception, thread-pool, unsupported-operation |
| Could not delete group mapping | exception | error | druid, basic-security, zookeeper, concurrency |
| Failed to publish schemas | exception | error | database, metadata-store, ingestion |
| Frame of size [%,d] not yet ready to read | exception | error | druid, frame-channel, concurrency |
| SQLCatalogManager only works with SQL based metadata store… | exception | critical | configuration, metadata-store, startup |
| Thread interrupted while adding to queue | console | warning | interrupt, http-client, queue, backpressure |
| User [ ] does not exist. | http | error | druid, basic-security, user-management, not-found |
| failed on syncing fd | console | warning | native, linux, filesystem, fsync, jna |
| The lock for interval | exception | error | druid, locking, segment-allocation, preemption |
| Unable to delete from container | console | warning | azure, storage, deletion, batch |
| Compression failed | exception | error | compression, gzip, java-io |
| Could not find container named | exception | error | kubernetes, task-adapter, pod-spec, container-name |
| Directory compression not supported for | exception | error | java, unsupported-operation, compression, format-capability |
| Output type[ ] must be numeric | validation | error | java, illegal-argument, type-mismatch, druid-rows |
| Task type [ ], does not support input source based security | exception | error | druid, security, authorization, task-framework |
| Could not stop server within %,d millis after unhandled… | console | critical | zookeeper, curator, shutdown, jvm-halt |
| failed to close one or more emitters | error_code | error | shutdown, emitter, io, resource-cleanup |
| Failed to load pod template file for | validation | error | kubernetes, pod-template, file-read, yaml |
| Next token wasn't a START_ARRAY, was | exception | error | json, http-response, protocol-mismatch, query-execution |
| . This can occur when the overhead from too many… | exception | critical | druid, memory, ingestion, tuning |
| Status report not available | exception | error | |
| Unsupported type[ ] | exception | error | column-processor, unsupported-type, segment-processing |
| Cannot use lookupNameUtf8 on this selector | exception | error | selector, utf8, extraction-fn, unsupported-operation, druid |
| Could not unassign role | exception | error | druid, basic-security, zookeeper, concurrency |
| Failed to deserialize authorizer role, ignoring | console | warning | security, json, deserialization, druid |
| Illegal segmentId format | exception | error | ingestion, segment-allocation, parsing |
| OffsetOutOfRangeException with message | console | info | kafka, offsets, streaming, retriable |
| Cannot add merged batches for level | exception | error | sorting, internal-state, frame-processor |
| Cannot read frame of size [%,d] bytes | exception | error | druid, frame-channel, corruption |
| Cannot shuffle with spec | validation | error | msq, stage-definition, validation |
| Failed to login as [ ] | console | error | kerberos, spnego, authentication, keytab, startup |
| leaderSessionTtl is ; leader failover may take up to | console | warning | consul, leader-election, configuration, ttl, failover |
| Non-aligned segments | exception | error | druid, segment-granularity, alignment, locking |
| Resume command was not accepted within 5 seconds | exception | error | druid, kafka, kinesis, pause-resume, timeout |
| (dynamic msg passed to InvalidInput.exception) | validation | error | invalid-input, argument-validation, druid-exception |
| Unsupported pairClass type | exception | error | druid, serialization, unsupported-type |
| can't start. | exception | error | lifecycle, illegal-state, kubernetes, double-start |
| Cannot order by a non-numeric aggregator | validation | error | druid, group-by, aggregator, ordering |
| Failed to retrieve results from cache for query ID | exception | error | cache, deserialization, query |
| Header file[ ] is [ ] bytes on disk but its metadata… | exception | critical | segment-files, corruption, io |
| Query type ' ' does not support returning results as arrays | exception | error | druid, query, unsupported-operation, arrays |
| Value overrun | exception | error | frame-corruption, string-field, decoder, druid |
| Backfill tasks require 'useConcurrentLocks' to be set to… | validation | error | supervisor, configuration, locking, druid-overlord |
| Failed to rename temp file | exception | error | hdfs, file-rename, segment-pushing, io |
| OPA response field [result] must be a JSON boolean | validation | error | |
| Path [ ] is not writable, check permissions | exception | error | filesystem, permissions, io |
| The property cannot be provided when the property is set | validation | error | s3, catalog, conflicting-parameters, validation |
| Timed out after [ ] millis during flushing | exception | error | timeout, flush, network, emitter |
| Use a table function to set either | validation | error | druid-catalog, validation, local-input-source, table-definition |
| AuthenticationToken ignored: | console | warning | kerberos, http, authentication, token, spnego |
| Can't find overwritingSegmentMeta for interval | exception | error | druid, segment-allocation, locking, replace |
| Failed to remove output directory | console | warning | google-cloud-storage, segment-pull, cleanup, ioexception, druid |
| HistogramBufferAggregator does not support getDouble | exception | error | druid, aggregation, unsupported-operation, buffer-aggregator |
| Invalid operation for AveragerFactoryWrapper. | exception | error | druid, moving-average, aggregator |
| Overlapping intervals | validation | error | ingestion, granularity, configuration, invalid-argument |
| watchSeconds (%ds) is much larger than leaderSessionTtl… | console | warning | consul, configuration, leader-election, failover |
| Cannot return float for Null Value | exception | error | java, aggregation, null-handling |
| Could not assign role | exception | error | druid, basic-security, zookeeper, concurrency |
| Could not convert value | validation | error | ingestion, parse-exception, type-mismatch, dimensions |
| durationThreshold is not a valid ISO 8601 duration, got | validation | error | config, iso8601 |
| Output buffer too small, please allocate more space. | exception | error | java, compression, zstd, buffer |
| Reset with skipped offsets is not supported when… | validation | error | supervisor, kafka, configuration, druid-overlord |
| 'druid.coordinator.kill.period | validation | error | coordinator, configuration, validation, startup |
| Exception while seeking to the | exception | error | kafka, streaming, sampling, offset-seek |
| taskCountMax can't lower than taskCountMin! | validation | error | druid, config, autoscaler, validation |
| Unable to read the task id from the file | exception | error | deep-storage, msq, corrupt-file, task-id |
| Unknown column type for column | console | warning | metadata, segment, column |
| Could not find interval for timestamp | validation | error | indexing-service, granularity-spec, timestamps |
| HistogramAggregator does not support getDouble() | exception | error | druid, aggregation, unsupported-operation, histogram |
| Indices to merge contained metric | validation | error | druid, index-merger, merge, schema-drift, metrics |
| Invalid input [ ] of type [ ] for [ ] aggregator [ ] | exception | error | datasketches, hll, invalid-input, aggregation, type-mismatch |
| Not using a service account | exception | error |