apache/cassandra
Documented errors, page 8 of 30. Back to apache/cassandra
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| access denied: + perm | exception | error | security, udf, sandbox, package-access |
| Bad query to JMX server: | exception | error | |
| Cannot convert value | exception | error | serialization, type-mismatch, bytebuffer |
| Cannot enable accord on system tables | validation | error | cassandra, accord, transactional-mode, system-keyspace, schema |
| Cannot use with | validation | error | cql, invalid-request, update, delete, filtering |
| Column was not found in table | validation | error | cassandra, cql, schema, alter-table, rename |
| compressor_providers entry is missing required 'class_name | validation | error | configuration, compression, missing-field |
| direct_write_buffer_size | console | warning | compression, direct-io, configuration, buffer-size |
| IndexRestrictions.MULTIPLE_EXPRESSIONS | validation | error | cassandra, cql, custom-index, restrictions |
| Invalid operation ( ) for non collection column | validation | error | cql, cassandra, schema-validation |
| Invalid value for data_disk_usage_max_disk_size | validation | error | config, guardrails, disk-usage |
| Route index is only allowed for accord journal table; given | validation | error | cassandra, accord, index, illegal-argument |
| can not be bigger than . You have set and respectively. | validation | error | configuration, guardrails, validation |
| is not a valid ASCII String | validation | error | cql, ascii, codec, encoding |
| This node was decommissioned and will not rejoin the ring… | exception | critical | bootstrap, decommission, configuration, startup |
| Token changing ownership from to | console | info | tcm, token-ownership, replacement, bootstrap |
| Unable to make long (for time) from | validation | error | cassandra, serialization, time, value-out-of-range |
| Can not finish joining ring, sequence is in an incorrect… | exception | error | bootstrap, cluster-join, illegal-state, cassandra |
| Error setting log for on level . Please check logback… | exception | error | jmx, logging, nodetool, logback |
| Failed to read partition index | exception | critical | sstable, index, corruption, verification |
| IEndpointSnitch has been deprecated and is no longer in use | exception | error | deprecated-api, snitch, unsupported-operation |
| internode_max_message_size must no exceed… | validation | error | cassandra, configuration, startup-validation |
| Invalid IP address ( . . . ) while deserializing inet… | exception | error | network, protocol, deserialization, cql-native-protocol |
| can not be bigger than | validation | error | configuration, guardrails, validation |
| Unknown keyspace: | validation | error | cassandra, nodetool, validation |
| A local deletion time should not be a legacy overflowed… | validation | error | validation, legacy-format, data-corruption, tombstone |
| Ambiguous negation: use type casts to disambiguate | validation | error | cql, operators, ambiguity |
| Cannot create heap dump unless -XX:HeapDumpPath or… | exception | error | heap-dump, configuration, diagnostics |
| e.getMessage() | validation | error | |
| not terminated | exception | error | timeout, executor, shutdown |
| Failed to retrieve compression dictionary for | console | warning | compression, dictionary, system-distributed, replication |
| Got mismatching cluster metadatas. Check logs on peers | exception | error | cassandra, tcm, consistency |
| Invalid value for : negative values are not allowed… | validation | error | config, validation, guardrails, cassandra |
| Invalid value of entire_sstable_stream_throughput_outbound: | validation | error | configuration, startup, validation |
| Last modified differ | console | warning | cassandra, tcm, cluster-metadata, diagnostics |
| MutationExceededMaxSizeException | exception | error | mutation, commitlog, payload-too-large, batch |
| The JVM is not configured to stop on OutOfMemoryError which… | console | warning | jvm, outofmemory, startup-check, legacy |
| Unhandled return type: | console | error | cli, nodetool, guardrails, type-mismatch, version-skew |
| UnsupportedOperationException | exception | warning | queue, unsupported-operation, collection |
| accord.journal_directory must not be the same as any… | validation | critical | cassandra, configuration, accord, directories |
| Can't upgrade from gossip since CMS is already initialized | exception | error | upgrade, cluster-metadata, idempotency, illegal-state |
| Cannot resolve UDTs for keyspace | validation | error | cassandra, udt, schema |
| EOF after " + copied + " bytes out of " + len | exception | error | io, eof, deserialization |
| Error occurred during verifying | exception | error | nodetool, verify, sstable |
| Error reading partition | console | warning | cassandra, scrub, sstable, data-corruption |
| Invalid yaml. Please remove properties | validation | error | yaml, configuration, deprecation |
| Neither -XX:HeapDumpPath nor cassandra.yaml:heap_dump_path… | console | warning | cassandra, configuration, heap-dump, jvm |
| New tokens exceed total bounds of current placement ranges | exception | error | tcm, token-management, bootstrap, range-splitting, illegal-argument |
| Number of concurrent compactors should be greater than 0. | validation | error | configuration, jmx, compaction, validation |
| Setting server_encryption_options.enabled has no effect… | console | warning | cassandra, tls, encryption, configuration |
| Unexpected request expecting READY, AUTHENTICATE, ERROR or… | exception | error | protocol, handshake, native-protocol, netty |
| Unknown bucket_mode '" + value + "' | validation | error | cassandra, cql, invalid-enum-value, validation |
| Attempting to compact transient sstables with non transient… | exception | error | compaction, transient-replication, internal-invariant |
| Column value does not satisfy value constraint for column | validation | error | cql, write-path, constraints, empty-value |
| Configuration definition inherits unknown | validation | error | config, inheritance |
| Detected high ' ' setting of for device ' ' of data… | console | warning | io, readahead, startup-check, performance |
| Disabling gossip while native transport is still active is… | console | warning | cassandra, gossip, native-transport, unsafe-state |
| Failed to bind port on . | exception | critical | network, bind, port-in-use, startup |
| Failed to decrypt the private key data. Either the password… | exception | error | |
| Failed to initialize crypto provider, class_name cannot be… | validation | error | cassandra, configuration, crypto-provider |
| LocalReadSizeTooLargeException | exception | error | read-path, memory-protection, query-aborted, payload-too-large |
| Must be one of | exception | error | concurrency, configuration, enum |
| Not enough bytes to read a set | validation | error | cassandra, serialization, set, validation |
| Round-trip mismatch: compressed with | exception | critical | compression, provider, round-trip, data-corruption |
| [ ] Writer already finished! | exception | error | cassandra, sai, illegal-state, writer-lifecycle |
| Small volume detected at ' '; setting to . You can override… | console | info | configuration, startup, disk, sizing |
| States differ: != | console | warning | cassandra, tcm, node-state, diagnostics |
| The channel this output stream was writing to has been… | exception | error | network, streaming, connection-reset |
| Type error: cannot assign result of operation | validation | error | cql, type-error, operations, functions |
| Write thresholds require top partitions tracking to be… | console | warning | cassandra, configuration, startup-validation |
| Cannot parse time value from | exception | error | cassandra, codec, time, parsing, invalid-type-exception |
| Gossip stage has pending tasks; skipping status check (no… | console | warning | cassandra, gossip, backpressure, thread-pool |
| Invalid endpoint state for | console | warning | gossip, tcm, upgrade, endpoint-state |
| Invalid class ' ': must extend or implement | exception | error | type-mismatch, reflection, config |
| Invalid specification: | exception | error | cli, argument-validation, parsing |
| Only complex cells should have a cell path | validation | error | cassandra, deserialization, data-validation |
| The floor on values cannot be computed for the duration as… | validation | error | cql, time-functions, duration |
| Unknown kind | validation | error | accord, serialization, transactions |
| Unsupported expression: | exception | error | cassandra, sai, query, unsupported-operator |
| Error initializing OnDiskOrdinalsMap at segment | exception | critical | cassandra, sai, vector-index, corruption |
| Error notifying dictionary trained listener for | console | warning | cassandra, zstd, compression, listener-callback |
| Expected an empty string, but got | validation | error | cassandra, json, type-mismatch |
| Failed to dump trie to | console | warning | cassandra, bti, index, diagnostics |
| Failed to insert pre-initialize entry into distributed… | exception | error | cassandra, tcm, bootstrap, distributed-log |
| Maximum pool size has been changed while resizing | exception | error | concurrency, executor, race-condition |
| Node is not a CMS member in epoch ; members= | exception | error | tcm, cms, cluster-metadata |
| throw new IOException(e.getMessage()) | exception | error | jmx, nodetool, io, compression-dictionary |
| Unable to get startup checks via ServiceLoader. Custom… | exception | error | serviceloader, startup, configuration |
| Unable to initialise | exception | error | initialization, network, sstableloader |
| Unexpected EOF replaying hints | console | warning | hints, replay, eof, truncation |
| Unhandled record type | exception | error | serialization, deserialization, compatibility |
| No metadata server could be found in lease file. | validation | error | configuration, cloudstack, snitch, startup |
| Partitioner mismatch from | console | warning | gossip, partitioner, configuration |
| Prepared statement of size | validation | error | cql, prepared-statement, cache, size-limit |
| received an invalid gossip generation for peer | console | warning | cassandra, gossip, clock-skew, time-drift |
| Request breached global limit of | console | info | native-transport, backpressure, rate-limit, throttling |
| Request on table . with %sttl of seconds exceeds maximum… | validation | error | ttl, invalid-request, expiration, configuration |
| Table . (id: ) no longer exists. It may have been dropped. | console | info | virtual-table, schema, dropped-table, accord |
| table of additional mutation does not match primary update… | exception | error | triggers, table-id, invalid-request, validation |
| There are duplicate constraint definitions on column | validation | error | cassandra, cql, constraints, duplicate |