apache/cassandra
Documented errors, page 7 of 30. Back to apache/cassandra
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Unsupported disk access mode for… | validation | critical | config, compaction, disk-io, invalid-enum |
| was already installed on position . Check the configuration… | console | warning | security, crypto-provider, jce, configuration |
| Artificial latency limit is | validation | error | configuration, latency, value-out-of-range |
| Can't abort a operation unless it has failed | exception | error | cluster-operations, operation-mode, tcm |
| Cannot create () index on frozen column . Frozen… | validation | error | cassandra, cql, secondary-index, frozen, collections |
| Cannot perform any operations against virtual keyspace " +… | exception | error | virtual-keyspace, invalid-argument, read-only |
| Cannot use DROP TABLE on a materialized view. Please use… | validation | error | cql, schema, materialized-view |
| CounterCacheSavePeriodInSeconds must be non-negative. | validation | error | jmx, configuration, cache, runtime-validation |
| error | console | error | nodetool, cli, jmx, command-line |
| internode_max_message_size must no exceed… | validation | error | cassandra, configuration, internode |
| lz4-java was unable to load native libraries; this will… | console | warning | lz4, compression, native-library, performance, startup-checks |
| max_concurrent_automatic_sstable_upgrades | console | warning | cassandra, compaction, configuration |
| minimum_replication_factor_fail_threshold to be set | validation | error | config, guardrails, replication-factor, cassandra |
| Not enough bytes to read the end-of-component byte of… | validation | error | serialization, composite-type, validation |
| creates a role with no password, which cannot authenticate… | exception | error | |
| .validateOptions() threw an error | validation | error | cassandra, configuration, compaction, reflection |
| unsupported target unit | validation | error | cql, unsupported-operation, units |
| access denied: + MODIFY_THREAD_PERMISSION | exception | error | security, securitymanager, udf, sandbox, accesscontrolexception |
| All values must be either negative or positive, got | validation | error | java-driver, duration, invariant |
| Can't apply a ClusterMetadata from gossip with epoch | exception | error | cluster-metadata, epoch, gossip-migration, precondition |
| Can't move and open a file that is already in use in the… | exception | error | sstable, state-conflict, concurrency |
| Connection Error | exception | critical | network, connection, native-protocol, netty |
| Failed to delete on exit | console | warning | filesystem, shutdown, cleanup, logging |
| Invalid index specified | validation | error | index, illegal-argument, secondary-index, resource-not-found |
| JMX settings in cassandra.yaml or cassandra-env.sh have… | console | warning | jmx, configuration-conflict, deprecated |
| manually specified tokens override automatic allocation | console | warning | cassandra, bootstrap, token-allocation, configuration |
| Not enough bytes to read a | validation | error | serialization, marshal, collection |
| can't be used with | validation | error | auth, configuration, startup, network-authorizer |
| Unable to create instance of ISslContextFactory for | exception | error | config, ssl, tls, reflection |
| All arguments must have the same vector dimensions | validation | error | cassandra, vector-search, invalid-request |
| CF was dropped during streaming | exception | error | streaming, schema, table-dropped |
| Cleaning up orphaned PreInitialize at epoch | console | warning | tcm, bootstrap, system-keyspace, pre-initialize |
| Commits are paused, not trying to commit | exception | error | commit, paused, cluster-metadata, shutdown |
| CorruptSSTableException / NoSuchFileException: missing… | exception | critical | sstable, missing-file, corruption, compression |
| CorruptSSTableException wrapping IOException for | exception | critical | sstable, corruption, io, storage |
| denylist_max_keys_per_table must be a positive integer. | validation | error | configuration, validation, illegal-argument |
| Failed to read a hint for | console | warning | hints, corruption, crc, disk |
| Failed to retrieve target column for: | validation | error | cassandra, sai, invalid-request, schema-validation |
| Hot reloading functionality has not been initialized. | exception | error | ssl, tls, lifecycle, hot-reload, illegal-state |
| Invalid number of arguments in call to function | validation | error | cql, function-resolution, arity |
| Prepare phase failed because it encountered legacy sstables… | exception | error | cassandra, repair, sstable, upgrade, incremental-repair |
| repair_session_max_tree_depth has been deprecated and… | console | warning | cassandra, config, deprecation, repair, yaml |
| There can not be more than 2 constraints (not including… | validation | error | cassandra, cql, constraints, schema-definition |
| This table currently does not support the complex partial… | validation | error | cassandra, virtual-table, partition-key, unsupported-operation |
| Value ' ' is not a valid representation of a varint value | validation | error | cassandra, marshalling, json, varint |
| Cannot parse collection value from | exception | error | cassandra, java-driver, parsing, cql-literal |
| cannot repair paxos in a preview repair | exception | error | repair, paxos, illegal-argument |
| Command ' ' took too long ( ms >= ms). | exception | error | sasi, timeout, query-quota, performance |
| Counter and non-counter mutations cannot exist in the same… | validation | error | cql, batch, counter, invalid-request |
| Failed to remove hard link files | console | warning | filesystem, cleanup, hardlink, io |
| Found a legacy log record | console | warning | txn-log, upgrade, legacy-format, startup |
| Got overlapping ranges in replica groups: | exception | error | cassandra, tcm, ownership |
| No accord transaction should be executed when… | exception | error | accord, cassandra, unsupported-operation, configuration |
| Nothing to repair for | exception | info | repair, keyspace, replication, skip |
| Out-of-bounds value at vector[ | exception | error | cassandra, sai, vector-search, validation |
| for ks: , table | validation | error | cassandra, runtime-exception, schema, context-wrapping |
| Unable to find masking function for | validation | error | cql, masking, function-resolution, invalid-argument |
| Unable to read partition key from data file | exception | critical | sstable, scrub, corruption, data-file |
| Unknown broadcast_rpc_address ' | validation | critical | cassandra, configuration, dns |
| Can not apply in-progress sequence, since its kind is | exception | error | tcm, invalid-state, cms, multi-step-operation |
| Cannot decode string as UTF8: '" +… | exception | error | cql-protocol, utf8, serialization |
| Column modification is not supported by table | exception | error | virtual-table, invalid-request, unsupported-update |
| Corrupt hint file found | exception | error | java, hints, corruption, io |
| Full chain/private key is not present in the keystore for… | console | warning | tls, keystore, certificate-chain, configuration |
| Function requires a vector argument, but found argument of… | validation | error | cql, type-mismatch, vector |
| Got no response for shadow round | console | warning | cassandra, gossip, shadow-round, network, bootstrap |
| Internode messaging byte limits that are shared between… | exception | critical | network, resource-limits, jvm-exit, concurrency |
| Interrupted while building indexes on SSTable | console | info | cassandra, secondary-index, interrupt, sstable |
| Invalid annotations, you have more than one @Replaces… | validation | error | annotations, configuration, developer-error |
| Must specify at least one command with a non-zero ratio | exception | error | cli, configuration, validation |
| Not running paxos repair for topology change because paxos… | console | warning | paxos, repair, topology-change, lightweight-transactions |
| Partitioner does not match validation metadata | exception | error | sstable, partitioner, verification, configuration |
| Unknown CF | exception | error | schema, table-not-found, tableid, stale-metadata |
| Unsupported message | exception | error | protocol, codec, invalid-frame, client-bug |
| A CQL blob string must have an even length (since one byte… | validation | error | blob, hex, parsing |
| Aggregate name ' ' is invalid | validation | error | cql, aggregate, naming, validation |
| All nodes are not yet upgraded | exception | error | upgrade, mixed-version, cluster-metadata, prerequisite |
| Constraints of are not satisfiable | validation | error | cassandra, cql, constraints, satisfiability |
| Gave up waiting on journal index to be ready | exception | error | accord, journal, timeout, startup |
| Got duplicate initiate migration message from | exception | error | cassandra, tcm, concurrency |
| Invalid map literal for | validation | error | cql, map, type-mismatch, validation |
| is missing and cassandra.storagedir system property is not… | validation | critical | configuration, filesystem, storage-directory, cassandra |
| Java source compilation failed: | validation | error | udf, java, compilation |
| Prepare phase for incremental repair session | console | error | repair, incremental-repair, compaction, concurrency |
| Requested range intersects a local range ( ) but is not… | exception | error | repair, token-ranges, validation |
| Uninstallation of failed | console | warning | security, crypto-provider, jce, cleanup |
| Beta version of server used | exception | error | cql-protocol, beta-version, client, builder |
| Error occurred attempting to finish migration for… | console | error | nodetool, consensus, migration, repair, jmx |
| Ignored host(s) don't exist in the cluster | exception | error | upgrade, cluster-metadata, validation, unknown-host |
| Invalid modifier specification: unrecognised property | validation | error | configuration, parsing, illegal-argument |
| Invalid parameter list for gaussian distribution: | exception | error | cassandra, cli, argument-count, distribution |
| local_system_data_file_directory must not be the same as… | validation | critical | cassandra, configuration, directories, commitlog |
| No node present with id | exception | error | cli, cluster-metadata, node-not-found, cassandra |
| Not yet initialized, can't load new sstables | exception | error | runtime, initialization, jmx, deprecated |
| property for check_data_resurrection startup check is not… | console | warning | startup-check, gc-grace, configuration |
| () cannot be used in the selection clause of a SELECT… | validation | error | cql, json, invalid-context |
| Server is not initialized yet, cannot run nodetool. | exception | error | nodetool, jmx, startup, cassandra |
| The next training or importing can occur only at least after | validation | warning | compression, training, rate-limit |
| Too many Accord trace events stored already; delete some to… | console | warning | accord, tracing, limit-exceeded |
| Unable to find sufficient sources for streaming range " +… | exception | critical | streaming, bootstrap, replication, topology |