ErrLookup › zhisheng17/flink-learning

zhisheng17/flink-learning

flink learning blog. http://www.54tianzhisheng.cn/ 含 Flink 入门、概念、原理、实战、性能调优、源码解析等内容。涉及 Flink Connector、Metrics、Library、DataStream API、Table API & SQL 等内容的学习案例,还有 Flink 落地应用的大型项目案例(PVUV、日志存储、百亿数据实时去重、监控告警)分享。欢迎大家支持我的专栏《大数据实时计算引擎 Flink 实战与性能优化》 · Java · 353 source files

Analyzed at d731cee761 on 2026-09-06. 50 documented errors.

Code / MessageTypeSeverityTags
Topic must be specified by the Kafka log4j appender
validation error kafka, log4j, config
Source must be specified by the Kafka log4j appender
validation error kafka, log4j, config
ConfigMap does not exists. It may be deleted externally.
exception error kubernetes, flink, high-availability, configmap
SQL parse failed
exception error sql, parser, flink, ddl
Unsupported command
exception error sql, parser, flink, sql-client
Unsupported command
exception error sql, planner, flink, dispatch
Could not find in ConfigMap
exception error kubernetes, flink, high-availability, state
Unrecognized Service type
exception error kubernetes, service-type, flink
Could not get the rest endpoint of
exception error kubernetes, flink, rest-endpoint, cluster-retrieval
kubernetes.cluster-id must be no more than
validation error kubernetes, configuration, validation
High availability should be enabled when starting standby…
validation error kubernetes, jobmanager, high-availability
Load kubernetes config failed.
exception error kubernetes, kubeconfig, io
Unsupported client type - cannot happen
exception warning flume, invariant, switch, flink
should be specified to a fixed port. Do not support a range…
exception error kubernetes, configuration, port
Could not properly remove all state handles.
exception error kubernetes, state-handle, cleanup, high-availability
Failed to clear job state in ConfigMap
exception error kubernetes, high-availability, configmap, io
invalid elasticsearch hosts format
exception error config, elasticsearch, url-parsing, flink
Only "local" is supported as schema for application mode…
exception error kubernetes, application-mode, jar-uri
kubernetes.cluster-id must not be blank.
validation error kubernetes, configuration, validation
The bootstrap servers property must be specified
validation error kafka, logging, config
The value ' ' cannot be re represented as 64bit number of…
validation error overflow, duration, parsing
Time interval unit ' ' does not match any of the recognized…
validation error duration, parsing, config
Unknown value for CONSUMER_OFFSET_RESET_TO.
exception error rocketmq, config, enum, flink, kafka-migration
Failed to find Deployment named
exception error kubernetes, deployment, taskmanager, kubeclient
Could not kill Kubernetes cluster
exception error kubernetes, flink, cluster-cleanup, kill-cluster
'kubernetes.jobmanager.replicas' should not be configured…
validation error kubernetes, jobmanager, configuration
Unknown Kubernetes deployment target
validation error kubernetes, flink, deployment-target, invalid-config
Could not create Kubernetes cluster
exception error kubernetes, flink, cluster-deployment, resource-creation
Could not start PrometheusReporter HTTP server on any…
exception error flink, metrics, prometheus, port-conflict
already exists in ConfigMap
exception error kubernetes, configmap, duplicate-key, high-availability
text does not start with a number
validation error java, parsing, duration, config
Failed to update ConfigMap
exception error kubernetes, flink, high-availability, checkpoint-id-counter, leadership
Couldn't deploy Kubernetes Application Cluster. Expected…
exception error kubernetes, flink, deployment-target, config-mismatch
Failed to deserialize state handle from ConfigMap data
exception error kubernetes, deserialization, state-handle, classpath
PWD env doesn't contains yarn application id or container id
exception error flink, metrics, yarn, environment
Failed to set state in ConfigMap for job
exception error kubernetes, high-availability, configmap, leader-election
Could not create the RestClusterClient.
exception error kubernetes, flink, rest-client, cluster-retrieval
./sql-submit -w -f <sql-file> -t <isTest:true|false> -b…
validation error cli, argument-validation, sql-client
Error to parse KubernetesWorkerNode from
exception error kubernetes, flink, resourcemanager, pod-name-parsing
The Flink cluster already exists.
exception error kubernetes, flink, duplicate-resource, cluster-deployment
The value ' ' cannot be re represented as 64bit number…
validation error java, parsing, duration, overflow
The given argument is no array.
validation error java, arrays, utils, validation
Invalid host/port configuration. Host
validation error flink, metrics, prometheus, config
Per-Job Mode not supported by Active Kubernetes deployments.
exception error kubernetes, flink, per-job-mode, unsupported-operation
bytes == null
validation error java, null, hex, utils
No measurement defined
exception error influxdb, validation, flink, null
This database does not exist!
exception error influxdb, database, flink, config
Unrecognized service type
exception error kubernetes, enum, service, argument
Failed to find port " " in Service
exception error kubernetes, service, port, rest
Failed to create ConfigMap
exception error kubernetes, configmap, kubeclient, async