ErrLookup › stalwartlabs/stalwart

stalwartlabs/stalwart

All-in-one Mail & Collaboration server. Secure, scalable and fluent in every protocol (IMAP, JMAP, SMTP, CalDAV, CardDAV, WebDAV). · Rust · 955 source files

Analyzed at e962003857 on 2026-09-06. 51 documented errors.

Code / MessageTypeSeverityTags
Invalid LOG level
panic error environment-variable, configuration, panic, logging, dev-mode
Failed to decode base64
panic error base64, decoding, console, panic, input-validation
Failed to load the platform certificate verifier
panic critical rust, tls, rustls, certificates, platform-verifier, panic
. Re-encode the key as named-curve PKCS#8, e.g. `openssl…
exception error rust, cryptography, pem, pkcs8, p256, vapid, webpush, key-parsing
Missing
panic error build-script, i18n, missing-translation
Sieve test failed
panic warning sieve, email, test-mode, rust
Invalid system time, panicking to avoid data corruption
panic critical config, clock, snowflake-id, startup
: has no plural categories while other languages do
panic error build-script, i18n, pluralization, validation
Invalid jump position
panic error parser, internal-invariant, expressions, rust
Failed to build the TLS client configuration
panic critical rust, tls, rustls, crypto-provider, build-config, panic
Failed to read
panic critical build-script, file-not-found, i18n, rust
Failed to deserialize counter/quota
panic critical database, restore, deserialization, corruption
Unspecified
exception error tls, network, smtp, starttls
: repeats the plural category
panic error build-script, i18n, pluralization, duplicate
Failed to scan keys
panic error database, storage, console, range-scan, panic
Failed to parse calendar template
panic error panic, template, config, groupware
Missing span ID
panic error telemetry, tracing, collector, panic
Failed to build DNS resolver
panic critical dns, panic, resolver, config
Failed to build DNSSEC resolver
panic critical dns, dnssec, panic, resolver, config
Cluster::SubscriberError
error_code error kafka, pubsub, subscriber, configuration
Node id exceeds , panicking to avoid data corruption
panic critical config, snowflake-id, startup, rust
: is missing the required "other" plural category
panic error build-script, i18n, pluralization, validation
Not Found
http error scim, http-404, rest
failed to install aws-lc-rs as the default rustls crypto…
panic critical rustls, tls, crypto, startup
unwrap_tls called on non-TLS acceptor
panic error tls, network, rust, panic
Server::ThreadError
error_code error imip, task-manager, worker-thread, email
Unauthorized
http error scim, http-401, authentication
Incorrect number of task channels
panic error internal, ipc, tokio, invariant
Invalid UTF-8
exception error encoding, utf-8, io, logs
Invalid line
exception warning parsing, udp, spam-filter, pyzor
Failed to delete keys
panic error database, storage, console, key-deletion, panic
Unknown database schema version, expected
panic critical database, migration, schema, downgrade
Forbidden
http error scim, http-403, authorization, permissions
The size of the request payload exceeds the maximum of
http error scim, http-413, request-body
StoreEvent::HttpStoreError
Failed to fetch HTTP list
error_code error http, network, store, configuration
Invalid response
exception warning parsing, udp, spam-filter, pyzor
Cluster::PublisherError
error_code error zenoh, pubsub, publisher, key-expression
Invalid version
error_code error serialization, data-corruption, versioning
Conflict
http error scim, http-409, conflict
Failed to start event collector
panic error threading, resources, collector, startup
Precondition Failed
http error scim, http-412, etag
OpenAPI request failed
exception error http, api, llm, network
Not Implemented
http error scim, http-501, unsupported-feature
SieveEvent::RuntimeError
Empty query string
error_code error sieve, scripting, validation
The HTTP method is not supported by this endpoint, allowed…
http error scim, http-405, method-not-allowed
The number of operations in the bulk request exceeds the…
http error scim, http-413, bulk
Migration aborted
panic critical database, migration, panic
Internal Server Error
http critical scim, http-500, server-error
The size of the bulk operation exceeds the maxPayloadSize
http error scim, http-413, bulk
journald does not exist in this environment
exception error logging, journald, platform, telemetry
journald not supported on non-Unix
exception error logging, journald, platform, telemetry