prestodb/presto
Documented errors, page 10 of 13. Back to prestodb/presto
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
ICEBERG_ROLLBACK_ERROR Exception during rollback | error_code | error | iceberg, delete-sink, rollback, io |
INVALID_TRANSACTION_MODE Multiple transaction isolation levels specified | error_code | error | transactions, sql-syntax, validation |
| primary keys not supported | exception | warning | jdbc, metadata, unsupported-feature, primary-key, presto |
| unsupported column type | validation | error | presto, decoder, unsupported-type, configuration |
| Unsupported Type: | exception | error | sql-parser, temporal, unsupported-operation |
| Unsupported type for 'year': | exception | error | |
| Expected column to be a time type but is | exception | error | jdbc, presto, type-mismatch, sql |
| Listing all tables after adding/dropping/altering… | exception | error | |
| Minimum cost of BCrypt password must be | validation | error | |
PINOT_DATA_FETCH_EXCEPTION Encountered Pinot exceptions when fetching data table from Split: < | error_code | error | pinot, io-exception, grpc, data-fetch, retriable |
| Unexpected metadata | exception | error | |
| Unsupported Cassandra type | exception | error | cassandra, unsupported-type, type-mapping, custom-type |
CATALOG_NOT_SPECIFIED Catalog must be specified when session catalog is not set | error_code | error | sql, show-grants, catalog, session |
| createSQLXML | exception | error | jdbc, presto, unsupported-operation, sqlxml |
DUPLICATE_RELATION WITH query name ' ' specified more than once | validation | error | cte, duplicate-name, sql |
INVALID_LITERAL ' ' is not a valid timestamp literal | error_code | error | literal, timestamp, parse-error |
| Invalid positions array size | validation | error | java, presto, illegal-argument, block-positions |
| Statement is closed | exception | error | |
| Block does not have same position count | exception | error | page, block, position-count, presto-common |
ICEBERG_UNKNOWN_MANIFEST_TYPE Unknown manifest file content | error_code | error | iceberg, manifest, compatibility, version-mismatch |
INDEX_LOADER_TIMEOUT Exceeded the time limit of | error_code | error | presto, index-join, timeout, performance |
| Invalid encryption materials provider class: | exception | error | s3, encryption, configuration, reflection |
INVALID_SCHEMA_NAME Too many parts in schema name | error_code | error | presto, schema-name, semantic-error, identifier |
| Type must be a RowType for StructVector | validation | error | arrow, type-mismatch, struct, row |
| Unexpected databaseName, expected | exception | error | glue, partition, metadata-validation, illegal-argument |
| Expected exactly one parameter for VARCHAR | validation | error | presto, varchar, type-system, illegal-argument, ddl |
| 'flight-shim.server-ssl-enabled' is enabled but… | validation | error | configuration, ssl, arrow-flight |
| Invalid position and length in page with positions | exception | error | page, index-out-of-bounds, presto-common |
INVALID_PROCEDURE_ARGUMENT Procedure argument cannot be null: | error_code | error | |
MATERIALIZED_VIEW_STALE Materialized view ' ' is stale | error_code | error | materialized-view, staleness, refresh |
| Metadata field is missing for variant type: | exception | error | |
PINOT_UNABLE_TO_FIND_INSTANCE Error when fetching instance configs for | error_code | error | pinot, controller, instance-config |
| setRowId | exception | warning | jdbc, unsupported-feature, rowid |
| shuffleWriteInfo and broadcastBasePath can not be specified… | validation | error | http, request-validation, spark, illegal-argument |
TABLE_FUNCTION_AMBIGUOUS_RETURN_TYPE Returned relation type for table function | error_code | error | |
| This connector does not support row update | exception | error | spi, unsupported-operation, connector, row-update |
| Unexpected stripe at offset | exception | error | |
ZOOKEEPER_ERROR ZK error checking metadata root | error_code | critical | zookeeper, accumulo, connection, startup |
| Duplicate null-call clause | exception | error | sql-parser, create-function, duplicate-clause |
| failed to get query details | console | warning | web-ui, http, fetch, typescript |
| format(format, args) | exception | error | http-header, assertion, presto-router |
| In differential_entropy UDF, unsupported arguments for type | exception | error | |
| Invalid fetch direction | validation | error | |
| Invalid year month interval qualifier: to | error_code | error | presto, interval, parsing, datetime |
| setUnicodeStream | exception | error | |
| Unsupported type for 'truncate': | exception | error | |
| Expected response code to be 200, but was | exception | error | http, http-status, page-transport, spark, network |
| Failed to resolve host: | exception | error | dns, network, kerberos |
| Port number out of range: | validation | error | spi, network, host-address, port-validation, range-check |
SERVER_SHUTTING_DOWN Server is shutting down | error_code | error | shutdown, server, lifecycle |
| toEpochMillis is not supported for TIMESTAMP( | exception | error | presto, unsupported-operation, timestamp-precision, overflow |
| valueIsNull length is less than positionCount | validation | error | presto, block, illegal-argument, nullability |
| Cannot show roles from catalog | exception | error | security, authorization, roles, metadata |
| Execution endpoint must use HTTP or HTTPS protocol: | validation | error | udf, url-validation, http, config |
| No mapping defined for column | validation | error | kafka, encoder, column-mapping, table-definition |
| ResultSet is closed | exception | error | |
| Table creation is not supported by the kafka connector | exception | error | |
| User defined type is not supported | exception | error | hive, user-defined-type, unsupported-operation |
| VARCHAR length must be a number | validation | error | presto, varchar, type-system, illegal-argument |
| Error reading parquet page in column | exception | error | |
HIVE_FILE_NOT_FOUND Invalid path in Symlink manifest file | error_code | error | hive, symlink-manifest, file-not-found, hdfs |
| Invalid position in block with positions | validation | error | java, presto, illegal-argument, block-position |
INVALID_RESOURCE_GROUP Cannot add queries to | error_code | error | |
| Invalid response from OpenID Metadata endpoint: | exception | error | |
| Not implemented: PreparedStatement.setBinaryStream | exception | error | |
| ConnectorDeleteTableHandle ConnectorDeleteTableHandle | validation | error | |
| SingleMapBlock does not support appendNull() | exception | error | presto, block, unsupported-operation, immutable |
| Unsupported values type: | exception | error | |
DISTRIBUTED_TRACING_ERROR SAMPLE_BASED Tracing Mode is currently not supported. | error_code | error | tracing, configuration, unsupported-feature |
| Invalid BCrypt password | validation | error | |
| Invalid file metadata | exception | error | |
| No console from which to read password | exception | error | cli, password, non-interactive |
| QualifiedObjectName should have exactly 3 parts, found | validation | error | presto, parsing, object-name, illegal-argument |
| Path does not start with a slash: | exception | error | |
| Property for cannot have a null value | error_code | error | presto, properties, null-value, metadata |
| SchemaTableName should have exactly 2 parts | validation | error | spi, illegal-argument, identifier-parsing |
| SQL statement is not a query: | exception | error | jdbc, statement, wrong-api |
| Timeout is negative | validation | error | jdbc, presto, validation, invalid-argument |
| Cannot validate tokens | http | error | oauth2, oidc, jwt, token-validation |
| Duplicate language clause | exception | error | sql-parser, create-function, duplicate-clause |
HIVE_INVALID_FILE_NAMES Hive table ' ' is corrupt. Some of the filenames in the partition: are not… | error_code | error | hive, bucketing, file-naming, corrupt-table |
| Metadata is missing for column | exception | error | |
| InputDistribution InputDistribution | validation | error | |
| RCBinary encoder does not support empty VARBINARY values… | exception | error | rcfile, rcbinary, varbinary, hive-bug |
| Reset stream has a block offset but stream is not… | error_code | error | orc, checkpoint, corruption, compression |
SHEET_BAD_DATA Sheet . is empty | error_code | error | bad-data, empty-sheet, presto |
| version columns not supported | exception | warning | jdbc, metadata, unsupported-feature, presto |
| cancelRowUpdates | exception | error | jdbc, presto, unsupported-feature, sqlfeaturenotsupported |
| Cannot create role | exception | error | security, roles, access-control, authorization |
| Cannot drop function in hive function namespace | exception | error | functions, sql-udf, hive, not-supported |
HIVE_DATABASE_LOCATION_ERROR Database ' ' location is not set | error_code | error | hive, metastore, database-location, ddl |
INVALID_FUNCTION_NAME Temporary functions cannot be qualified. | error_code | error | |
| Invalid property name | validation | error | spi, session-properties, validation, plugin |
| Malformed DN: | exception | error | tls, x509, hex-decoding, dn-parser |
| View not found | exception | error | hive, view, not-found, ddl |
| Cannot create tag on table | exception | error | presto, security, access-denied, tagging |
| Cannot parse enum signature | validation | error | presto, type-signature, enum, parsing |
| Failed to scan changed partitions | exception | error | iceberg, io, file-scan, refresh |
| File does not exist | validation | error | |
| File has no columns | exception | critical | orc, corruption, footer, schema |