k3s-io/k3s
Documented errors, page 2 of 2. Back to k3s-io/k3s
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| only wrote bytes to ; expected | exception | error | go, tar, corruption, download, io |
| server token not found | http | error | k3s, token, credentials, file-corruption, authentication |
| alarm must be disarmed manually | exception | critical | etcd, corruption, alarms, disaster-recovery, disk |
| failed hash verifications | exception | critical | integrity, sha256, corruption, deployment, startup |
| invalid flag use; cannot use --disable-apiserver with… | validation | error | datastore, apiserver, configuration, ha |
| ip: is not ipv4 or ipv6 | validation | error | go, network, ip, dual-stack |
| Rootless is not supported on windows | panic | error | rootless, windows, platform-unsupported, panic, k3s |
| failed link verifications | exception | error | integrity, symlinks, deployment, filesystem |
| token is required to join a cluster | validation | critical | bootstrap, token, cluster-join, ha |
| found multiple bootstrap keys in storage | exception | critical | k3s, bootstrap, etcd, token, migration |
| tar file entry contained unsupported file type | exception | error | go, tar, file-type, archive |
| Requested VPN: is not supported. We currently only support… | validation | error | vpn, config, validation |
| this server has not yet been promoted from learner to… | exception | warning | k3s, etcd, learner, raft, join, transient |
| does not exist, please pass --token to complete the… | validation | error | cluster-reset, restore, token, recovery |
| failed to unmarshal apiserver addresses from etcd | exception | error | etcd, json, apiserver, networking, k3s |
| invalid ip format | validation | error | go, network, ip, parsing, configuration |
| invalid node-ip | validation | error | go, network, configuration, ip, k3s |
| no snapshots given for removal | validation | error | etcd, snapshot, cli, validation, backup |
| %s: %s | console | error | http, connection, agent, status, server |
| unsupported flannel backend | validation | error | flannel, windows, backend, config |
| server is stopping | exception | warning | loadbalancer, lifecycle, transient, network, retry |
| failed to unmarshal tailscale output | exception | error | go, vpn, tailscale, json, parsing |
| no certificates loaded from etcd-s3-endpoint-ca | validation | error | s3, tls, certificates, configuration |
| unsupported encryption keys found | validation | error | security, encryption, kubernetes, configuration |
| cannot perform cluster-reset while server URL is set -… | validation | error | cluster-reset, recovery, etcd, configuration |
| etcd alarm list failed | exception | error | etcd, alarms, nospace, disk, health |
| no IPv6 address found | validation | error | k3s, network, ipv6, node-ip, configuration, dual-stack |
| not running as root | console | error | permissions, root, linux, unix |
| no bootstrap data found | exception | critical | k3s, bootstrap, datastore, etcd, storage |
| node is running k3s version that does not support… | http | error | upgrade, versioning, secrets-encryption |
| etcd datastore disabled | http | warning | k3s, etcd, datastore, http, sqlite |
| fields for file ( ) smaller than required index (key: … | exception | error | integrity, parsing, sha256, manifest |
| method not allowed | http | warning | http, k3s, method-not-allowed, secrets-encryption |
| directory is empty | exception | critical | bootstrap, certificates, data-dir, recovery |
| dual-stack or IPv6 are not supported on Windows node | validation | error | windows, ipv6, dual-stack, platform, cluster-cidr |
| invalid token format | validation | error | token, validation, format, clientaccess |
| auth user not set | http | error | authentication, http, middleware |
| failed to determine MTU for | exception | error | flannel, network, mtu, interface, config |
| host identifier bits must not be set in CIDR prefix | validation | error | networking, cidr, configuration, rootless |
| no IPv4 address found | validation | error | k3s, network, ipv4, node-ip, configuration, dual-stack |
| disarm failed | exception | error | etcd, alarms, nospace, quota, disk |
| delegated cgroup v2 controllers are required for rootless | exception | critical | k3s, rootless, cgroups, cgroup-v2, linux, kubelet |
| multiple global unicast addresses defined for | validation | error | go, network, interface, multi-homed, configuration |
| the interface is not up | exception | error | go, network, interface, link-down |
| tombstone file has been detected but --server is empty… | validation | critical | k3s, etcd, tombstone, join, recovery |
| proxy URL must include scheme and host | validation | error | s3, proxy, configuration, url-parsing |
| all cloud-provider functionality disabled by config | validation | error | cloud-provider, servicelb, configuration, validation |
| invalid cipher text, not : delimited | exception | error | k3s, encryption, aes-gcm, bootstrap, corruption |
| can't find ip for interface | exception | error | go, network, interface, dhcp, address-missing |
| invalid annotation found on node | http | error | annotations, secrets-encryption, cluster-sync |
| pids cgroup controller not found | exception | critical | k3s, cgroups, kubelet, linux, container |
| cannot use S3 config secret when restoring snapshot… | validation | error | k3s, etcd, s3, cluster-reset, credentials |
| server node name not set | validation | critical | k3s, etcd, node-name, hostname, startup |
| etcd: snapshot path must be a file, not a directory | validation | critical | etcd, snapshot, restore, cluster-reset, k3s |
| failed to create path for symlink | console | error | filesystem, permissions, startup, kubeconfig |
| failed to run tailscale status --json | exception | error | go, vpn, tailscale, exec, cli |
| password hash not found in node secret | http | error | authentication, kubernetes, secrets, node |
| tailscale does not provide an ipv4 address | exception | error | tailscale, vpn, ipv4, networking |
| invalid flag use; --server is required with --disable-etcd | validation | error | etcd, cluster, ha, configuration |
| s3 configuration was not set | validation | error | s3, etcd, configuration, backup |
| missing annotation on node | http | error | annotations, secrets-encryption, cluster-sync |
| token must not be empty | validation | error | token, validation, api, clientaccess |
| no entries found in | exception | error | integrity, sha256, deployment, startup |
| invalid flag use; --cluster-reset required with… | validation | error | cluster-reset, restore, etcd, backup, configuration |
| unsupported proxy scheme | validation | error | proxy, network, environment, loadbalancer, url |
| invalid snapshot operation | http | error | http, api, snapshot, validation |
| invalid flag use; cannot use --disable-etcd with… | validation | error | datastore, etcd, configuration, ha |
| --server is required | validation | error | agent, cli, server, config, validation |
| invalid output format: | validation | error | etcd, snapshot, cli, output-format, validation |
| toleration with operator 'Exists' must have an empty value | validation | error | servicelb, tolerations, kubernetes, validation |
| snapshot save already in progress | exception | warning | etcd, snapshot, concurrency |
| no etcd restore path was specified | validation | error | etcd, restore, configuration |
| node password not set | http | error | authentication, http-headers, node |
| only https:// URLs are supported, invalid scheme: | validation | error | token, url, tls, networking, clientaccess |
| node name not set | http | error | authentication, http-headers, node |
| unexpected compressed etcd snapshot contents | exception | error | etcd, snapshot, zip, restore |
| missing argument; 'token delete' is missing token | validation | error | cli, token, usage |
| invalid output format | validation | error | cli, validation, token |