eclipse-vertx/vert.x
Documented errors, page 2 of 4. Back to eclipse-vertx/vert.x
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Cannot have pipelining with no keep alive | validation | error | http, http1, client, config |
| Unsupported WebSocket msg | exception | error | |
| 411 Length Required | http | error | http, content-length, request-framing, vertx |
| 431 Request Header Fields Too Large (RFC6585) | http | error | http, headers, cookies, vertx-http-client |
| cacheDir has been removed. FileResolver is closing? | exception | error | |
| Package structure does not match directory structure | exception | error | verticle, java-source-compilation, package-structure |
| a header value contains a prohibited character | validation | error | http, headers, validation, control-characters |
| Request must have a valid content-type header to decode a… | exception | error | http, multipart, content-type, http1 |
| Unable to create temporary file with prefix | exception | error | filesystem, io, temp-file |
| Failed to decode | exception | error | json, decoding, jackson, stream |
| a header value contains a prohibited character '127 | validation | error | http, headers, validation, ascii |
| File is outside of the cacheDir dir: | exception | error | |
| Multipart form requires multipart/form-data content type… | validation | error | http, multipart, content-type, client |
| Compilation failed | exception | error | |
| Mapping is not available without Jackson Databind on the… | exception | error | json, decoding, missing-dependency, jackson-databind |
| Compilation failed! | exception | error | |
| Invalid position for escape character | validation | error | uri, percent-encoding, index, illegal-argument |
| KeyStore does not contains a valid entry | validation | error | |
| Unmodifiable stream priority | exception | error | http2, immutability, stream-priority |
| HTTP/1.x connections don't support PING | exception | error | http, http2, http1, unsupported-operation, ping |
| cacheMaxTimeToLive must be >= 0 | exception | error | |
| Failed to delete | exception | error | filesystem, delete, io, directory |
| Cannot set chunked after data has been written on request | validation | error | http-request, chunked, state |
| Change group of file not supported | exception | error | filesystem, chown, posix, windows, unsupported |
| Failed to encode as JSON: | exception | error | json, encoding, serialization, jackson |
| invalid escape sequence `% | validation | error | |
| This operation must be called from a Vert.x thread | exception | error | threading, streams, vertx, concurrency |
| Invalid null value passed for traffic shaping options update | validation | error | vertx, traffic-shaping, illegal-argument, null |
| Invalid OID | exception | error | asn1, oid, pki |
| Certificate revoked | exception | critical | tls, certificate, revocation, crl, security |
| Request must have a content-type header to decode a… | validation | error | http, multipart, content-type, validation |
| Resource manager closed | exception | error | lifecycle, closed, resource-manager, illegal-state |
| 429 Too Many Requests (RFC6585) | http | warning | http, rate-limit, retry, vertx-http-client |
| Cannot schedule a timer with initialDelay < 0 | validation | error | timer, scheduling, argument-validation |
| Parsing already done | exception | error | vertx, json-parser, illegal-state, lifecycle |
| 400 Bad Request | http | error | |
| Only the context thread can write a message | exception | error | http, threading, event-loop, http1 |
| Response has already been written | exception | error | http, response, illegal-state, async |
| DNS record decoding error occurred: Unsupported resource… | exception | error | |
| Invalid WebSocket version | http | error | websocket, http1, handshake, version-negotiation |
| Response head already sent | exception | error | http, response-headers, illegal-state |
| Supplied deployable is null | exception | error | deployment, null, supplier, verticle |
| Cannot get canonical name of cacheDir | exception | error | |
| Invalid PKCS8 encoding: could not read Algorithm Identifier | exception | error | pkcs8, der, pki |
| 511 Network Authentication Required (RFC6585) | http | error | |
| Failed to decode | exception | error | json, deserialization, decode, vertx |
| Server already bound | validation | error | quic, http-server, lifecycle, illegal-state |
| HTTP/1.x connections don't support GOAWAY | exception | error | http1, http2, goaway, unsupported |
| Accessed denied for chown on | exception | error | filesystem, chown, security, permissions |
| Invalid type for shareddata data structure | validation | error | shared-data, java, illegal-argument, serialization |
| Request method must be one of POST, PUT, PATCH or DELETE to… | validation | error | http, multipart, http-method, validation |
| 428 Precondition Required (RFC6585) | http | error | http, concurrency, conditional-request, vertx-http-client |
| Cannot read hosts file | exception | error | |
| Invalid authority host portion: | validation | error | validation, host, uri, illegal-argument |
| PQC enforcement policy | exception | error | ssl, pqc, post-quantum, tls |
| 403 Forbidden | http | error | |
| HTTP keepAliveTimeout must be >= 0 | validation | error | |
| Invalid reset code value | validation | error | http2, rst-stream, argument-validation |
| maxExecuteTime must be > 0 | validation | info | http, status-code, gateway, expectation |
| Invalid type for message header value | exception | error | |
| Invalid DER: expected to find an OBJECT_IDENTIFIER (6) in… | exception | error | der, asn1, ec, named-curve, oid |
| Only socket address are currently supported | validation | error | http-client, socket-address, unsupported |
| The provided pointer is not a valid JSON Pointer | validation | error | |
| 506 Variant Also Negotiates (RFC2295) | http | error | |
| File not found: current dir is | exception | error | |
| Invalid DER: not a sequence | exception | error | der, asn1, ec, private-key, format |
| 422 Unprocessable Entity (WebDAV, RFC4918) | http | error | http, validation, rest, vertx-http-client |
| 507 Insufficient Storage (WebDAV, RFC4918) | http | error | |
| address not specified | exception | error | eventbus, reply, missing-address, illegal-state |
| Event Bus is not started | exception | error | eventbus, lifecycle, not-started, illegal-state |
| Invalid DER: object is not a string | exception | error | |
| Invalid WebSocket location | http | error | websocket, http1, handshake, uri, host-header |
| ${certificate.getSigAlgName()} | exception | error | x509, certificate, no-such-algorithm, jca |
| context must not be null | exception | error | streams, null, context, vertx |
| ${e} | exception | error | vertx, json-parser, jackson, initialization |
| Invalid PKCS8 encoding: not a sequence | exception | error | pkcs8, der, pki |
| No ClusterManagerFactory instances found on classpath | exception | error | clustering, service-loader, classpath, spi, missing-dependency |
| 423 Locked (WebDAV, RFC4918) | http | error | http, webdav, locking, vertx-http-client |
| Already a codec registered with name | exception | error | eventbus, codec, duplicate-registration, illegal-state |
| clusterPort p must be in range 0 <= p <= 65535 | validation | error | |
| Set request or WebSocket handler first | exception | error | |
| Missing private key | exception | error | |
| 425 Unordered Collection (WebDAV, RFC3648) | http | warning | http, webdav, ordering, vertx-http-client |
| 501 Not Implemented | http | error | |
| HTTP client must be configured for at least one HTTP version | validation | error | http-client, configuration, protocol |
| 505 HTTP Version Not Supported | http | error | |
| a header value contains a prohibited character '127 | validation | error | http, headers, validation |
| AsyncFile must only be used in the context that created it… | exception | error | |
| Invalid key index | exception | error | context, local-state, illegal-argument, internal |
| Invalid escape sequence: % | validation | error | |
| 426 Upgrade Required (RFC2817) | http | error | http, tls, upgrade, vertx-http-client |
| Invalid url protocol: | exception | error | |
| Missing -----BEGIN PRIVATE KEY----- or -----BEGIN RSA… | exception | error | ssl, pem, private-key, keystore |
| This should be a close frame | exception | error | |
| initialMaxData must be >= 0 | validation | error | |
| 405 Method Not Allowed | http | error | |
| Cannot read hosts config | exception | error | |
| No null bind local address | validation | error | vertx, null, listen, argument-check |
| Unknown ResolvedAddressTypes | exception | error | |
| Invalid DER: length field too big ( | exception | error | der, asn1, length-field, ber, encoding |