derailed/k9s
Documented errors, page 2 of 2. Back to derailed/k9s
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| expected ReferenceRes, but got %T | exception | error | kubernetes, go, type-assertion, references, renderer, k9s |
| invalid command use `context xxx` | validation | warning | command, kubernetes-context, cli, usage |
| chart is in an invalid state | validation | warning | helm, release-status, health |
| unable to launch shell pod on node | console | error | kubernetes, k9s, node, shell-pod, scheduling, image-pull |
| unable to find controller for replicaset | exception | error | kubernetes, replicaset, owner-reference, rollback |
| port-forward is already active on pod | console | warning | k9s, port-forward, duplicate, tunnel, validation |
| access denied for user on | validation | warning | kubernetes, rbac, navigation, namespace |
| expecting screendumper, but got %T | exception | error | go, type-assertion, screendumps, filesystem, renderer, k9s |
| expecting a factory but got %T | exception | error | k9s, xray, context, dao, type-assertion |
| failed to fetch source resource | console | error | kubernetes, k9s, custom-resource, jump, api-error |
| no screendump dir found in context | exception | error | go, kubernetes, context, screendump, dao |
| expecting context Wait | exception | error | go, context, k9s, serviceaccount, dao |
| nothing selected | validation | warning | ui, selection, logs, container, k9s |
| shell exec failed | console | error | kubernetes, k9s, shell, exec, kubectl |
| unable to load bench file | exception | error | benchmark, filesystem, io |
| unable to locate replicas from | console | error | k9s, scale, replicas, table-parsing, views-config |
| default value for number input is not a valid number | validation | error | go, yaml, k9s, plugin, config, validation |
| failed to maintain log stream after | console | error | kubernetes, logs, stream, retry, network |
| failed to decode table rows | exception | error | kubernetes, table, decode, crd, k9s |
| pod must be running. Current status= | console | error | k9s, port-forward, kubernetes, pod-phase, validation |
| the server doesn't have a resource type | exception | error | kubernetes, resource-discovery, crd, api-group |
| unable to parse version in | console | error | kubernetes, k9s, helm, parsing, table-data |
| expecting a ContainsPodSpec for | console | error | kubernetes, k9s, type-assertion, images, workload, dao |
| pod condition ready is false | validation | warning | pod, readiness, conditions, kubernetes |
| expecting a nuker for | console | error | k9s, delete, dao, type-assertion, kubernetes |
| no node assigned | exception | warning | kubernetes, scheduling, pod, ui, k9s |
| failed benchmark | exception | warning | go, kubernetes, benchmark, render, health-status |
| unable to locate container status for | console | warning | kubernetes, pods, containers, status-mismatch |
| no valid selector found on deployment | exception | error | go, kubernetes, k9s, deployment, selector, labels |
| stream closed: for | console | info | kubernetes, logs, eof, stream |
| unsupported resource | validation | warning | xray, allowlist, command, usage |
| expecting a sanitizer for | console | error | k9s, sanitize, dao, type-assertion, pods |
| could not convert revision to a number | validation | error | helm, rollback, validation, strconv |
| port is not available on host | validation | error | port-forward, network, port-in-use |
| container is not ready | exception | warning | go, kubernetes, container, readiness, health-status |
| user is not authorized to scale | exception | error | go, kubernetes, rbac, k9s, scale, subresource, authorization |
| user is not authorized to restart | exception | error | go, kubernetes, rbac, k9s, restart, rollout, authorization |
| unable to marshal resource | exception | error | go, yaml, k9s, marshal, crd, metrics |
| invalid benchmark host | console | error | k9s, benchmark, config, yaml, service |
| node is already cordoned | exception | warning | kubernetes, node, cordon, idempotency, drain |
| user is not authorized to run jobs | exception | error | go, kubernetes, rbac, k9s, cronjob, authorization |
| user is not authorized to delete | exception | error | go, kubernetes, rbac, k9s, delete, authorization |
| osc52 clipboard unavailable: stdout is not a tty or… | validation | warning | terminal, clipboard, osc52, environment |
| unable to locate container named | console | warning | kubernetes, pods, containers, port-forward |
| unable to set image. This pod is managed by | exception | error | kubernetes, pod, owner-reference, image, controller |
| user is not authorized to list nodes | exception | error | kubernetes, rbac, node, authorization |
| no valid selector found on statefulset | exception | warning | kubernetes, statefulset, selector, logs, k9s |
| no column index for | console | error | k9s, scale, views-config, table, yaml-config |
| unable to parse path | console | error | k9s, workload-view, path-parsing, views-config |
| user is not authorized to patch a deployment | exception | error | go, kubernetes, rbac, k9s, deployment, image, authorization |
| no component found for | exception | error | go, viewer-registry, navigation, startup |
| Container is not running? | console | error | kubernetes, pods, containers, lifecycle, debugging |
| kubectl command is not in your path | console | error | kubernetes, k9s, exec, path, environment |
| user is not authorized to view pod logs | exception | error | kubernetes, rbac, logs, pod, subresource |
| invalid annotation | validation | error | kubernetes, port-forward, annotation, configuration, k9s |
| readiness gate check failed | validation | warning | pod, readiness-gates, health, kubernetes |
| the server doesn't have a resource type | exception | error | kubernetes, resource-discovery, crd, typo |
| spec to local port count mismatch. Expected | validation | error | port-forward, configuration, validation |
| user is not authorized to patch a statefulset | exception | error | kubernetes, rbac, statefulset, authorization, k9s |
| desiring replicas got available | validation | warning | deployment, rollout, health, kubernetes |
| no data found for resource | exception | warning | kubernetes, table, header, configuration, k9s |
| no valid selector found for job | exception | error | kubernetes, job, label-selector, logs |
| osc52 payload exceeds encoded size limit | validation | warning | clipboard, osc52, limits, terminal |
| you must provide a selection | exception | warning | ui, selection, logs, statefulset, k9s |
| invalid label selector | console | error | kubernetes, k9s, label-selector, validation, config |
| no valid selector found on daemonset | exception | error | go, kubernetes, k9s, daemonset, selector, labels |
| unsupported resource for scaling | exception | error | go, kubernetes, k9s, scale, gvr, unsupported |
| invalid port-forward specification | validation | error | port-forward, annotation, parsing, kubernetes |
| missing resource name in path | validation | warning | go, kubernetes, ui, path-parsing, edit |
| no connection available | exception | error | kubernetes, connection, xray, startup |
| pod is terminating | validation | info | pod, termination, kubernetes |
| plugin unmarshal failed for | validation | error | go, yaml, k9s, plugin, config, unmarshal |
| failed to process field selector template | console | error | kubernetes, k9s, template, field-selector, config |
| ` ` command not found | validation | warning | alias, command, usage, navigation |
| unable to assert CRD servers versions for | validation | warning | crd, kubernetes-api, validation |
| user is not authorized to list pods | exception | error | kubernetes, rbac, pod, list, recorder |
| container ready check failed | validation | warning | pod, containers, readiness, kubernetes |
| pods failed | validation | warning | job, batch, health, kubernetes |
| node is already uncordoned | exception | warning | kubernetes, node, uncordon, idempotency, drain |
| user is not authorized to update portforward | exception | error | kubernetes, rbac, port-forward, subresource |
| unable to locate node | exception | error | kubernetes, node, not-found, cache |
| nothing selected | validation | warning | go, kubernetes, ui, selection, edit |
| [ ] is deprecated | validation | warning | crd, deprecation, kubernetes-api |
| no matching pods for | exception | warning | kubernetes, labels, selector, pods, k9s |
| no table found for gvr | exception | error | kubernetes, table, gvr, list, k9s |
| desiring replicas but ready | validation | warning | daemonset, rollout, health, kubernetes |
| invalid file name | validation | warning | benchmark, filesystem, naming |
| no describer for | exception | error | kubernetes, dao, describer, interface, k9s |
| resource is not Valuer | exception | warning | kubernetes, values, interface, dao, k9s |
| user is not authorized to get pods | exception | error | kubernetes, rbac, port-forward, pod |
| CRD is no longer served by the api server | validation | warning | crd, kubernetes-api, configuration |
| invalid resource name | validation | warning | xray, alias, command, usage |
| user is not authorized to (un)suspend cronjobs | exception | error | go, kubernetes, rbac, k9s, cronjob, authorization |
| no valid selector found on Service | exception | warning | kubernetes, service, selector, logs, k9s |
| plugin validation failed for | validation | error | go, yaml, k9s, plugin, config, validation |
| no tree renderer defined for this resource | exception | error | kubernetes, tree, renderer, configuration, k9s |
| resource is not Loggable | exception | warning | kubernetes, logs, interface, dao, k9s |
| unable to forward port because pod is not running. Current… | exception | error | kubernetes, port-forward, pod-status |
| no nuker for | exception | error | kubernetes, delete, interface, dao, k9s |
| expected but got | validation | warning | pdb, disruption-budget, health, kubernetes |