apache/shardingsphere
Documented errors, page 2 of 4. Back to apache/shardingsphere
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
1253 COLLATION ' ' is not valid for CHARACTER SET | exception | error | mysql, charset, collation, set-names, validation |
| updateDouble | exception | error | jdbc, resultset, sql-federation, read-only, shardingsphere |
| updateTime | exception | error | jdbc, resultset, sql-federation, read-only, shardingsphere, time |
| setSavepoint | exception | error | jdbc, circuit-breaker, savepoint |
| updateBigDecimal | exception | error | jdbc, resultset, sql-federation, read-only, shardingsphere, bigdecimal |
| ` ` cannot be unwrapped as | exception | error | jdbc, metadata, wrapper, unwrap |
| Column index out of range | exception | error | jdbc, metadata, off-by-one, result-set |
| Expected blr_message | exception | error | jdbc, resultset, sql-federation, read-only, blob, streaming |
30001 Unsupported SQL operation | exception | error | distsql, proxy, unsupported-operation, factory, grammar |
| updateTimestamp | exception | error | jdbc, resultset, sql-federation, read-only, shardingsphere, timestamp |
| Wrong operation during authentication phase | exception | error | firebird, protocol, authentication, wire-protocol |
| Backend executor engine is unavailable in | exception | critical | lifecycle, concurrency, executor, proxy, shutdown |
| Unsupported operator | exception | error | pagination, rownum, operator, rewrite, arithmetic |
| updateNCharacterStream | exception | error | jdbc, sql-federation, resultset, nchar, readonly |
| Unsupported Returning Expression | exception | error | oracle, dml, returning-clause, visitor, unsupported |
| Invalid path ` `. | console | critical | bootstrap, cli, arguments, startup, path |
| Can not find YAML rule configuration with type | validation | error | yaml, rule-configuration, spi, classloading |
| execution_mode is required. | validation | error | mcp, tool-arguments, validation, execution-mode |
| Can not find field name | exception | error | firebird, transaction, concurrency, proxy-frontend |
| getFetchSize | exception | error | jdbc, shardingsphere, generated-keys, fetch-size, unsupported-operation |
| Wrong length ` ` of MYSQL_TYPE_TIME | exception | error | mysql, binary-protocol, date, packet-parsing, misleading-message |
| addBatch sql in PreparedStatement | exception | error | jdbc, shardingsphere, preparedstatement, batch, api-misuse |
| Query did not return a result set. | exception | error | mcp, sql, jdbc, result-set, dialect |
| Missing required format info in createBatch() | exception | error | postgresql, encoding, authentication, startup, utf8 |
| Unexpected trailing bytes in BLR | exception | error | jdbc, resultset, sql-federation, read-only, clob |
| Unsupported data source type | exception | error | pipeline, data-source, factory, configuration |
| Unsupported Firebird format code | exception | error | mysql, prepared-statement, binary-protocol, parameters |
| updateDate | exception | error | jdbc, resultset, sql-federation, read-only, shardingsphere, date |
| Failed to decrypt the ciphertext | exception | error | encrypt, decrypt, key-mismatch, data-corruption |
| Load meta data for schema | exception | error | pipeline, metadata, migration, wrapping-exception |
| Can not find logic encrypt column by | exception | error | encrypt, config, column-mapping, sql-rewriting |
| Truncated batch BLOB segment length | exception | error | firebird, protocol, blob, packet-parsing, truncated-data |
| SQL federation does not support SQL | exception | error | sql-federation, wrapper, execution, calcite |
12010 Can not support variable | exception | warning | distsql, ral, variables, validation |
| execution_mode must be one of . | validation | error | mcp, tool-arguments, validation, execution-mode, enum |
| Invalid 'chunk-size' value | validation | error | pipeline, consistency-check, configuration, validation |
| Unsupported Complex Expression | exception | error | oracle, dml, complex-expression, projection, visitor |
| Can not find shorthand projection segment, owner is | exception | error | encrypt, projection, shorthand, internal-invariant |
| updateBytes | exception | error | jdbc, resultset, sql-federation, read-only, shardingsphere, binary |
| updateRow | exception | error | jdbc, resultset, row-updates, shardingsphere, unsupported-operation |
| Invalid compaction type. Must be 'MAJOR', 'MINOR' or… | validation | error | hive, ddl, compaction, alter-table, validation |
| Invalid port ` `. | console | critical | bootstrap, cli, arguments, startup, port |
| Can not use different encryptor for | exception | error | encrypt, sql-checker, encryptor-mismatch, subquery |
| MCP session exceeded the maximum tool call quota of | validation | error | mcp, quota, tool-calls, rate-limit, session |
| Sharding algorithm class | exception | error | sharding, class-based, algorithm, upgrade, reflection |
| Decode binlog event failed, errorCode | exception | critical | pipeline, mysql, binlog, replication, incremental |
| Failed to start embedded Tomcat runtime. | exception | critical | mcp, tomcat, http, startup, port, bind |
| releaseSavepoint | exception | error | jdbc, circuit-breaker, savepoint, cleanup |
| Can not get value from parameter sets. | exception | error | jdbc, batch, prepared-statement, internal-error |
| Failed to start server. | exception | critical | mcp, startup, server, io, transport |
| Unsupported BLR version | exception | error | jdbc, resultset, sql-federation, read-only, blob |
| updateString | exception | error | jdbc, resultset, sql-federation, read-only, shardingsphere |
| Failed to read java.sql.Blob content | exception | error | firebird, jdbc, blob, io, serialization |
| unsupported SQL statement | exception | error | sql-federation, single, decider, statement-type |
| first | exception | error | jdbc, resultset, sql-federation, cursor, shardingsphere |
| Unsupported object_types value | validation | error | mcp, request-validation, object-types, enum, shardingsphere |
| SQL federation pagination parameter value | exception | error | sql-federation, pagination, limit, validation |
| Unsupported time format | exception | error | postgresql, bind, time, value-parsing |
3 Sharding rules ' ' in database ' ' are still in used by sharding table… | exception | error | sharding, distsql, drop-rule, binding-table, in-use |
| System property ` ` must be a positive integer, but was ` `. | validation | error | mcp, configuration, system-property, startup |
| Unhandled case | exception | error | oracle, dml, projection, visitor, select |
| getParameterType | exception | error | jdbc, shardingsphere, mybatis, parametermetadata, sql-feature-not-supported |
| isSigned | exception | error | jdbc, shardingsphere, parametermetadata, sql-feature-not-supported |
| The SQL clause ' =VALUES( )' is unsupported in encrypt… | exception | error | encrypt, on-duplicate-key-update, assisted-query, values-clause |
| execute with SQL for PreparedStatement | exception | error | jdbc, preparedstatement, execute, unsupported-operation, shardingsphere |
| BLOB fields are not supported in Firebird batch operations | exception | error | jdbc, resultset, sql-federation, read-only, clob |
| Invalid batch handle: statement handle | exception | error | postgresql, extended-protocol, portal, bind, state-machine |
| Underlying SQL state | exception | error | postgresql, bind, bit-type, value-parsing |
| updateXXX | exception | error | jdbc, resultset, updatable-resultset, shardingsphere, unsupported-operation |
| getSQLXML | exception | error | jdbc, shardingsphere, database-metadata, resultset, sql-feature-not-supported, sqlxml |
| Metadata introspection SQL should use MCP metadata… | validation | error | mcp, sql-validation, metadata, shardingsphere |
| Inventory dump failed on | exception | error | pipeline, inventory-dump, migration, wrapping-exception |
| isLast | exception | warning | sql-federation, jdbc, resultset, unsupported-operation |
| getBoolean | exception | error | jdbc, shardingsphere, generated-keys, resultset, sql-feature-not-supported, boolean |
| getObject with map | exception | error | jdbc, resultset, shardingsphere, type-map, unsupported-operation |
| updateBinaryStream | exception | error | jdbc, sql-federation, resultset, blob, readonly |
| Either key generator name or algorithm segment must be… | validation | error | sharding, distsql, key-generate, validation, configuration |
| setFetchDirection | exception | error | jdbc, shardingsphere, generated-keys, fetch-direction, unsupported-operation |
| HiveServer2 in embedded mode has been deprecated by Apache… | exception | warning | mysql, unsupported-command, protocol, proxy-frontend |
400 Load datetime from database failed. | exception | critical | configuration, time-service, database, spi, connection |
WF-VAL-002 Workflow synchronization was interrupted. | exception | error | mcp, workflow, synchronization, interruption |
| unsupported CommonExpressionSegment | exception | error | sql-federation, calcite, expression, converter |
| Invalid statement handle | exception | error | firebird, prepared-statement, batch, statement-handle |
| 'chunk-size' is not a valid number | validation | error | pipeline, consistency-check, configuration, validation |
| approved_steps must contain only | validation | error | mcp, workflow, validation, approval-steps |
30 No tableless route info found. | exception | error | routing, tableless, statement-support |
| Wrong length ` ` of MYSQL_TYPE_DATE | exception | error | mysql, binary-protocol, time, packet-parsing, misleading-message |
| getTime | exception | error | jdbc, shardingsphere, generated-keys, resultset, sql-feature-not-supported, time |
| The configured runtime does not support rule inspection… | exception | error | mcp, distsql, unsupported-feature, compatibility |
| getTimestamp | exception | error | jdbc, shardingsphere, generated-keys, resultset, sql-feature-not-supported, timestamp |
| Projections not in simple select, table subquery, join… | exception | error | encrypt, projection, subquery, unsupported-sql |
| Column index ' ' is out of range. | exception | error | jdbc, metadata, column-index, sharding |
| MySQL BLOB type meta in binlog should be range 1 to 4, but… | exception | error | mysql, binlog, blob, cdc, metadata-mismatch |
| Unknown statement info request type | exception | error | firebird, prepared-statement, describe, protocol |
1050 Table ' ' already exists | exception | error | single, ddl, create-table, routing |
| getHoldability | exception | error | jdbc, resultset, sql-federation, holdability, shardingsphere |
| must be an integer. | validation | error | mcp, validation, arguments, integer-parsing |
| Unknown database information request type | exception | warning | firebird, protocol, sql-info, unsupported-feature, misleading-message |
| Weight ` ` of available target ` ` should be number. | validation | error | load-balance, weight, algorithm, configuration, number-format |
| Can not find ` ` in PostgreSQL command packet type. | exception | error | postgresql, protocol, command-type, tls, wrong-protocol |