apache/seatunnel
Documented errors, page 7 of 22. Back to apache/seatunnel
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| SftpException wrapped (pwd failed while deleting) | exception | error | sftp, io, connection |
| The variable placeholder | console | warning | deprecation, placeholder, doris, template |
| Upsert failed | exception | error | qdrant, grpc, vector-database, write-failed |
FIND_SLACK_CONVERSATION_FAILED Find Slack Conversion Fail. | error_code | error | slack, channel-lookup, api |
| plugin_input must not be empty when configured | validation | error | config, validation, multi-table |
| Python source is disabled by the server-side security… | exception | error | python, security-policy, feature-flag, system-property |
| SNMP SET request timed out for agent | exception | error | snmp, network, timeout, sink |
| The checkpoint coordinator | exception | error | zeta-engine, checkpoint, not-found, pipeline, failover |
| The job id has already been submitted and is not starting… | exception | error | zeta-engine, job-submission, duplicate-jobid |
| The update before event at for table was not followed by… | exception | error | db2, cdc, streaming, change-log, invariant |
| Unable to parse create_replication_slot response | exception | error | postgresql, cdc, replication-slot, jdbc, protocol |
| Failed to drop table: | exception | error | catalog, lance, drop-table, namespace |
FILE_SCAN_SPLIT_FAILED Failed to scan iceberg splits from: | error_code | error | iceberg, io, split-planning |
KERBEROS_AUTHENTICATION_FAILED Kerberos authentication failed using this principal | error_code | error | kerberos, authentication, jdbc, security |
| MySQL-CDC diagnostic: required binlog sequence | console | warning | mysql, cdc, binlog, retention, diagnostics |
| Option 'operation_timeout_ms' must be greater than zero | validation | error | config, validation, azure |
| OptionValidationException(e.getMessage()) | validation | error | jdbc, config-validation, options |
SEND_RESPONSE_FAILED Send response message to DinkTalk server failed | error_code | error | dingtalk, network, http |
| start_timestamp can't be negative | validation | error | hbase, validation, timestamp, config |
| All fields in row are null, skipping | console | warning | data-quality, null-values, skip, traditional-mode |
| cluster have no master node | exception | critical | seatunnel, zeta-engine, hazelcast, master-election, cluster |
DECRYPT_FAILED Decryption failed for batchId= | console | error | decryption, secret-key, crypto, socket-source |
| Hive does not support schema in `table_name` when… | validation | error | hive, config, regex, escaping |
| Interrupted during MQTT publish retry | exception | warning | mqtt, interrupted, retry, io-exception |
| Invalid YashanDB JDBC URL format | validation | error | jdbc, config-validation, url |
| Job id restore interrupted while entering pending queue | exception | warning | interrupted, pending-queue, failover, job-restore, zeta-engine |
| No existing ancestor found while resolving local path | exception | error | io, file-connector, local-filesystem, path-resolution |
| part size is less than , set to default value | console | warning | clickhouse, configuration, split-size, clamping |
| PostHog source connector only supports batch mode | exception | error | seatunnel, connector, batch-mode, posthog |
| rename file failed, will continue move file, but maybe… | console | warning | clickhouse, file-io, filesystem, conflict |
| Sample dry-run mode cannot be combined with validation, job… | validation | error | cli, dry-run, mutually-exclusive |
| schema.constraintKeys | validation | error | config, vector-index, constraint |
| Subtask ID is out of server id range , please adjust the… | validation | error | mysql, server-id, parallelism, configuration |
| Unable to convert to LocalDate from a java.sql.Time value ' | exception | error | cdc, datetime, type-mismatch, conversion |
| Unsupported row kind | console | warning | hugegraph, row-kind, cdc, unsupported |
| Failed during source_listing setup/scan for protocol= | exception | error | io, hadoop, file-discovery |
| Failed to discover remaining tables to capture | exception | critical | jdbc, cdc, table-discovery, connection |
FILE_TYPE_INVALID Check orc file [ ] failed | exception | error | orc, file-format, io, file-source |
| [FileSchemaEvolution] DROP event references unknown column | console | warning | schema-evolution, cdc, file |
GET_MYHOURS_TOKEN_FAILE Login http client execute exception, http response status code | error_code | error | seatunnel, http, authentication, myhours |
| Unknown Job State | exception | error | zeta-engine, job-state, switch-default, state-machine |
| Unsupported convert to Row, typeDefine | exception | error | type-mismatch, row-conversion, seatunnel-api |
| Unsupported FloatingPoint precision: | exception | error | lance, arrow, float, unsupported |
| Cluster name is required. Please specify it using -cn or… | exception | error | cli, cluster, hazelcast, missing-option |
COMMON_ILLEGAL_ARGUMENT file_name_expression must contains | error_code | error | file-sink, transaction, filename-template |
| Could not query the view | console | error | oracle-cdc, logminer, sql, permissions |
| Failed to read schema for table | exception | error | oracle, cdc, jdbc, schema-read |
| Option ' ' is a List, and it is recommended to configure it… | console | warning | configuration, list-parsing, type-conversion |
| PostHog option ' ' must not be blank | validation | error | seatunnel, posthog, config, validation |
| previous schema changes in progress, schemaChangePhase | exception | error | schema-change, concurrency, source |
| Received DML 'sql' for processing, binlog probably contains… | console | warning | mysql, cdc, binlog, replication-format |
| received unexpected exception will perform keep alive | exception | error | cdc, postgres, opengauss, keep-alive, network, replication |
| start.mode.timestamp must not be greater than the current… | exception | error | rocketmq, source, timestamp, start-mode |
| The value of Metric does not support | exception | error | metrics, connector, type-mismatch |
| Utility class | exception | info | java, utility-class, anti-instantiation |
| Both 'mappings' and 'schema_config' are present… | console | warning | config, conflict, hugegraph, deprecation |
CommonErrorCodeDeprecated.TABLE_SCHEMA_GET_FAILED Column [ ] does not exists in table schema [ ] | error_code | error | orc, schema, column-missing, file-source |
| Configuration value overflows/underflows the integer type. | validation | error | |
| Failed to close equality delta writer | exception | error | iceberg, sink, io |
| Failed to load JDBC driver | console | warning | jdbc, driver, classpath, sink |
| Failed to process regex table path: | exception | error | jdbc, regex, metadata, table-discovery |
| set time-characteristic failed, unknown time-characteristic | validation | warning | flink, config, time-semantics |
API-09 Handle save mode failed | error_code | error | save-mode, sink, database |
| ${e.message} | validation | error | paimon, config, validation |
| Exactly once is enabled, but not found primary key or… | exception | error | cdc, jdbc, primary-key, exactly-once, chunk-splitting |
| Failed to persist failure sample to | console | warning | hugegraph, io, file-write, dirty-data |
| Invalid Params format in Params. | exception | error | rest, url-parsing, query-string |
| MySQL-CDC diagnostic: required binlog sequence | console | warning | mysql, cdc, binlog, diagnostics |
| Param [ ] is not set in error message [ ] | validation | error | error-codes, params, argument-validation |
| Please configure unique `database`.`table`, not allow… | validation | error | config-validation, doris, duplicate |
| plugin dir: not exists, load plugin from classpath | console | warning | plugin-discovery, classpath, configuration |
| Post-sync delete: rename-to-trash failed, will retry… | console | warning | file-connector, post-sync, delete, rename, filesystem |
| Unsupported convert to OffsetDateTime, typeDefine | exception | error | type-mismatch, datetime-conversion, seatunnel-api |
| Unsupported operation | error_code | error | cdc, debezium, rowkind, serialization |
| Error while checking whether table exists under path | exception | error | hadoop, filesystem, io, hudi |
| Failed to open AmazonDocumentDB source reader for database | exception | critical | java, documentdb, connection, startup |
| Failed to parse file modified date format: yyyy-MM-dd… | exception | error | config, date-parsing, file-filter, format |
| Post-sync backup staging disappeared before verification… | console | warning | hadoop, file-source, staging, file-not-found, retryable |
| Unable to open file: , Aborting | exception | error | ftp, io, network, filesystem |
| Unsupported type for numeric plus. | exception | error | cdc, numeric-type, snapshot-splitting, unsupported-type |
INSERT_DOC_ERROR INSERT_DOC_ERROR.getDescription() | error_code | error | typesense, sink, http, batch-write, retry |
| Metrics snapshots are updated through merge semantics… | exception | error | zeta-engine, metrics, state-store, unsupported-operation, api-misuse |
| MySQL-CDC diagnostic: variable | console | info | mysql, cdc, diagnostics, variables, version-compat |
| not supported create new Offset by filename and position. | exception | error | oracle-cdc, unsupported-operation, offset, scn |
| Unable to connect to the MySQL database at | exception | error | mysql, cdc, network, connection, debezium |
| Unsupported Timestamp unit | exception | error | lance, arrow, timestamp, unsupported-unit, sink |
| Failed during target_bulk_listing for path= | exception | error | io, hdfs, listing, metadata |
| Failed to clear scroll ID | console | warning | elasticsearch, scroll, cleanup |
| Failed to get cluster members information | exception | error | cluster, hazelcast, network, cli |
| Kerberos re-login from keytab failed | console | warning | kerberos, hadoop, authentication |
| SeaTunnel transform task | exception | error | spark, transform, job-failure |
| Skip failed sink table in Flink starter | console | warning | flink, sink, multi-table |
| Unsupported MySQL version: | exception | error | jdbc, mysql, version-parsing, compatibility |
| Unsupported type | exception | error | json, cdc, type-mismatch, debezium |
| Checking catalog path | exception | critical | filesystem, io, catalog, hdfs |
COMMON_WRITER_OPERATION_FAILED (CommonErrorCodeDeprecated.WRITER_OPERATION_FAILED) Close kafka sink writer error | error_code | error | kafka, sink-writer, resource-close, producer |
CONNECT_DATABASE_FAILED unable to build XADataSource | error_code | critical | jdbc, xa, datasource, config |
| Consumer for queue already exists, skipping | console | warning | rabbitmq, duplicate-splits, recovery |
| Error sink writer failed during shutdown | console | warning | error-sink, shutdown-race, data-loss, drain-loop |
| Failed to authenticate to the MySQL database at | exception | error | mysql, cdc, authentication, debezium |