apache/cassandra

Documented errors, page 3 of 30. Back to apache/cassandra

Code / MessageTypeSeverityTags
Unsupported snitch
exception error accord, snitch, configuration, illegal-argument
Cluster Metadata Identifier mismatch. Node is attempting to…
exception critical cassandra, tcm, cluster-identity, peer-communication
Corrupted key cache. Key length of
exception error cache, deserialization, corruption, startup
must be positive.
validation error guardrails, configuration, password-policy
The tree position is less than zero.
exception error cassandra, sai, index-corruption, metadata
Constraint ' ' can be used only for columns of type but it…
validation error cql, schema, constraints, type-mismatch
Could not catch up to epoch
exception error tcm, cms, catch-up, epoch, timeout
Failed to transfer all hints to
exception error java, hints, network, internode
Slice conditions ( ) are not supported on durations
validation error cql, duration, lightweight-transactions, conditions
Cannot change transactional mode from
validation error cassandra, accord, migration, state-machine, transactional-mode
Found empty hints file
console warning hints, startup, corruption, cleanup
Memtable class does not accept any futher parameters, but…
validation error cassandra, configuration, memtable, reflection
Not enough bytes to deserialize collection
exception error cassandra, java-driver, deserialization, corrupt-data
is of version which is now unsupported and cannot be read.
validation error sstable, descriptor, versioning, upgrade
Corrupt flags value for clustering prefix (isStatic flag…
exception critical cassandra, corruption, sstable, deserialization, io
Could not cancel in-progress sequence
console warning cassandra, accord, cluster-metadata, transaction
Multiple sstable format implementations with the same name
validation error configuration, sstable, startup
Out of journal flushes over the past s with average…
console warning disk, fsync, performance, journal
SASL negotiation not complete
exception error authentication, sasl, lifecycle
3
Unable to verify sstable files on disk
error_code error startup, sstable, filesystem
Configured node identity is not matching identity…
exception error tls, mtls, configuration, internode-authentication
Invalid queue identifier
validation error accord, parsing, enum
Secondary indexes are not supported on transiently…
validation error cassandra, secondary-index, transient-replication, replication
The arbitrary command execution is not permitted with
exception critical security, jmx, arbitrary-command-execution
Config contains both old and new keys for the same…
console error cassandra, yaml, configuration, deprecated-keys
failed to create encyption context for hints file. ignoring…
console warning hints, encryption, config, io
Node is not in gossip, not running GossipTask
console info gossip, startup, lifecycle
Not marking nodes down due to local pause of
console info failure-detection, gc-pause, gossip
has authorization enabled which requires to enable…
validation error auth, configuration, startup, cassandra-yaml
Some hints were not written before shutdown. This is not…
console warning hints, shutdown, repair, hints-handoff
CoordinatorBehindException (read command serialized at…
exception error distributed-consistency, schema-epoch, tcm, replica-lag
It is not possible to reconfigure password_policy guardrail…
console warning guardrails, security, configuration, runtime-reconfiguration
Unable to allocate
exception error cache, serialization, memory-allocation
UNSAFE_MIXED_MUTATIONS_MSG
exception error accord, mixed-mutations, unsafe-operation, invalid-request, transactions
Cannot parse 32-bits int value from
exception error cassandra, codec, invalid-type-exception, parsing, cql-int
Error occured when getting the guardrails config
console error nodetool, jmx, guardrails, connection
Insufficient disk space to store
exception critical disk-space, io, streaming, capacity
Operator is only supported in intersections for reads that…
exception error sai, query-planning, invalid-request, consistency
constraint of relation ' ' is not supported. Only these are
validation error cassandra, cql, constraints, schema-definition
Snapshot name contains illegal characters: . Allowed…
validation error snapshot, validation, illegal-characters
This node was started with paxos variant
console warning paxos, lwt, consistency, configuration, upgrade
Unable to find sufficient sources for streaming range
console error streaming, bootstrap, replication-factor, data-loss, node-down
Cluster metadata identifier mismatch from
console warning gossip, cluster-metadata, split-brain
Couldn't read from temporary stress log file
exception error io, file-read, temp-file
requires
validation error auth, configuration, startup, role-manager
Unsupported commit log version:
exception critical commitlog, version-mismatch, restore
Can't abort bootstrap for - it does not exist in cluster…
exception error nodetool, cluster-metadata, bootstrap, invalid-argument
Duplicate column ' ' in PRIMARY KEY clause for materialized…
validation error cql, materialized-view, primary-key, duplicate-column
Invalid folder descriptor trying to create log replica
exception error filesystem, transaction-log, file-descriptor
Transaction Statement is unsupported when migrating away…
validation error cql, accord, transactions, migration
Unkown field in user type
validation error cassandra, cql, udt, rename, typo
Invalid configuration for cms_commit_retry_strategy.
validation error configuration, startup, retry-strategy, cassandra
Unexpected extraneous bytes after map value
validation error serialization, validation, collections
Unsupported expression during index query:
exception error cassandra, sai, query, unsupported-operation
Because of this name
exception error cassandra, schema, unsupported-type
Could not create SSL Context.
exception critical ssl, tls, sstableloader
Couldn't parser stats json
exception error json, parsing, stress-graph
Failed to initialize command line hierarchy
exception critical cli, picocli, initialization, nodetool
Failed to update per-SSTable components for SSTable
console warning sai, sstable, index-components, corruption
Replica filtering protection has cached over
console warning query, filtering, memory, coordinator
this + " is not supported as conditional update commit…
validation error cassandra, consistency-level, lwt, validation
Write request failed due to coordinator behind
exception error
Cannot take a snapshot on secondary index or invalid column…
validation error snapshot, entity-format, argument-validation
Clustering keys must be in ascending lexographical order
exception error cassandra, sai, ordering, internal-invariant
(dynamic) e.getMessage() from SSTableAcquisitionException
console warning repair, compaction, concurrency
Invalid SSTable , please force %srepair
exception critical sstable, corruption, verification, repair
Invalid value for system property: expected size in bytes…
validation error configuration, system-properties, startup
min_index_interval of
console warning cassandra, index-summary, configuration, memory
must be positive.
validation error configuration, guardrails, password
Can't revert join from
exception error tcm, bootstrap, join-revert, state-machine, illegal-state
Decompressed lengths mismatch
exception critical lz4, decompression, data-corruption, io
Failed to create SSL context using
exception error ssl, tls, keystore, ioexception, validation
Invalid limit value
validation error cql, limit, binding, type-mismatch
Replica filtering protection has cached over
exception error read-path, filtering, memory, overload
Setting capacity of NopCache is not permitted as this cache…
exception error cache, unsupported-operation, configuration
ttl for snapshot must be at least
validation error snapshot, ttl, validation
Unable to move
exception error move, execution-exception, streaming, topology
Attempting to compact pending repair sstables with sstables…
exception error compaction, incremental-repair, internal-invariant
Cannot drop user type
validation error cassandra, cql, udt, dependency
Data file partition position
console warning cassandra, scrub, sstable, index-mismatch
Dropping data... (Attempted to write a non-empty value…
console error serialization, data-loss, schema
Invalid or malformed
validation error cql, syntax, parsing
throw new RuntimeException(e)
exception info jmx, objectname, unreachable
CorruptSSTableException wrapping…
exception critical sstable, corruption, parsing, storage
ex.getMessage()
validation error cql, invalid-enum-value, duration
Insufficient remaining bytes to deserialize Inner node…
exception error merkle-tree, buffer-overflow, serialization
constraint can not be specified on a key column
validation error cql, schema, constraints, primary-key, not-null
Some directories failed to import, check server logs for…
console error nodetool, import, sstable, compaction, server-side
Triggers are present but TriggersPolicy.forbidden is…
exception error triggers, configuration, policy, invalid-request
Unable to create instance of generator of class
validation error guardrails, configuration, reflection
When adding a read replica, that replica needs to exist as…
exception error replication, read-replica, placement, invalid-state-transition
You can't mix sstables from different directories in a…
exception error compaction, jbod, unsupported-operation, directories
Attempted to use message version " + messagingVersion + "…
exception error versioning, accord, compatibility
Couldn't commit the transformation. Is the node shutting…
exception error tcm, interrupted, shutdown, cluster-metadata
Invalid configuration of startup_checks:
validation error configuration, startup-checks, cassandra
Not enough bytes to read value size of component
validation error serialization, composite-type, validation
compression dictionary is not created for dict id
exception error cassandra, compression, zstd-dictionary, state
Already logging to
exception error logging, configuration, illegal-state
Column deletion is not supported by table
exception error virtual-table, invalid-request, unsupported-delete
IO exception while reading file
console warning io, filesystem, startup-check