anomalyco/sst
Documented errors, page 3 of 4. Back to anomalyco/sst
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| You cannot provide both "job" and "function" in the | exception | error | config, validation, deprecated-api, cron |
| Cannot access `nodes.cluster` in dev mode. | exception | error | dev-mode, elasticache, redis, sst |
| File ' ' not found | error_code | error | filesystem, config, cli |
| Cannot provide both "domain" and "route". Use the "domain"… | validation | error | ssr-site, router, domain, config-conflict |
| failed to open source binary | exception | error | go, rust, filesystem, build |
| Request count scaling is only supported for http/https… | validation | error | aws, ecs, autoscaling, alb, sst |
| expecting JSON key should be always a string: %T | validation | error | go, json, unmarshal, malformed-input |
| failed to read workspace directory | exception | error | filesystem, python, build, workspace |
| Bastion instance profile must be a name, not an ARN. | validation | error | vpc, bastion, iam, config-validation, aws |
| Failed to stop task | error_code | error | aws, ecs, network, iam |
| Lambda@Edge functions must be deployed in us-east-1 region… | validation | error | lambda-edge, cloudfront, region, arn |
| Provisioned concurrency requires function versioning. Set… | validation | error | aws, lambda, provisioned-concurrency, versioning, config-requirement |
| no package archive found for | exception | error | python, pip, package-install, glob |
| Cannot access `nodes.autoScalingTarget` in dev mode. | exception | error | dev-mode, autoscaling, nodes, sst |
| Failed to run task | error_code | error | aws, ecs, network, iam |
| sst.aws.linkable is deprecated. Use sst.Linkable.wrap… | exception | warning | deprecation, linking, aws, api-migration |
| result.errors.join("\n") | validation | error | aws, lambda, esbuild, bundling, build-error |
| Could not load Vite configuration from | exception | error | remix, vite, config, sst |
| failed to put bucket policy for | exception | error | aws, s3, bucket-policy, ssl |
| React Router assets directory not found at | validation | error | react-router, cloudflare, build-output, assets |
| Invalid provider type | exception | error | aws, cognito, oauth, config-validation |
| Cannot access the created function because it is referenced… | validation | error | lambda, arn, external-resource |
| failed to copy workspace packages for container | exception | error | filesystem, python, container, docker, workspace |
| Failed to lookup secret for Redis cluster | exception | error | redis, elasticache, secret, tags, version-migration |
| Could not find config file for | validation | error | cloudflare, framework-config, vite, missing-file, sst-config |
| Unsupported response_type | http | error | oauth, auth, http-400, configuration |
| You are using the "Vpc.v1" component. Please migrate to the… | exception | error | vpc, migration, deprecated-api, postgres |
| failed to copy synced dependencies | exception | error | filesystem, python, dependencies, lambda, build |
| TanStack Start assets directory not found at | validation | error | tanstack-start, cloudflare, build-output, assets |
| The provided ARN " " is not a ElasticSearch domain ARN. | validation | error | arn, elasticsearch, validation |
| failed to create form part metadata | exception | error | cloudflare, multipart, metadata, go |
| You must provide a "container" name in each rule when there… | validation | error | load-balancer, containers, validation |
| Could not find handler file | validation | error | aws, lambda, handler, file-not-found |
| waitUntil requires a valid Date | validation | error | typescript, validation, workflow, invalid-date |
| aws provider not found | exception | error | aws, pulumi, provider, rpc, bootstrap |
| You cannot provide both a function and a task in the | exception | error | config, validation, cron, ecs |
| You cannot set both aliases and usernames. Learn more about… | exception | error | aws, cognito, authentication, mutually-exclusive, config-validation |
| client_id mismatch | http | error | oauth, auth, security, client-id |
ErrCloudflareMissingAccount missing account | error_code | error | cloudflare, config, account-id, init |
| At least one condition (path, query, or header) must be set… | validation | error | load-balancer, alb, validation, routing |
| expect end of JSON object but got more token: %T | validation | error | go, json, unmarshal, trailing-data |
| You must provide the password to connect to your locally… | exception | error | opensearch, dev-mode, password, configuration |
| Lambda@Edge requires a qualified ARN (with version). Got | validation | error | lambda-edge, arn, versioning, cloudfront |
| Build ID not found in ".next/BUILD_ID" for site | exception | error | nextjs, build-id, missing-file, build |
| Function URL is not enabled. Enable it with "url: true". | validation | error | aws, lambda, function-url, missing-config |
| You must provide a custom domain for | validation | error | load-balancer, tls, certificate, domain |
| Missing "vpc.containerSubnets" for the | exception | error | aws, ecs, vpc, subnets, missing-property |
| No build output found at | validation | error | static-site, build-output, path-validation, config-validation |
| Failed to get username for OpenSearch | exception | error | opensearch, reference, tags, credentials |
| JSON value can't be decoded: %T | validation | error | go, json, type-mismatch, unmarshal |
| You must provide the ports to expose via… | validation | error | aws, ecs, alb, configuration, sst |
| At least one of function, queue, or topic is required for… | exception | error | aws, s3, bucket-notification, missing-config |
| Could not load OpenNext output file at | exception | error | nextjs, opennext, build-output, missing-file |
| failed to decode cloudflare unenv config | exception | error | worker, cloudflare, json, build, subprocess |
| Priority must be between 1 and 50000 in Service " ". When… | validation | error | load-balancer, alb, validation, priority |
| Only one of function, queue, or topic is allowed for the | exception | error | aws, s3, bucket-notification, config-conflict |
| Site directory not found at | validation | error | ssr-site, path, config, fs |
| Unsupported memory: . The supported values for memory for a… | validation | error | ecs, fargate, memory, validation |
ErrLockExists Concurrent update detected, run `sst unlock --stage= | error_code | error | state, lock, concurrency, deploy |
| Failed to get password for OpenSearch | exception | error | opensearch, reference, tags, credentials |
| You must provide a container name in "loadBalancer.rules"… | validation | error | aws, ecs, alb, configuration, sst |
| Cannot access `nodes.cloudmapService` in dev mode. | validation | error | dev-mode, cloudmap, service-discovery, nodes |
| The provided ARN " " is not a DSQL cluster ARN. | validation | error | arn, dsql, validation |
| illegal file path in zip | exception | critical | python, security, zip-slip, wheel |
| Incompatible "astro-sst" adapter version detected. The… | exception | error | astro, version-mismatch, adapter, dependency |
| The VPC endpoint has no DNS entries. | validation | error | dsql, dns, vpc-endpoint |
| You cannot provide both a function and a task in the | exception | error | config, validation, cron, ecs |
| unsupported platform | error_code | error | platform, bun, installation |
| Found in " " for . Remove it to avoid interfering with SST… | validation | error | cloudflare, wrangler, vite-plugin, conflicting-config, sst-config |
| The "routeSite" function has been deprecated. Configure the… | exception | error | deprecation, router, api-migration, sst |
| VPC bastion is not enabled. Enable it with "bastion: true"… | validation | error | vpc, bastion, config-validation, aws |
| TanStack Start server bundle not found at | validation | error | tanstack-start, cloudflare, build-output, missing-file |
| The `namespaceId` property must be a positive integer. | validation | error | cloudflare, configuration, validation, rate-limit |
| The provided ARN " " is not a Kinesis stream ARN. | validation | error | arn, kinesis, validation, sst |
| Cannot set both "logging.retention" and "logging.logGroup" | validation | error | aws, lambda, logging, config-conflict |
| invalid archive name format | exception | error | python, sdist, naming, archive |
| SolidStart's nitro.config.ts must be configured to use the… | validation | error | solidstart, nitro, cloudflare, preset, build-config |
| The "vpc.subnets" property has been renamed to… | validation | error | aws, lambda, vpc, breaking-change, renamed-property |
| Cannot provide both "edge" and "route". Use the "edge" prop… | validation | error | ssr-site, router, edge, config-conflict |
| failed to move extracted package | exception | error | python, filesystem, move, build |
| Proxy is not enabled. Enable it with "proxy: true". | exception | error | mysql, aws, rds-proxy, configuration |
| expect JSON object close with '}' | validation | error | go, json, unmarshal, truncated |
| failed to make binary executable | exception | error | rust, build, permissions, filesystem |
| failed to open zip | exception | error | python, wheel, zip, corrupt-file |
| The number of Elastic IP allocation IDs must match the… | validation | error | vpc, nat, elastic-ip, config-validation, aws |
| Unsupported storage: . The supported value for storage is… | validation | error | aws, fargate, storage, validation |
| You must provide at least one rule in "loadBalancer.rules"… | validation | error | load-balancer, validation, alb, shared-infrastructure |
| Cannot create more than 15 read-only replicas for the | exception | error | aurora, rds, limits, config-validation |
| Duplicate priority on listener " " in Service " ". | validation | error | load-balancer, alb, validation, priority |
| Durable functions require "logging.format" to be set to… | validation | error | aws, lambda, durable, logging |
| failed to parse properties | exception | error | json, serialization, python, build |
| Container " " in "loadBalancer.rules" does not match any… | validation | error | load-balancer, containers, validation |
| Failed to get auth token for Redis | exception | error | redis, elasticache, secret, auth-token |
| not implemented | exception | error | worker, cloudflare, dev, unimplemented |
| Storage must be at least 20 GB for the | validation | error | mysql, aws, rds, validation |
| failed to hash file | exception | error | go, filesystem, hashing, io |
| Could not find hosted zone for domain | exception | error | cloudflare, dns, hosted-zone, domain, api-token |
| Found "base" configured in vite.config.ts but missing… | validation | error | vite, react-router, asset-paths, configuration |
| failed to extract archive | exception | error | python, tar, extraction, corrupt-file |
| The provided ARN " " is not a DynamoDB stream ARN. | validation | error | arn, dynamodb, streams, validation, sst |