TechnitiumSoftware/DnsServer
Documented errors, page 3 of 5. Back to TechnitiumSoftware/DnsServer
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| Cannot unsign zone: the is zone not signed. | exception | error | csharp, dns, dnssec, zone-management, concurrency, technitium-dns |
| Failed to promote to Primary node: the Cluster Secondary… | exception | error | cluster, dns-zone, promote, missing-state, technitium |
| User already exists | exception | error | auth, user-management, duplicate |
| Cluster node URL must use HTTPS scheme. | validation | error | cluster, validation, constructor, tls, security |
| Failed to add Secondary node: a maximum of 255 nodes are… | exception | error | cluster, join, capacity-limit, scaling |
| Failed to update Primary node: the Cluster Secondary… | exception | error | cluster, dns-zone, update-primary, missing-state, technitium |
| The Dynamic Updates option is invalid for Secondary… | validation | error | dns, secondary-forwarder-zone, dynamic-updates, config, enum, zone-type |
| The zone '<memberZoneInfo.DisplayName>' is already a member… | exception | error | dns, catalog-zone, membership, conflict, input-validation |
| Failed to delete Cluster: only a Primary node can delete… | exception | error | cluster, authorization, primary-node, delete, rbac |
| Port 853 is reserved for DNS-over-TLS service. Please use a… | exception | error | dns, port-conflict, dns-over-tls, configuration |
| The application name contains an invalid character | exception | error | dns, application, validation, filesystem, security, path |
| Username cannot be null or empty. | validation | error | auth, user-management, validation |
| Serve stale reset TTL must be between | validation | error | dns, cache, serve-stale, validation, configuration |
| The ECDSA ( ) private key must have key size of 256 bits. | exception | error | dns, dnssec, crypto, ecdsa, pem, key-size |
| DNS Server does not have TSIG key | exception | error | tsig, zone-transfer, auth, secondary-zone |
| Failed to update Cluster options: The config refresh… | validation | error | cluster, configuration, validation, dns-server |
| Invalid AdGuard Upstreams config file format: missing… | exception | error | csharp, config, adguard, format, technitium, advanced-forwarding-app |
| DNSSEC private key format is invalid. | exception | error | dns, dnssec, crypto, serialization, binary, format |
| Time-based one-time password (TOTP) is already disabled for… | exception | warning | auth, totp, mfa, state, technitium-dns-server |
| User account is disabled. Please contact your administrator. | exception | error | auth, login, user-management, disabled |
| Valid range is from 1 to 4. | exception | error | dns, configuration, validation, resolver, concurrency, limits |
| Cannot set record: SOA RETRY cannot be greater than SOA… | exception | error | dns, record, soa, refresh, retry, validation |
| Failed to resync configuration: only Secondary nodes can… | exception | warning | cluster, role-guard, config-resync, primary-node, technitium |
| The SSO Scopes cannot have more than 255 entries. | validation | warning | sso, config, validation, length-limit, oidc-scopes |
| Cannot delete SOA record. | exception | error | dns, primary-zone, soa, immutable-record, delete |
| Web service TLS certificate path length cannot exceed 255… | validation | error | dns-server, technitium, tls, certificate, input-validation, configuration, csharp |
| At least one parameter must be provided. | validation | error | http-api, client, cluster, argument-validation |
| EDNS Client Subnet IPv4 Override must be an IPv4 network… | exception | error | dns, edns, ecs, ipv4, configuration |
| Failed to add Secondary node: only a Primary node can add a… | exception | error | cluster, authorization, primary-node, join, rbac |
| Failed to update Primary node: the Primary node's domain… | exception | error | cluster, validation, duplicate, naming, update-primary, technitium |
| Serve stale max wait time valid range is 0 to 1800… | exception | error | dns, configuration, validation, cache, resolver, limits |
| Failed to add Secondary node: node ID already exists in the… | exception | error | cluster, join, id-conflict, uniqueness |
| The private keys must contain at least one Zone Signing Key. | validation | error | csharp, dns, dnssec, validation, technitium-dns |
| The SSO Client ID length cannot be more than 255 chars. | validation | warning | sso, config, validation, length-limit |
| The SSO Group Map cannot have more than 255 entries. | validation | warning | sso, config, validation, length-limit, group-mapping |
| Username can contain only alpha numeric, '@', '-', '_', or… | validation | error | auth, user-management, validation, character-encoding |
| Web Service config file format is invalid. | exception | critical | dns-server, technitium, configuration, config-file, binary-config, csharp |
| Failed to promote to Primary node: only Secondary nodes can… | exception | error | cluster, role-guard, promote, secondary-node, technitium |
| The private key must be a Zone Signing Key. | validation | error | csharp, dns, dnssec, validation, technitium-dns |
| Valid range is from 1 to 10. | exception | error | dns, configuration, validation, resolver, limits |
| Failed to update Primary node: the specified Primary node… | exception | error | cluster, validation, update-primary, stale-reference, technitium |
| Group already exists | exception | error | auth, group-management, duplicate |
| Networks cannot have more than 255 entries. | exception | error | dns, zone-transfer, acl, configuration |
| Cannot configure more than 255 block list URLs. | validation | error | dns, blocklist, validation, configuration |
| Cannot update NSEC3 parameters: the zone must be signed… | exception | error | dnssec, nsec3, state-precondition, validation, csharp |
| Cannot update record in | exception | error | dns, secondary-subdomain-zone, read-only, immutable, zone-type, update |
| DnsServer allowed zone file version not supported. | exception | error | dns, csharp, config, version-mismatch, technitium |
| DnsServer blocked zone file format is invalid. | exception | error | dns, blocked-zone, config-file, serialization, startup |
| Forwarder was not defined | exception | error | csharp, config, json, schema, reference, technitium, advanced-forwarding-app |
| All name servers failed to answer the request | exception | error | recursion, forwarder, network, rcode, dnssec |
| DnsServer block list zone file format is invalid. | exception | error | dns, blocklist, config-file, serialization, startup |
| Failed to add Secondary node: the Secondary node domain… | exception | error | cluster, join, domain-validation, naming |
| The SSO Metadata Address URL scheme can be 'http' or… | validation | warning | sso, config, validation, uri-scheme |
| DnsServer block list zone file version not supported. | exception | error | dns, blocklist, config-file, versioning, serialization |
| No such zone was found: <sourceZoneName or "."> | exception | error | dns, zone-management, clone, not-found, input-validation |
| Failed to add Secondary node: the Cluster is not… | exception | error | cluster, join, validation, not-initialized |
| Group description length cannot exceed 255 characters. | validation | warning | groups, validation, length-limit |
| No lease was found for hardware address | exception | warning | dhcp, lease, runtime-state, scope |
| Failed to add private key: key tag collision. Please try… | exception | error | dnssec, private-key, key-tag, retry, csharp |
| Failed to resolve forwarder domain name for all forwarders | exception | error | forwarder, recursion, name-resolution, bootstrap |
| NSEC3 iterations valid range is 0-50 | validation | error | csharp, dns, dnssec, nsec3, validation, technitium-dns |
| The SSO Client Secret length cannot be more than 255 chars. | validation | warning | sso, config, validation, length-limit, secrets |
| Web Service config version not supported. | exception | critical | dns-server, technitium, configuration, version-mismatch, downgrade, binary-config, csharp |
| Zone already exists: <zoneInfo.DisplayName> | exception | error | dns, csharp, zone-management, duplicate, concurrency, technitium |
| The EdDSA ( ) private key must be for Ed25519 curve. | exception | error | dns, dnssec, crypto, eddsa, ed25519, pem |
| Failed to ask Secondary node to leave: only a Primary node… | exception | error | cluster, authorization, primary-node, leave, rbac |
| Failed to refresh configuration: the Cluster is not… | exception | warning | cluster, precondition, config-refresh, technitium, state-guard |
| Invalid EDNS UDP payload size: valid range is 512-4096… | exception | error | dns, edns, udp, configuration |
| EDNS Client Subnet IPv6 Override must be an IPv6 network… | exception | error | dns, edns, ecs, ipv6, configuration |
| Web server ' ' TLS certificate file must contain a… | exception | error | csharp, tls, certificate, private-key, pkcs12, technitium, block-page-app |
| DHCP Server requires static IP address to work correctly… | exception | error | dhcp, networking, ipv4, startup, static-ip |
| Port 853 is reserved for DNS-over-TLS service. Please use a… | exception | error | dns, network, port, dnsoverhttp, reserved-port, configuration, argumentoutofrange |
| DNS Server TLS certificate file must contain a certificate… | validation | error | tls, certificate, private-key, pkcs12 |
| QPM Prefix Limits for IPv4 cannot have more than 255… | exception | error | dns, qpm, rate-limiting, ipv4, configuration |
| Cannot convert the zone '<currentZoneInfo.DisplayName>'… | exception | warning | dns, zone-management, convert, no-op, input-validation |
| Cannot delete private key: only keys with Generated state… | exception | error | dnssec, private-key, state-precondition, validation, type-guard, csharp |
| Failed to resolve forwarder domain name for all conditional… | exception | error | conditional-forwarder, recursion, name-resolution, zone |
| No such Catalog zone was found | exception | error | dns, catalog-zone, membership, not-found, input-validation |
| Web Service TLS certificate file must contain a certificate… | validation | error | dns-server, technitium, tls, certificate, private-key, pkcs12, csharp |
| Name server addresses cannot have more than 255 entries. | validation | error | dns, notify, zone-transfer, validation, network |
| No 'forwarderAddresses' were configured. | exception | error | csharp, config, json, schema, technitium, advanced-forwarding-app |
| Cannot convert the zone '<currentZoneInfo.DisplayName>'… | exception | error | dns, zone-management, convert, unsupported-type |
| Failed to join Cluster: the Primary Node URL must use the… | exception | error | cluster, dns-names, validation, join, dns-server |
| Port 853 is reserved for DNS-over-TLS service. Please use a… | exception | error | dns, network, port, dnsoverhttps, reserved-port, configuration, argumentoutofrange |
| Scope with overlapping range already exists | exception | error | dhcp, scope, validation, configuration |
| Already logged in. | exception | error | http-api, client, session, state |
| DNS64 prefix can have only the following prefixes: 32, 40… | exception | error | csharp, config, ipv6, dns64, nat64, network, technitium |
| Failed to update Primary node: the Cluster is not… | exception | error | cluster, precondition, update-primary, technitium, state-guard |
| CacheZoneManager format version not supported | exception | error | dns, cache, config-file, versioning, serialization |
| No such primary zone was found | exception | error | dnssec, zone-management, primary-zone, validation |
| is supported only on Windows 11 (build 22000 and later)… | exception | error | quic, libmsquic, platform, runtime, doq |
| Extracting Zip entry would have resulted in a file outside… | exception | error | security, zip-slip, path-traversal, dns-app |
| No active session exists. Please login and try again. | exception | error | http-api, client, session, dashboard, auth |
| The SSO Metadata Address URL length cannot be more than 255… | validation | warning | sso, config, validation, length-limit |
| At least one primary name server address must be specified… | validation | error | dns, secondary-forwarder-zone, name-servers, config, validation |
| Cannot add record: use SetRecords() for | exception | error | dns, record, app, invalidoperation, validation |
| Failed to promote to Primary node: the Cluster is not… | exception | error | cluster, precondition, promote, technitium, state-guard |
| Network ACL cannot have more than 255 entries. | validation | error | dns, acl, network, validation, zone-management |
| Cannot publish DNSKEY: no generated private keys were found. | exception | error | dnssec, private-key, dnskey, validation, type-guard, csharp |
| DnsServer blocked zone file version not supported. | exception | error | dns, blocked-zone, config-file, versioning, serialization |