MyCATApache/Mycat-Server
Documented errors, page 2 of 4. Back to MyCATApache/Mycat-Server
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| SelfCheck### user all node is empty! | exception | critical | config, startup, user, mycat |
| op table not in schema | exception | error | sql, routing, config |
| Sharding column can't be updated: -> | exception | error | upsert, sharding-column, on-duplicate-key |
| Unable to acquire bytes of memory, got | exception | critical | java, memory, out-of-memory, long-array, sorter |
| Could not set field @ | exception | error | reflection, deserialization, type-mismatch |
| datacenter Id can't be greater than | validation | error | snowflake-id, config-validation, argument-out-of-range |
| " find no Route:" + ctx.getSql() | exception | error | mysql, routing, sharding, select |
| : is ignore,no need to migrate! | console | warning | data-migration, data-node, mycat, config |
| user passwrod need to decrype ,but decrype password is… | exception | error | config, password, decryption |
| load crc32slot datafile error:dn= | exception | error | crc32slot, datafile, parse-error, migration |
| nameSuffix , require name parameter cannot multiple breaks! | exception | error | configuration, xml, mutually-exclusive, sharding |
| type not supported yet | exception | error | jdbc, mongodb, resultset, unsupported-feature |
| sequnce not found in db table | exception | error | java, mysql, sequence, missing-row, sql |
| groupPartionSize must >0,but cur is | exception | critical | sharding-config, validation, configuration |
| SelfCheck### user refered schemas is empty! | exception | error | config, startup, mycat, schema |
| table rule duplicated! | exception | error | configuration, xml, duplicate-key, startup |
| 无效的SQL语句 | exception | error | sql, parse-error, druid, routing, invalid-sql |
| Unhandled SQL AST node type encountered: | exception | error | mysql, sharding, sql-ast |
| bufferSize must be a power of 2 | validation | error | java, ringbuffer, illegal-argument, configuration |
| can't find any valid datanode : + tableConfig.getName() + … | exception | error | sql, routing, sharding, partition-function |
| joinKey not provided : + tc.getJoinKey() + , + insertStmt | exception | error | sql, insert, er-join, routing |
| "Parent relevant column can't be updated " + tableName +… | exception | error | mysql, sharding, er-join, update |
| schema: ,table: ,sql: is not allowed,because table is… | exception | error | routing, migration, sql, update-blocked |
| can't find myid properties file | exception | critical | zookeeper, config, io, runtime, mycat |
| Failed to delete: | exception | error | java, filesystem, io |
| can't find table define in schema + tableName + schema: +… | exception | error | sql, routing, join, schema-config |
| Can't find valid data node(s) for some of specified node… | exception | error | sharding, routing, partition, datanode, in-clause |
| Conversion of exceeds Long.MAX_VALUE in . Try a larger… | validation | error | java, byteunit, overflow, conversion |
| SelfCheck### schema all node is empty! | exception | error | config, startup, mycat, null-check |
| You have an error in your SQL syntax; check the manual that… | exception | error | mysql, sql-syntax, date-function |
| Buckets cannot be less than 0 | exception | error | sharding, consistent-hash, configuration |
| can't find table define in schema schema: | exception | error | schema-config, insert-routing, table-not-found |
| columnValue: Please eliminate any quote and non number… | exception | error | number-format, sharding, input-validation |
| SQLNonTransientException(e) from catlet error handling | exception | error | routing, catlet, hint, sql-non-transient |
| writeHost duplicated! | exception | error | configuration, xml, duplicate |
| A batchSize of: with batchStatsAt of: will overrun the… | validation | error | java, ringbuffer, batch, bounds-check |
| bufferSize must not be less than 1 | validation | error | java, ringbuffer, argument-validation |
| failed to connect to zookeeper service | exception | critical | zookeeper, network, connection, curator |
| user duplicated! | exception | error | configuration, xml, duplicate |
| please check tableFile.properties,make sure | exception | error | java, configuration, data-migration, sharding |
| the select proess err ,the SelectResponse is empty | exception | error | postgresql, protocol, select, desync |
| cannot get the slaveID for dataHost | exception | error | migration, zookeeper, slave, concurrency, lock |
| no rule is found | exception | error | config, null-argument, sharding |
| Packet size over the limit. | validation | error | mysql-protocol, packet-size, network, configuration |
| all columns in group by clause should be in the selected… | exception | error | sql, group-by, mpp-merge |
| can't find any valid datanode : -> -> | exception | error | sql, sharding, routing, datanode |
| Cannot construct as it does not have a no-args constructor | exception | error | reflection, constructor, instantiation |
| invalid table subTables | exception | error | config, mycat, subtables, invalid-argument |
| offer data error! | exception | error | nio, executor, backpressure, mysql |
| There is no space for new record | exception | error | sorting, memory-management, capacity |
| Can't find a valid data node for specified node index : +… | exception | error | sql, routing, sharding, config-mismatch |
| [user: ] doesn't exist in [host: ] | exception | error | configuration, firewall, user |
| can't find table define in schema | exception | error | sql, routing, config |
ERR_HANDLE_DATA e.toString() | error_code | error | session, execution, backend, generic-exception |
| writeNotSend but found connnection close err | exception | error | connection-closed, nio, network, write |
| bad insert sql (sharding column: not provided, | exception | error | insert, sharding-column, missing-column |
| ChildTable multi insert not provided | exception | error | er-table, insert, batch, unsupported-operation, child-table |
| number of values and columns have to match | exception | error | mongodb, sql, insert, validation, argument-mismatch |
| Parent relevant column can't be updated -> | exception | error | mysql, sharding, er-join-key |
| Constructor for threw an exception | exception | error | reflection, constructor, wrapped-exception |
| In case of slice table,sql have different rules,the… | exception | error | sql, subquery, sharding |
| Cannot find class | exception | error | class-not-found, serialization, classloader |
| MyCAT Server Channel has been closed | exception | error | aio, network, server-shutdown, accept |
| only one rule can defined | exception | error | configuration, xml, unsupported-operation, sharding |
| rehashNodeDir must be a directory | exception | error | configuration, filesystem, rehash, illegal-argument |
| Initial capacity exceeds maximum capacity of | validation | error | java, memory, illegal-argument, configuration |
| fetching sequence can not support the db driver | exception | error | java, mysql, sequence, jdbc, unsupported |
| Have already allocated a maximum of | exception | error | java, memory, page-table, resource-leak, illegal-state |
| n must be > 0 | validation | error | java, ringbuffer, argument-validation |
| In case of slice table,sql has different rules,currently… | exception | error | sql, subquery, sharding |
| invalid sql: + origSQL | exception | error | mysql, routing, insert, sql-syntax |
| Unexpected exception | exception | error | jdbc, mongodb, driver, connection, url |
| clusterId and zkURL and myid must not be null or empty! | exception | critical | zookeeper, config, validation, missing-keys, mycat |
| String length must be a multiple of four. | validation | error | java, base64, decoding |
| error while calling spill() on | exception | critical | java, memory, spill, out-of-memory, io |
| illegal hex-string | exception | error | parsing, hex, validation |
| MySQL replication stream is already open | exception | error | mysql, binlog, replication, illegal-state |
| number of columns error | exception | error | mongodb, sql, insert, validation |
| joinKey not provided : | exception | error | insert, child-table, join-key |
| table duplicated! | exception | error | config, xml, duplicate-key, child-table |
| partition table, insert must provide ColumnList | exception | error | insert, sharding, missing-column-list |
| You have an error in your SQL syntax, don't support lock… | exception | error | sql, lock, unsupported, syntax |
| all columns in order by clause should be in the selected… | exception | error | sql, order-by, mpp-merge |
| Log already in use? in | exception | error | xa, file-lock, startup, concurrency |
| not found schema : | exception | error | schema, configuration, show |
| sql 注释 语法错误 | exception | error | sql, comment, parser |
| newSchema: is not exists! | exception | error | java, configuration, data-migration, schema |
| "bad insert sql (sharding column:"+ partitionColumn + " not… | exception | error | sql, mycat, sharding, insert |
| tablesFile.properties read fail! | exception | error | java, configuration, data-migration, classpath |
| slaveIds range must be 2 size | exception | error | migration, parsing, invalid-input |
| "lock type must be write or read" | exception | error | mysql, routing, lock-tables, unsupported-syntax |
| Page size cannot exceed | validation | error | java, memory, illegal-argument, configuration |
| readHost duplicated! | exception | error | configuration, xml, duplicate |
| "can't find any valid datanode :" + tableName + " -> " +… | exception | error | sql, mycat, sharding, partitioning |
| can't find hint datanode | exception | error | sql, hint, datanode, routing |
| load crc32slot datafile error:dn=value= | exception | error | migration, parsing, crc32slot, format |
| in noSharding mode schema must have default dataNode | exception | critical | config, mycat, schema, sharding |
| multi table related update not supported,tables: | exception | error | mysql, sharding, sql-routing |
| Unknown packet | exception | error | postgresql, protocol, packet, parser |
| dataHost: do not config the salveIDs field | exception | error | migration, config, zookeeper, slave, datanode |