Billionmail/BillionMail
Documented errors, page 2 of 5. Back to Billionmail/BillionMail
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| download error | http | error | http, http-status, lipsync, expired-url |
| failed to get validate code | exception | error | captcha, validation-code, login, redis |
| Failed to set Alibaba Cloud DNS verification | exception | error | acme, dns-01, alidns, credentials |
| Failed to set Cloudflare DNS verification | exception | error | acme, dns-01, cloudflare, credentials |
| lipsync API error | http | error | http, api-error, lipsync, third-party |
| create download request | error_code | error | url, validation, http-request, lipsync |
| create output file | error_code | error | filesystem, io, permissions, disk-full |
| Failed to create directory | exception | error | filesystem, ssl, certificate, mkdir |
| invalid data length | exception | error | encryption, aes, data-corruption |
| lipsync API call | error_code | error | network, http-client, timeout, lipsync |
| Logout failed | exception | error | jwt, logout, redis, token-blacklist |
| postfix-billionmail service not found | exception | error | |
| alert settings file not found | exception | warning | configuration, filesystem, blacklist |
| error saving project configuration | exception | error | go, file-io, config |
| failed to query relay domain mappings | exception | error | database, sql, relay, dkim, migration |
| group not exists: | exception | error | |
| error reading knowledge base file | exception | error | go, file-io, knowledge-base |
| error saving company profile | exception | error | |
| error saving empty site map file | exception | error | go, file-io, filesystem, permissions |
| resolve failed | exception | error | dns, network, blacklist |
| circuit breaker [ ] | error_code | error | circuit-breaker, http, resilience, network |
| marshal lipsync request | error_code | error | json, serialization, lipsync, video-gen |
| no default jwt secret found | panic | critical | jwt, security, environment, startup |
| task : update database threads failed | exception | error | database, write-failure, wrapped-error, batch-mail |
| create status request | error_code | error | http, url, lipsync, jobid |
| http get error | http | error | |
| rspamdadm not found | error_code | error | rspamd, docker, exec, mail |
| error saving default footer config file | exception | error | go, filesystem, permissions, config, footer, askai |
| failed to restart dovecot container | exception | error | docker, container, dovecot, mail-service |
| reconnect failed | exception | error | smtp, reconnect, retry, connection |
| error reading knowledge base directory | exception | error | go, filesystem, io, directory |
| failed to import recipients | exception | error | database, insert, batch |
| failed to write postfix master config | exception | error | postfix, file-write, permissions, tls |
| get task info failed | exception | error | database, wrapped-error, batch-mail |
| certificate not found in database | exception | error | database, ssl, certificate, mail-service |
| DNS verification setup failed | exception | error | dns, acme, dns01, challenge, lego |
| failed to write temporary output file | exception | error | filesystem, disk, docker-compose, go |
| failed to check alias existence | exception | error | database, postgresql, alias |
| illegal file path: | exception | critical | go, compression, gzip, path-traversal, security |
| rar file was not created successfully | exception | error | go, compression, rar, file-not-found, external-command |
| failed to get account | error_code | critical | database, postgres, rbac, auth |
| DNS automated resolution failed: APIKey or SecretKey is… | validation | error | dns, acme, alidns, missing-credentials, config |
| DNS provider initialization failed | exception | error | dns, acme, tencentcloud, provider-init, config |
| error getting prompt config | exception | error | json, config, io, go |
| Prefix validation error | exception | error | go, regex, validation |
| Prefixes can contain only letters, numbers, underscores… | validation | error | go, validation, input |
| error reading knowledge base | exception | error | go, filesystem, json, not-found |
| failed to create backup for | exception | error | filesystem, permissions, backup, go |
| Failed to save certificate file | exception | error | filesystem, ssl, certificate, file-write |
| failed to get option from database: | error_code | critical | database, postgres, options |
| error reading images configuration file | exception | error | filesystem, io, config-persistence |
| file not exists: | error_code | error | filesystem, file-not-found, chown |
| local IP not found | error_code | error | network, ip-detection, environment, go |
| invalid certificate | exception | error | acme, certificate, validation, pem |
| failed to read CSV headers | validation | error | csv, file-upload, parsing |
| SMTP close writer | exception | error | smtp, end-of-data, email-delivery |
| docker.sock not mounted, cannot access Docker API | exception | error | docker, deployment, socket |
| new SMTP client | exception | error | smtp, tls, protocol |
| let's encrypt certificate is empty | exception | error | acme, certificate, renewal, empty-value |
| Failed to create ACME client | exception | error | go, acme, lego, private-key, client-init |
| error saving prompt config file | exception | error | filesystem, io, permissions, go |
| Failed to create email | exception | critical | go, database, transaction, batch |
| specified user not valid | exception | error | |
| Unsupported DNS provider | validation | error | acme, dns-01, validation, unsupported-provider |
| no scenes provided | validation | error | ffmpeg, validation, video-gen, empty-input |
| alert settings file is empty | exception | warning | configuration, filesystem, json |
| No SPF record found (from cache) | exception | error | dns, spf, cache, negative-caching |
| write video data | error_code | error | network, io, download, truncated-file |
| unrar extraction failed | exception | error | go, compression, rar, external-command, process-exit-error |
| DNS automated resolution failed: APIKey or Email is empty… | validation | error | dns, acme, cloudflare, missing-credentials, config |
| %s | exception | error | smtp, network, relay |
| write audio data | exception | error | io, network, filesystem, partial-write |
| DNS automated resolution failed: ClientID, ClientSecret or… | validation | error | go, acme, dns, azure, missing-credentials |
| failed to load contacts | exception | error | database, postgresql, query |
| failed to update BILLIONMAIL_HOSTNAME in postfix container | exception | error | docker, postfix, exec, container |
| Invalid operator: | panic | error | panic, validation, versioning, go |
| the recipient has unsubscribed from the current group and… | validation | error | docker-compose, multi-ip, yaml, type-assertion |
| configuration value too long, maximum 1024 characters | validation | error | validation, settings, input-length |
| error saving knowledge base | exception | error | go, filesystem, io, persistence |
| Failed to generate user private key | exception | critical | crypto, acme, entropy, tls |
| read dovecot.conf failed | exception | error | filesystem, dovecot, read-failure |
| error reading company profile file | exception | error | go, filesystem, io, permissions |
| Failed to generate DKIM key pair | exception | error | docker, dkim, rspamd, key-generation, exec |
| failed to unmarshal tool call arguments | exception | error | go, json, llm, streaming, tool-calls |
| account ID not found in context | error_code | error | auth, context, rbac |
| failed to parse alert settings | exception | warning | json, configuration, parsing |
| SMTP dial | exception | error | network, smtp, dial, tcp |
| annotate | error_code | error | imagemagick, batch-processing, video-gen, exec |
| error saving style config file | exception | error | |
| error saving company profile file | exception | error | |
| failed to connect to SMTP server | exception | error | smtp, email, network |
| invalid port: | error_code | error | validation, firewall, ports, go |
| private key data is empty | validation | error | tls, certificate, private-key, validation |
| create clone request | error_code | error | http, url, cartesia, config |
| failed to apply configurations, but rollback succeeded | exception | error | configuration, rollback, postfix |
| failed to create zip entry for | http | error | zip, archive, export |
| SMTP rcpt | exception | error | smtp, email-delivery, relay-denied |
| Failed to connect to Docker API | exception | error | docker, dkim, connection, socket |
| No log files found | http | warning | filesystem, logs, not-found |
| decode lipsync response | error_code | error | json, decoding, lipsync, third-party |