ErrLookup › openzipkin/zipkin
openzipkin/zipkin
Zipkin is a distributed tracing system · Java · 358 source files
Analyzed at 878ce2a1fa on 2026-08-14. 133 documented errors.
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| reading from json | exception | error | zipkin, json, decoding, span |
| Invalid .version.number | exception | error | elasticsearch, opensearch, version-detection, configuration, storage |
| credential refresh thread didn't start | exception | critical | zipkin, elasticsearch, credentials, scheduler, startup |
| query unsupported due to missing annotation_query index | exception | error | zipkin, cassandra, schema, query, annotation-index |
| Start bucket ( ) > end bucket ( ) | exception | error | zipkin, cassandra, query, timestamp, validation |
| should be a 1 to 32 character lower-hex string with no… | exception | error | zipkin, hex, codec, number-format, validation |
| No content reading cluster health | exception | error | elasticsearch, health-check, proxy, cluster-health, storage |
| no property in | exception | critical | zipkin, elasticsearch, credentials, properties-file, configuration |
| Failed to archive the trace | exception | error | typescript, zipkin-lens, http, archive, status-code, bug |
| remoteService= unsupported due to missing table… | exception | error | zipkin, cassandra, schema, remote-service, query |
| Could not detect the span format | exception | error | zipkin, codec, decode, format-detection |
| Expected start object, was | exception | error | elasticsearch, json-parsing, client, proxy, configuration |
| dateSeparator must be empty or a single character | validation | error | zipkin, elasticsearch, index-naming, configuration, validation |
| v2 formats should only be used with list messages | exception | error | zipkin, codec, decode, proto3, json-v2 |
| category == null | validation | error | zipkin, scribe, collector, null-check, configuration |
| Pulsar Client is unable to subscribe to the topic | exception | critical | pulsar, zipkin, subscription, topic, permissions |
| Pulsar client creation failed. | exception | critical | pulsar, zipkin, connection, configuration, runtime-exception |
| id is all zeros | exception | error | zipkin, span, span-id, validation, builder |
| Attempting to make a blocking request from an event loop… | exception | critical | elasticsearch, armeria, event-loop, deadlock-prevention, async |
| Unable to establish connection to RabbitMQ server | exception | critical | rabbitmq, zipkin, connection, io, amqp |
| No valid endpoints found in ES hosts | exception | critical | zipkin, elasticsearch, endpoints, configuration, startup |
| Malformed: fieldNumber was zero at byte | exception | error | zipkin, protobuf, malformed, decoding |
| input is not a list | validation | error | zipkin, javascript, validation, trace-data |
| Could not load Lens UI from | exception | error | zipkin, ui, lens, classpath, startup |
| key == null | validation | error | mysql, autocomplete, null-check, api-contract, storage |
| clientProps is empty | validation | error | pulsar, zipkin, builder, validation, configuration |
| Not a valid JSON object, start token | exception | error | elasticsearch, json-parsing, span, deserialization |
| Cannot gunzip spans | http | error | zipkin, collector, gzip, http, payload |
| Session initialization failed. See server logs | exception | critical | cassandra, zipkin, session, startup, schema, connection |
| empty property in | exception | critical | zipkin, elasticsearch, credentials, validation, configuration |
| endTs <= 0 | validation | error | zipkin, query, validation, api |
| Elasticsearch versions 5-9.x are supported, was | exception | error | elasticsearch, version-compatibility, index-templates, configuration, storage |
| Expected json, proto3 or thrift list encoding | exception | error | zipkin, codec, decode, validation |
| should be lower-hex encoded with no prefix | exception | error | zipkin, trace-id, span-id, hex, validation |
| Expected json or thrift object, not list encoding | exception | error | zipkin, codec, decode, json, thrift |
| Health status couldn't be read | exception | error | elasticsearch, health-check, authentication, json-parsing, storage |
| calls were empty | exception | error | zipkin, storage, aggregate, validation |
| Timeout establishing connection to RabbitMQ server | exception | critical | rabbitmq, zipkin, timeout, network, amqp |
| Missing : | exception | error | core, dependency-link, builder, illegal-state, validation |
| ttl <= 0 | exception | error | zipkin, internal, delay-limiter, validation, builder |
| Don't use test data that results in indeterministic… | validation | error | testing, assertion, test-data, ordering, determinism |
| v1 format is not supported. For help, contact… | validation | error | zipkin, javascript, validation, data-format, v1-migration |
| Already Executed | exception | error | core, call, one-shot, illegal-state, retry |
| autocompleteTtl <= 0 | validation | error | zipkin, cassandra, autocomplete, ttl, configuration |
| empty trace ID | exception | error | zipkin, span, trace-id, validation, builder |
| The distribution version is not supported | exception | error | internal, factory, distribution, fork-hazard, elasticsearch |
| reading from proto3 | exception | error | zipkin, protobuf, decoding, span |
| Trace is missing a timestamp | exception | error | zipkin, javascript, trace-data, timestamp |
| ttlUnit == null | exception | error | zipkin, internal, delay-limiter, null-pointer, builder |
| keys == null | validation | error | zipkin, cassandra, autocomplete, null-check, builder |
| Could not connect to storage, skipping test | exception | info | testing, integration-tests, test-aborted, connectivity, ci |
| localDc == null | validation | error | zipkin, cassandra, datacenter, null-check, builder |
| spans were empty | validation | error | zipkin, trace-tree, validation |
| Greater than 32-bit varint at position | exception | error | zipkin, varint, protobuf, malformed |
| Malformed: invalid wireType | exception | error | zipkin, protobuf, malformed, wire-type |
| Maximum skip depth exceeded | exception | error | zipkin, thrift, security, malformed |
| autocompleteCardinality <= 0 | validation | error | zipkin, cassandra, autocomplete, cardinality, configuration |
| remoteService= unsupported due to missing column… | validation | error | mysql, storage, schema, migration, remote-service-name, illegal-argument |
| Canceled | exception | error | core, call, cancellation, io-exception, concurrency |
| concurrency < 1 | validation | error | pulsar, zipkin, builder, validation, concurrency |
| indexFetchMultiplier <= 0 | validation | error | cassandra, zipkin, builder, validation, query-tuning |
| Cannot read keyspace metadata for keyspace | exception | critical | cassandra, zipkin, keyspace, metadata, configuration |
| bootstrapServers == null | exception | error | kafka, zipkin, builder, null-check, configuration |
| connectionFactory == null | exception | error | rabbitmq, zipkin, builder, null-check, amqp |
| invalid port | exception | error | core, endpoint, port, illegal-argument, validation |
| Incomplete annotation at | exception | error | elasticsearch, json-parsing, annotation, validation, span |
| datasource == null | validation | error | mysql, storage, builder, null-pointer, datasource, configuration |
| parentId is empty | exception | error | zipkin, span, parent-id, validation, builder |
| sessionFactory == null | validation | error | cassandra, zipkin, builder, null-check, configuration |
| reading from TBinary | exception | error | zipkin, thrift, decoding, legacy |
| keyspace == null | validation | error | zipkin, cassandra, keyspace, null-check, configuration |
| maxSpanCount <= 0 | validation | error | zipkin, configuration, in-memory-storage |
| hex field greater than 32 chars long | exception | error | zipkin, protobuf, trace-id, malformed |
| schema lacks indexing: apply | exception | critical | cassandra, zipkin, schema, upgrade, indexing |
| Expected start of dependency link object but was | exception | error | elasticsearch, json-parsing, dependency-link, schema, storage |
| metrics == null | exception | error | zipkin, java, activemq, collector, configuration |
| schema not installed: apply | exception | critical | cassandra, zipkin, schema, startup, configuration |
| Invalid .version.number | exception | critical | elasticsearch, opensearch, zipkin, version-parsing, compatibility |
| logger == null | exception | warning | zipkin, java, collector, internal, logging |
| consumerProps is empty | validation | error | pulsar, zipkin, builder, validation, configuration |
| rate should be between 0 and 1: was | validation | error | zipkin, java, collector, sampling, configuration, validation |
| traceId == null | exception | error | zipkin, trace-id, null-pointer, validation |
| Truncated: length > bytes available | exception | error | zipkin, truncated, transport, decoding |
| has an invalid port | validation | error | cassandra, zipkin, port, contact-points, validation |
| traceId is all zeros | exception | error | zipkin, trace-id, validation |
| contactPoints == null | validation | error | zipkin, cassandra, contact-points, null-check, configuration |
| serviceNameSuffix == null | validation | error | testing, test-helpers, null-pointer, zipkin-tests |
| maxConnections <= 0 | validation | error | zipkin, cassandra, connection-pool, configuration, validation |
| transportType == null | exception | error | zipkin, java, metrics, collector, configuration |
| loggingClass == null | exception | error | zipkin, java, collector, builder, logging |
| OpenSearch versions 1-3.x are supported, was | exception | error | opensearch, version-compatibility, index-templates, configuration, storage |
| empty id | exception | error | zipkin, span, span-id, validation, builder |
| End of input while parsing object. | exception | error | elasticsearch, json-parsing, truncated-input, span, deserialization |
| Malformed: invalid boolean value at byte | exception | error | zipkin, protobuf, boolean, malformed |
| Failed to execute [ ] | exception | critical | cassandra, zipkin, schema, cql, permissions |
| .version.number not found in response | exception | critical | elasticsearch, opensearch, zipkin, version-detection, response-parsing |
| node had no version | exception | error | cassandra, zipkin, version, cluster-metadata, driver |
| Greater than 64-bit varint at position | exception | error | zipkin, varint, protobuf, malformed |
| Invalid span, expecting annotations array start, got | exception | error | elasticsearch, json-parsing, span, schema, deserialization |
| topic is null or empty | validation | error | pulsar, zipkin, builder, null-check, topic |