ErrLookup › openimsdk/open-im-server

openimsdk/open-im-server

IM Chat OpenClaw · Go · 403 source files

Analyzed at 175a7bb067 on 2026-09-04. 31 documented errors.

Code / MessageTypeSeverityTags
error (dynamic message passed to http.Error)
http warning http, websocket, error-handling, msggateway
config field not found
validation error configuration, reflection, startup
ReqIdentifier failed,sendID
exception error websocket, protocol, client-server
topic groupID not found
exception error kafka, consumer-group, configuration, mq
failed to create in-cluster config
exception error kubernetes, service-discovery, configuration
listener done
exception warning prometheus, metrics, lifecycle
rpcPorts index out of range
exception error config, startup, grpc, ports
jpush push failed
exception error push-notifications, jpush, third-party-api
failed to create clientset
exception critical kubernetes, configuration, initialization
failed to dial endpoint
exception error grpc, kubernetes, network
standalone api port is 0
validation error configuration, grpc, startup, standalone
code , msg
exception error push-notifications, getui, third-party-api
invalid object enable
validation error configuration, object-storage, startup
prommetrics
exception warning prometheus, metrics, context-cancel
size must be greater than 0
validation error validation, mongodb, sequence
values length is too large, causing overflow
validation error redis, lua, memory-limit, batching
prometheus listen error
exception error network, prometheus, port-conflict, startup
user not found
exception error database, data-consistency, friends
failed to initialize connections for service
exception error kubernetes, grpc, service-discovery
rpc register
exception error grpc, service-discovery, registry, startup
serve end
exception error grpc, lifecycle, shutdown
signal
exception info signal, shutdown, lifecycle
topic not found
exception error kafka, messaging, config, topic
failed to get endpoints for service
exception error kubernetes, network, rbac
rpc
exception error grpc, startup, lifecycle
service has no ports defined
exception error kubernetes, configuration, manifest
no command to run
validation error cli, startup, configuration
nil kafka config
validation error config, kafka, messaging, missing-config
failed to get service
exception error kubernetes, rbac, service-discovery
listen rpc
exception error network, grpc, bind, ports
unsupported queue engine
validation error config, messaging, validation