ErrLookup › alibaba/druid
alibaba/druid
阿里云计算平台DataWorks(https://help.aliyun.com/document_detail/137663.html) 团队出品,为监控而生的数据库连接池 · Java · 1,753 source files
Analyzed at fa8dc99126 on 2026-08-14. 52 documented errors.
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| load managed jdbc driver event listener error. | exception | error | filter, reflection, instantiation, configuration |
| minIdle must >= 0 | validation | warning | datasource, pool-sizing, validation, bug |
| validationQuery failed | exception | error | datasource, connection-validation, validation-query, configuration |
| Config DataSource error. | exception | error | config-filter, properties, configuration, datasource |
| Not supported by HighAvailableDataSource. | exception | error | ha-datasource, unsupported-operation, authentication, jdbc |
| Failed to decrypt. | exception | error | config-filter, encryption, rsa, password, configuration |
| create driver instance error, driver className ' | exception | error | driver-loading, access-control, reflective-access, configuration |
| jdbc-driver's class not found. | exception | error | driver-loading, classpath, proxy-driver, configuration |
| create driver instance error, driver className | exception | error | driver-loading, instantiation, configuration, jdbc |
| validateConnection: connection closed | exception | info | datasource, connection-validation, pool-operation, network |
| xa not support dbType | exception | error | xa, datasource-configuration, dbtype, jdbc |
| {className} | exception | error | datasource, stat-logger, reflection, configuration |
| not support | exception | warning | statement, unsupported-operation, jdbc, orm-interop |
| Error | exception | error | exception-wrapping, non-sqlexception, filter, connection-pool, diagnostics |
| validationQuery didn't return a row | exception | error | validation, connection-pool, config, keepalive |
| wait millis , active , maxActive , creating | exception | critical | getconnection-timeout, connection-pool, create-error, chained-cause, database-connectivity |
| connection holder is null | exception | error | holder-null, concurrency, lifecycle, connection-pool, race |
| create exceptionSorter error | exception | error | datasource, exception-sorter, reflection, configuration |
| onFatalError, activeCount | exception | critical | circuit-breaker, fatal-error, database-outage, connection-pool, exception-sorter |
| Not supported by DruidDataSource | exception | error | xa, unsupported-operation, authentication, jdbc |
| statement is closed | exception | error | statement, closed-handle, connection-pool, jdbc |
| Failed to get public key | exception | error | config-tools, x509, certificate, io, encryption |
| ZK Client is NULL, Please set the zkConnectString. | exception | error | ha-datasource, zookeeper, configuration, node-listener |
| keepAliveBetweenTimeMillis must be greater than… | exception | error | config, keepalive, eviction, timing, init, validation |
| getStatData error | exception | warning | jmx, monitoring, stats, lifecycle, diagnostics |
| check connection info failed | exception | error | config, credentials, connection, runtime-reconfig |
| maxWaitThreadCount , current wait Thread count | exception | error | backpressure, connection-pool, capacity, getconnection, config |
| No Observer(such as PoolUpdater) specified. | exception | error | ha-datasource, node-listener, configuration, observer-pattern |
| connect error, url , driverClass | exception | critical | connection, driver, config, classloader |
| maxEvictableIdleTimeMillis must be grater than… | validation | warning | datasource, eviction, validation, configuration |
| not support oracle driver | exception | error | oracle, driver, version, init, compatibility |
| Cannot load remote config file from the | exception | error | config-filter, config-file, io, configuration |
| minIdle greater than maxActive | validation | error | datasource, pool-sizing, validation, configuration |
| Please set the ZooKeeper node path. | exception | error | ha-datasource, zookeeper, configuration, node-listener |
| dataSource already closed at | exception | critical | lifecycle, closed, shutdown, connection |
| maxActive less than minIdle | validation | error | config, pool-sizing, properties, validation |
| connection disabled | exception | error | connection-disabled, validation, fatal-error, connection-pool, chained-cause |
| Please set the urlTemplate. | exception | error | ha-datasource, zookeeper, configuration, node-listener |
| ConfigLoader only support DruidDataSource | exception | error | config-filter, type-check, datasource, configuration |
| timeBetweenLogStatsMillis not support… | validation | error | config, monitoring, stats, init, validation |
| interrupt | exception | error | lifecycle, threading, interrupt, init |
| dataSource inited. | validation | error | config, lifecycle, scheduler, init-order |
| connection closed | exception | error | connection-closed, fatal-error, lifecycle, connection-pool, chained-cause |
| driverClassName length > 256. | validation | error | datasource, driver, validation, configuration |
| can not restart, activeCount not zero. | exception | error | lifecycle, restart, connection-leak, pool-state |
| url not set | exception | critical | config, driver, init, missing-config |
| illegal initialSize , maxActive | validation | error | config, pool-sizing, init, warmup, validation |
| illegal maxActive | validation | error | config, pool-sizing, init, validation |
| timeBetweenEvictionRunsMillis must > 0 | validation | error | datasource, eviction, validation, configuration |
| toCount can't not be less than zero | validation | warning | validation, fill, argument-check, config, programming-error |
| logger can not be null | validation | warning | validation, stat-logger, argument-check, config, monitoring |
| maxActive can't not set zero | validation | error | config, pool-sizing, validation |