ErrLookup › abiosoft/colima
abiosoft/colima
Container runtimes on macOS (and Linux) with minimal setup · Go · 97 source files
Analyzed at c3a5f9184d on 2026-08-15. 262 documented errors.
| Code / Message | Type | Severity | Tags |
|---|---|---|---|
| error parsing disk mount script template | panic | critical | template, panic, disk, lima |
| error retrieving embedded vmnet file | exception | error | vmnet, embedded, build, packaging |
| error encoding yaml file | exception | error | yaml, encoding, internal, node-tree |
| error in config | validation | error | config, validation, flags, macos |
| error executing template | exception | error | template, go-template, runtime, fields |
| runtime disk provisioned for | exception | error | disk, runtime, colima, state, containerd, docker |
| error parsing template | exception | error | template, go-template, syntax, parsing |
| error validating SHA sum for | exception | error | sha, integrity, download, cache |
| unexpected error during yaml decode: doc has multiple… | exception | error | yaml, multi-document, embedded, internal |
| failed to read model manifest | exception | error | docker, model-runner, manifest, container-exec |
| error traversing yaml node | exception | error | yaml, traversal, embedded, internal |
| unable to disable qemu x86_84 emulation | console | warning | rosetta, qemu, binfmt, apple-silicon, colima, non-fatal |
| uneven children of found for mapping node | exception | error | yaml, mapping, validation, embedded |
| error getting terminal size | exception | warning | terminal, tty, io, cli |
| krunkit not found in $PATH\nInstall with: brew tap… | exception | error | dependency, qemu, homebrew, macos, path |
| error preparing vmnet | exception | error | filesystem, daemon, permissions, startup |
| error reading config file | exception | error | yaml, embedded, build, binary-corruption |
| error saving template | exception | error | filesystem, permissions, template, save |
| error watching directory recursively | console | warning | inotify, fsevents, watcher, filesystem |
| error picking an available port | console | critical | network, ports, fatal, resource-exhaustion |
| ' ' cannot be updated after initial setup, discarded | console | warning | config, fixed-settings, lifecycle, warning |
| unexpected error during yaml node traversal | exception | error | yaml, internal, invariant, rare |
| cannot copy registry certs to vm | console | warning | docker, registry, certificates, vm, non-fatal |
| embedded default config is invalid yaml | exception | error | yaml, embedded, corruption, internal |
| error getting disk image details | exception | error | disk-image, architecture, runtime, colima, metadata |
| invalid directory | console | warning | inotify, paths, filesystem |
| error sanitising mount path for inotify | exception | error | mounts, inotify, configuration, paths |
| error decoding docker response | console | warning | json, parsing, docker, error-wrapping |
| error setting up inotify dependencies | exception | error | inotify, daemon, mounts, vm, network |
| unable to read embedded file | console | warning | embedded-assets, build, editor |
| unexpected status code | http | error | network, http, github-api, rate-limit, go |
| error backing up kubeconfig | exception | error | kubeconfig, kubernetes, permissions, backup, host |
| error occurred installing dependencies for | exception | error | dependencies, sudo, installation, vmnet |
| error starting | console | warning | network, vmnet, daemon, per-process, non-fatal |
| cannot read file | exception | error | file-read, guest, ssh, colima, filesystem |
| error running watcher | console | warning | inotify, watcher, logging, goroutine |
| error finalizing download | exception | error | filesystem, cache, rename, permissions |
| unable to resize disk | console | warning | disk, resize, qemu-img, colima, non-fatal |
| unexpected error nested value encoding | exception | error | yaml, reflection, config, types |
| error encoding YAML | exception | error | yaml, serialization, types |
| relative paths not supported for mount | validation | error | mounts, paths, validation, filesystem |
| error writing yaml file | exception | error | yaml, filesystem, permissions, disk-full |
| error setting up DNS | exception | error | dns, post-start, wrapper, colima, guest |
| error running , output: , err | exception | error | host, exec, command-failure, wrapper, cli |
| ' ' overlaps | validation | error | lima, mounts, configuration, vm, filesystem |
| error initiating container runtime | exception | error | runtime, container, docker, containerd, go |
| failed to start port forwarder | exception | error | socat, port-forwarding, network, docker |
| no editor found in $PATH, kindly set $EDITOR environment… | exception | error | editor, environment, cli, interactive |
| error applying nerdctl script template | exception | error | go, colima, nerdctl, template, internal |
| error creating directory | exception | error | file-write, guest, ssh, filesystem, colima |
| error during Lima prune | exception | error | colima, lima, cache, prune, subprocess |
| daemon is not running | exception | error | daemon, vm, retry, startup, lima |
| process not found | exception | error | go, colima, daemon, portability, process |
| error creating runtime disk | exception | error | disk, lima, storage, vm, provisioning |
| error retrieving home directory | console | critical | environment, home, fatal, process-exit |
| minimum Lima version supported is | exception | error | lima, version-check, dependencies, startup |
| config load failed | console | warning | config, yaml, corruption, defaults-fallback |
| error in config file | validation | error | colima, config, yaml, validation, startup |
| error stopping | exception | error | lifecycle, lima, restart, vm |
| error closing temporary port listener | console | critical | network, fatal, file-descriptors, rare |
| error during prune | exception | error | colima, cache, filesystem, permissions, prune |
| nerdctl only supports | validation | error | colima, nerdctl, containerd, runtime, cli |
| cannot truncate file for fresh download | exception | error | download, resume, filesystem |
| error running provision script(s) | console | warning | provisioning, scripts, yaml, vm |
| failed to fetch releases | exception | error | network, github-api, http, ramalama, proxy |
| invalid pid | exception | error | go, colima, daemon, pidfile, parsing |
| no models available Pull a model first: colima model pull… | validation | error | colima, llm, model-runner, docker, cli |
| unable to assign host IP addresses to the VM | console | warning | network, vm, ip-address, startup, host-addresses |
| error encoding kubernetes config to json | exception | error | kubernetes, json, serialization, internal |
| error creating temp file | exception | error | filesystem, temp-files, disk-space, vmnet |
| not found, run 'brew install ' to install | exception | error | dependencies, host, path, homebrew, install-check |
| unable to enable rosetta | console | warning | rosetta, apple-silicon, vz, binfmt, colima, non-fatal |
| cannot restart, VM not previously started | exception | error | restart, lifecycle, state, colima, profile |
| error retrieving current runtime: empty value | exception | error | runtime, vm, guest-agent, colima, go |
| failed to write dnsmasq config | exception | error | dns, dnsmasq, guest, filesystem, colima |
| failed to create dnsmasq config directory | exception | error | dns, dnsmasq, guest, ssh, colima |
| error preparing config file | exception | error | config, filesystem, permissions, save-config |
| no IP address assigned to network interface | exception | error | kubernetes, k3s, network, lima, dhcp, vm |
| error copying VM config | exception | error | clone, filesystem, known-issue, colima |
| error editing config file | exception | error | editor, interactive, environment, edit |
| error setting up network dependencies | console | warning | network, vmnet, daemon, non-fatal, permissions |
| error watching container volumes | exception | error | inotify, runtime, daemon, configuration |
| could not check for updates | exception | error | network, github-api, updates, rate-limit, transient, go |
| inotify not running | exception | warning | inotify, status, daemon |
| error writing temp file | exception | error | disk-space, filesystem, temp-files, vmnet |
| not running | exception | error | lifecycle, state, guest, environment-variables, colima |
| empty file, startup aborted | exception | error | editor, abort, edit, ux |
| cannot fetch required directory | console | critical | environment, filesystem, fatal, home-directory |
| could not start docker-model-runner after 3 attempts | exception | error | docker, model-runner, retry, startup |
| empty runtime | validation | error | inotify, runtime, validation |
| lima compatibility error | validation | error | version-check, lima, dependency, pre-run |
| unable to enable qemu | console | warning | binfmt, qemu, emulation, guest, colima, non-fatal |
| error in template | exception | error | yaml, template, validation, edit |
| failed to decode response | exception | error | json, parsing, proxy, network, go |
| curl download failed for | exception | error | download, network, curl, retry, tls, go |
| error checking vmnet process | exception | error | colima, vmnet, pidfile, process-check, macos, daemon |
| failed to restart dnsmasq service | exception | error | dns, dnsmasq, systemd, guest, colima |
| error extracting vmnet archive | exception | error | colima, vmnet, tar, sudo, macos, installation |
| error resolving download URL | exception | error | network, http, download, retry |
| failed to write resolv.conf | exception | error | dns, resolv-conf, guest, colima, filesystem |